Is there a straightforward, simple, clear, tested and proven way to install a bug-free version of Lucee anymore?

Good evening. I’ve been developing with CFML for about 20 years, so I am not a newbie. But, I truly hate server configuration stuff.

I’ve been trying to get a Lucee server up and running on an Ubuntu 22.04 AWS instance. I have used the nice video guides by Andreas, I have tried using CommandBox. I have tried using the now very outdated ubuntu-nginx-lucee scripts. I have tried standalone Lucee. I have tried to have GPT guide me through an install. I have tried just every single thing I can try and find online. I have looked for installation guides, I have looked for helpful guides and how-to’s all over the place.

Every single one of these – each of them – creates an unstable or unusable Lucee server. The problems that are generated are almost too numerous to name. Memory leaks, being unable to define web roots, enormous and rage enducing issues with mod_cfml, duplicated server requests (this happens almost every single time), huge CPU and memory issues.

My application ran just fine for 7+ years on a similar AWS instance, even using the old ubuntu-nginx-lucee script (back when it worked and was current). The application is fine.

I don’t know what’s changed. I don’t know if it’s because of Ubuntu 22.04 and not Ubuntu 20. I don’t know if it’s because Lucee has moved to version 6. I can’t find out why. Honestly: I have put about 150 hours over the last 6 weeks (I am not exaggerating) into trying to build a stable server configuration. I have spun up dozens and dozens of new AWS instances.

I don’t want to offend anybody, but there is no existing documentation on how to do this out there on the internet, given the current environment and software versions, right now. The existing documentation/guides/how-to’s are all somehow out of date. Apparently there isn’t going to be a Lucee-installer ever again? I can’t even figure out how to change the webroot to my actual webroot in /opt/lucee because now there’s a .CFConfig.json file? And not an XML one? Or does the XML one matter if I have Nginx? Or Apache? Why is it when I google “change Lucee webroot” I don’t find any answers that work?

I really don’t know where to turn, now. Reaching out here is a last resort. I just can not figure out what to do. Please understand that if I sound emotional, it’s because I am emotional. I have actually cried tears of actual frustration about this. I am spending days and days and days of my life on this earth trying to get this to work, and every single thing I do is not working. I need help.

Does anybody have a guide – a current, updated guide – (again, current) that shows how I can set up a running Lucee instance? That’s all I need. Something that works.

This is not a complicated server. It’s a light application server of .cfm pages located in /web/default/wwwroot. This is not an insane configuration. It is as basic as it gets.

OS: Ubuntu 22.04
Java Version: 11
Tomcat Version: Can’t make install work
Lucee Version: Can’t make install work

1 Like

I just want to say – I have been so grateful to the developers of Lucee over the years. I have had immense joy in building in CFML for so long.

If you sense frustration and sadness from me, it’s because I am feeling like the hobby I’ve loved for most of my adult life is becoming actually impossible for me, and it’s all because I can’t just get a stable server up and running. Coding these little CFML projects has been a true passion for me. I just want to get back to it, but I can’t, because I can’t get a server to just run.

I just want a running, stable, updated server. That’s all I want. Why is it so hard to figure out how to do this? Why is it so incredibly complicating?

I’m not sure what ppl are supposed to do to help given the very broad and detail-free nature of your post, but this sticks out.

No-one is forcing you to use Lucee 6 (unless Micha is there holding a gun to your head…?). I’d not touch a new release of either Lucee of CF for at least six months after it goes out the door, so the early adopters can wade through the issues.

What version of Lucee did you have running stably? Use that.

As for memory leaks… it could be a case that the usage patterns / traffic volume of your app have got to a tipping point where previous issues with the code that weren’t quite pushing resources over the edge now are. We had (/have) this with our codebase.

Given Ubuntu, Tomcat, Lucee are all things people have got working separately and together no problem, the unique variable is your codebase. When faced with problems like this, it’s counter-productive to go “it’s not my code”, because it prevents you looking at your code. My approach here would be to go “it’s my code. I don’t understand why, but Occam’s Razor is pointing to it being my code”.

Or, in this case, the new Lucee version is also a candidate. But don’t discount it being your code having got beyond its breaking point.

Another unique factor in this situation is… well… you. Maybe you don’t quite have the expertise to manage this stuff well (you say you hate it, so that’s a pointer in this direction)? Have you considered engaging someone who specialises in this stuff to sort it out? If yer spending “literal” weeks on it… it was probably time to engage help with this some time in the past.

Your toy-throwing post might be cathartic - I get that - but it’s very light on detail and is poss a bit self-indulgent. I’ve been guilty of this in the past, so this is not much of an indictment coming from me. But yer not likely to get much fine-tuned help based on the info you provide. I recommend taking a deep breath and tackle one issue at a time. And report the result of your investigations and the anomalies you find. Actual data / information.

But start by downgrading Lucee to the last version you ran that was “stable”. Discount the Lucee version from being a factor in this. Then move on to the next one change. Report back on that.

And also… get someone in who’s confident with this stuff. I think it’s clear you are out of your depth and comfort zone.

1 Like

HI @gooutside

Adam gave you some good pointers, please keep in mind.

I also want to give you some advice. I hope it is useful to you:

  • Do not use Lucee 6. We are at the first stable version and it is natural that there are problems. Continue using 5.4 (or whatever has worked well for you so far).

  • What type of installation do you need? CommandBox is the fastest way to get your setup. But installations with Tomcat also work well, and it is still quite simple to implement.

  • After you have installed a version of Luce that has never given you any problems, try to figure out if the problem is your code. Download a version of FusionReactor (you can also install it with CommandBox): you have 14 days of trial, and it will give you a lot of information about your application. It saved my life many times.

  • If you want your application under /web/default/wwwroot you don’t have to move the root directory. Simply position yourself with Box inside this directory, and start the server :slight_smile:

  • I know very well that these things are very frustrating. I don’t know English well, but if you want I can help you by writing to us on Skype. I can dedicate time to you after working hours.

Don’t get overwhelmed by problems. Solve them one at a time. I hope I was helpful.



I am a hobbyist – not a developer with professional resources. I can not just “call someone in.” Yeah, I am out of my depth. Yeah, I am out of my comfort zone. No, I can’t just call a professional. Basic, nuts and bolts server set up should not require a trained Lucee server management professional for every installation.

Here is a key detail that I can not seem to figure out:

All scheduled tasks in Lucee are hitting the Lucee engine twice. I have downloaded FusionReactor and have been watching it. I have multiple “Applications” showing up, for some reason. ROOT, MyApplication, Lucee are the names of some of the applications. Requests from outside the computer are being handled by Lucee. Requests from Lucee’s scheduled tasks are handled by MyApplication and Lucee.

I have two Web Contexts on the front page of the Lucee admin panel, which say:

URL: http://localhost:8888/ Webroot: /opt/lucee/tomcat/webapps/ROOT Configuration: /opt/lucee/tomcat/lucee-server/context/.CFConfig.json
URL: Webroot: /web/default/wwwroot Configuration: /opt/lucee/tomcat/lucee-server/context/.CFConfig.json

Note that the actual webroot is at /web/default/wwwroot. Also note that the .CFConfig.json file has seemingly nothing in it that specifies anything about where the webroot should be. And, also note that the URL is, facially, an error: it shows http:// and a port :443.

I am experiencing serious issues with this configuration. This is coming from a default, vanilla installation via the last installation package manager. I have followed almost precisely and exactly the Apache2 configuration steps for apache2.conf, 000-default.conf and default-ssl.conf. Sometimes when the server starts up the Web Context shows before it switches to I have no idea why.

I think there is a serious misconfiguration issue happening due to the relationship between mod_cfml, apache2 and Lucee. I have no idea how to resolve it. This is an opaque, mysterious relationship and there are almost no examples that I can find online in which this behavior is explained.

I know that people are defensive of their code. This is not the code. This is happening with no code being executed, still. This is a baseline server installation misconfiguration issue. This happening even with all scheduled tasks turned off. There is something about the relationship with mod_cfml, Lucee and Apache2 that is seriously, majorly out of order. And I don’t even know how to even begin to diagnose how to resolve it.

And, if you sense frustration, it’s because I’m doing the most basic, generic, absolutely unedited vanilla installation you can possibly imagine. I am following every instruction guide I can find on the internet. They say, “download the most recent stable version of Lucee from” If is the most recent, stable release of Lucee. That’s why I’m using it.

By the way, I’ve done a fresh install – completely new AWS instance – of the last known working installer from, for version Just a completely fresh, completely clean install. I am still getting the “duplicate” context creations. Whenever I run a scheduled task, it runs twice, once in an application called “MyApplication”, and then once in an application called “Lucee.” When I run the page externally it goes through a third application called “ROOT.”

Thisnot my code – is the reason I’m running into memory issues. I am looking for help in understanding why Apache2, mod_cfml and Lucee – regardless of the version – are creating multiple applications and running duplicate requests to the applications. Apache is showing only one request. Somehow along the path of Apache to Mod_cfml to Lucee the request is being duplicated into two different running Applications.

If this is an apache configuration issue, please note that I am using the configurations recommended by the installers and guides online.

After you have installed a version of Luce that has never given you any problems …

This is part of the issue. I can’t install the ubuntu-nginx-lucee script anymore, it just plain doesn’t work. And that’s what worked for me, before. So now I am forced into using Apache, since there are literally no guides on configuring Lucee with Nginx that are anything remotely close to applicable any longer.

I tried CommandBox but there were an almost endless array of problems around permissions and configuration issues. I simply could not make a CommandBox server work. CommandBox seems primarily configured to do quick stand-ups of Lucee for development purposes and it is very challenging to find good documentation on how to use it for a Production environment.

If I am missing something here, please, I’d like to know. Is there a guide out there that Google hasn’t shown me?

I just need a Lucee Server to serve my /web/default/wwwroot directory to the public, with a few basic rewrite rules and the capability to execute certain AWS cli commands with . I really, really want to do this. I have literally spend days and days of my life trying to do this. I do not understand why there are so few resources for this, or why even a fresh, from scratch installation is still causing problems with duplicated contexts as mentioned in my post above.

Just like you I initially thought that CommandBox was a tool for starting up CFML servers within a non-production environment.

But this simply isn’t true.
A CommandBox Production Server is entirely appropriate.

I also had quite a few issues in starting out with CommandBox.
I also found the documentation - to be really difficult to grok.
“I” found the docs read more like a “cookbook” - when I first started reading them.
And I still think they do read cookbook-esque - but I have a better inherent knowledge of CommandBox, now, so normally I am just after a recipe for doing XXX.

There are two very separate concerns in a CommandBox install.
The Configuration and usage of CommandBox and your Lucee Server configuration - which, when using CommandBoxis (onbviously) CommandBox driven.
My point is - although there is overlap - and although it is intertwined : They are still separate concerns.

You can take your existing lucee-server.xml
And start a Lucee 5.x server with CommandBox - that uses your existing lucee-server.xml.

No need to worry about anything else - initially.
And to get to this point - IS REALLY EASY.

  • Install CommandBox on your server.
  • Change Directories to your app-root.
  • use box server start

Your application - as you know it - won’t be working yet - but that’s OK.
In your app-root - you will now have a server.json file.
This file is what you will use inform CommandBox of how you want it to start / run your application.

Want it to use ports 80 / 443?
There is a setting for that in the server.json.

So now you just have to go to the ortus website and search for CommandBox server port - to get the right syntax / placement of the setting in your server.xml.

At this point - this where I got lost…
Because you can hand-edit the server.json for your port setting.
OR You can use a commandbox recipe, too.
OR you can use envornment variables.
OR you can use them all - where one overwrites the other…

And there is also a tool called cfconfig - which when you’re srating down the CommandBox road, seemingly goes hand-in-hand with CommandBox.
cfconfig is for managing your Lucee server settings.
You can set individual Lucee settings via cfconfig:
cfconfig set adminPassword=commandbox to=myConfig.json

But hold on - this is storing lucee settings in a JSON file not the lucee-server.xml
What gives:?

And just like the CommandBox server settings - you can overwrite the lucee server settings via a “recipe” file AND environment variables, too!

There were just too many options - all at once - to get my head around how it all worked together.

It took me a lot of (wasted) time and a lot of bothering @Brad_Wood, here in the Lucee forums AND the OrtusSolutions forums and the SLACK channels.

So the simplest cookbook recipe for you - IMHO is;

  • Install commandbox
  • run box server start from within your app-root directory. ::: BUT ignore the fact that it is IN your app-root - for the moment.
    In fact put aside any and all thoughts about your app entirely for the moment.
    Your first goal is to get a vanilla Lucee server up and running ::: on the right port / with the right mod_cml settings / with the correct URL rewrite rules / with SSL configured (if needed) / etc.
    (effectively - think of all the settings you would need to configure in Apache HTTPD / TOMCAT / NGINX).
    These are all COMMANDBOX concerns, because you no longer need apache2 or nginx or tomcat.
    (You can use any of these, in any combination - or all of them if you really want to - but you don’t NEED them any more - CommandBox can do them all (with production efficiency and security).

If you want to use NGINX for URL-rewrites - go ahead…just don’t configure url_rewrites in CommandBox (they’re not there anyway - unless you put them in)…

But at least now you have a specific / directed task - not a frustrated “This is ALL shit - ALL to much…”

How do I get url rewrites working? I have done this and this and it doesnt seem to be behaving for me

As for the OrtusSolutions documentation - which I (now) have a great appreciation for ::: keep in mind that your now looking for a recipe to get url rewrites working with CommandBox.
And since (to me, at least) their documentation reads like a cookbook - it becomes a lot more useable!

Once you get this far - and it sincerely isn’t long to get HERE. (Couple of hours - because of the reading you’ll be doing) and LITERALLY, it is only a few minutes to get to here from a fresh EC2 instance - once you’re more comfortable .

You copy your existing lucee-server.xml file into the location that commandbox actually runs the Lucee server from and you should have exactly what you were expecting.

You might still need to make some tweaks in the lucee config - for your new server / install - but that can all be done within the Lucee Administrator - just like you have always done.

From this point forward:
It has nothing to do with CommandBox
(Except for the fact that you need to start the Lucee server after an instance restart via box server start from within the app-root - and you can set this up to happen automatically)

It has nothing to do with cfconfig, either.
You can leave things now and NEVER have to deal with cfconfig at all.

As an aside / extra :::
cfconfig is especially useful if your using docker / or you have (or want) some sort of automated pipleline (orchestration).
If you have a starting mindset of treating your entire infrastructure as a script-configurable (repeatable) resource - then it can be a really useful tool.

Or… you just want to learn cfconfig anyway - now that you’ve jumped into the CommandBox hostel and decided you want to stay here with us, a while longer!

1 Like

Thank you, @Gavin_Baumanis, for this really thoughtful and kind and well-written response. I really appreciate your empathy and kindness.

I have tried to do some CommandBox stuff, partly because everybody talks about “how great” CommandBox is, and just how amazing it is and on and on. I’m sure it is!! But, like you, I am stuck at some very basic things in the very early stages, things that seem sort of like serious issues that nobody else seems to care about?

I’d like for CommandBox to be my public web server on ports 80 and 443, but, well, I can’t do that. Flatly can’t. Apparently I must run CommandBox as “sudo” in order to do this. But, everything in the entire online security world warns strongly and clearly against running web servers as “sudo” or as root users.

So, right off the bat, we have an incompatibility, and no real way to overcome it. Are we just saying, “well, it’s OK, because it’s just what we have to do to make it work.” Really? We’re going to violate basic security principles? Really? That’s the answer?

One of the things that is most appealing to me about CommandBox is not having to use Apache or Nginx. So, I’m not really all that interested in staying at port 8080 and putting a reverse proxy in place just to be able to serve pages on port 80.

I also don’t like hacky workarounds like iptables and authbind.

Again, perhaps this provides some understanding of why I am finding it so deeply, profoundly frustrating to get even a very, very simple Lucee web server stood up. I keep running into these kinds of fundamental contradictions.

Thank you again for your response. I wonder if you have any insight about the port 80 issue (which seems like a serious, obvious, unambiguous dealbreaker to me and yet somehow isn’t for anybody else for reasons I can’t read about literally anywhere on the internet); I’d love to hear more.

You can. But you need to have only ONE host on your machine on port 80. From what you wrote you need at least two.

CommandBox does not have the ability to have more “virtualHost” (it’s a feature, from what I understand, that is in the next release). This means that, by design, each host runs on its own port. So you can only use port 80 for ONE host (I also didn’t understand this at first, used to Apache + Coldfusion).

The easiest way to have more hosts is to add a webserver as a proxy.
(Browser → Apache/Ngnix like proxy → Lucee/CommandBox)

It’s very simple, I’ll give you an example:

site1 → CommandBox port: 7552
site2 → CommandBox port: 7553

Now on Apache add two virual hosts, configured as follows:

<VirtualHost *:80>
     ServerName site1
     DocumentRoot /www/site1/wwwroot
     Protocols h2 h2c http/1.1
     ProxyRequests off
     ProxyPass /
     ProxyPassReverse /

     RewriteEngine on
     RewriteCond %{SERVER_NAME} =site1
     RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]

Then add a similar virtualhost for site2 by changing the port and the host.
There is nothing more.

This is an example for Ngnix like proxy too:

server {
     listen 443 ssl http2;
     ssl_certificate /etc/letsencrypt/live/site1/fullchain.pem;
     ssl_certificate_key /etc/letsencrypt/live/site1/privkey.pem;

     include /etc/letsencrypt/options-ssl-nginx.conf;
     include /etc/nginx/snippets/headers.conf;
     ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem;
     root /www/site1/wwwroot;
     index index.html index.htm;

     location / {
         include /etc/nginx/snippets/methods.conf;

         proxy_set_header X-Forwarded-Host $host;
         proxy_set_header X-Forwarded-Server $host;
         proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;

         proxy_http_version 1.1;
         proxy_pass http://localhost:7552/;

I left references to SSL that might be useful (you don’t have to manage SSL on CommandBox if you use a webserver as a proxy).

Regarding using CommandBox with sudo, “sudo” is necessary when doing maintenance on Linux systems. More than worrying about using CommandBox with sudo, in my opinion you might worry about CommandBox running with a low-privilege user. But this is AFTER your installation is working.

I hope I was helpful.

If you are completely out of your depth I would suggest you go buy a hosting service that provides the level of support you require.

There are multiple hosting options for Lucee, all of whom will provide the level of support you need.

Many programmers simply do not know or simply do not care to know exactly how hosting works. They focus in on what is important to them, which is coding.

I sense your frustration, and there are many experienced professionals who have and deal with the setup of websites on a daily basis. They have seen it, done it, and you will be hard pressed to stump them.

Googling “Lucee hosting” will come up with a bevy of options.


I’ve installed and maintained Lucee servers via AWS Lightsail for several years now (7+ years). When I originally set up my Lucee server, there was an extensive amount of documentation, active support and guides for engaging in the setup. There were actively maintained projects like ubuntu-nginx-lucee, which helped with the set-up. It was a much easier effort.

My server ran mostly carefree and happy for many years. My code was stable, the server set-up was stable, updates were mostly stable, but, regrettably, my server reached the end of its life (unsupported Ubuntu and Nginx, primarily), and the need arose for an upgrade to a more modern server. My server would go literally months without a need for restart. It was stable. Extremely stable.

So, perhaps you can imagine my surprise when I went to accomplish the same task I set upon 7+ years ago – installing a new server from scratch – and found that there is, for some reason, no longer the same ecosystem of support, help, guides, scripts, and other materials available.

I’m not an idiot, I’ve managed the server just fine for years and years and years. If I have that kind of experience, and I’m now looking for resources for new server setup, is it acceptable that I am encountering an ecosystem devoid of support options and, frankly, is hostile about it? What has happened to the Lucee project to cause the barriers to entry to go up and not down? Why are documentation and guides just so painfully hard to find, outdated, incomplete or insufficient, these days? Why have we seemingly abandoned the development of simple, low-barrier installers?

So, if I say I’m “out of my depth,” it’s because somehow in the last seven or so years, the water around Lucee has been rising. While Lucee, itself, may be getting easier to use, it’s getting harder to install Lucee in the first place.

So, rather than reacting with hostility and mockery, perhaps the community could engage in some reflection about why this is happening? Why are the barriers to entry going up and not down? Does anybody even care, or is everybody satisfied that because “I got mine,” they don’t need to worry about others just trying to get started?

Something in this ecosystem has changed. I didn’t realize it until I had to start my server over again.

First and formost, not trying to offend you or call you anything, other than another lucee user :slight_smile:

Without going into the very fine details, Lucee is an opensource project. It does not have the same level or following that say, Debian Linux has.

As much as you need Lucee’s help to do “yourthing”, Lucee needs time and resources.

So if you want to complain, fine, complain but my knee jerk reaction with all complainers on opensource projects is, its free, what have you done for the open-source community?

If you do not like something, fork-it, code it, fix it.

However, if you are going to come on here, and after a bunch of nice constructive gestures continue to “BOO” the volunteer works of a great many people, then what does that say about you?

If you want to be helpful, constructive, thoughtful, kind, generous, supportive, or useful, then do something for the lucee community.

the docs are absolutely needing a touch up
the funding for the foundation could always use more, as it helps pay for professional programmers to bang out the awesome code that people such as myself, could never create.
If you can program, submit some pull requests, as lord knows Lucee needs more hands on deck, not less.

As for installation, I have managed to install Lucee on FreeBSD and HPUX, what exactly are you having issues with?

I am not “booing” the developers, and I appreciate @Roberto_Marzialetti and @Gavin_Baumanis suggestions. I’m working through them, trying to figure out alternatives. It’s hard. @Gavin_Baumanis has provided the beginnings of what appears to be one of the first actually straightforward guides to individual server setup in CommandBox that I have yet found on the internet. Thanks, Gavin! I really do appreciate it!

But this is a forum post. I am a hobbyist CFML developer, there is absolutely nothing I could contribute to this project. I don’t even know how to fork-it. I’ve never needed to. I haven’t needed to. I have no experience in software management other than my dumb little website and my dumb little CFML tag-based coding projects. But I love my website. I love making my little code projects and it’s a place of incredible creative expression and learning for myself. I cherish it quite dearly.

So, when Lucee becomes so overwhelming and complicated to install that even I can’t do it after years of experience in self-managing the installs, then perhaps it would help the community to hear that perspective and think about what it means to the long-term health of the overall project. I know resources are limited. I hear that. Again: the total abandonment of simple, low-barrier installer programs is mind-boggling to me. Do you want new people to use this code or not?

I deeply appreciate the work the Lucee team puts into continued development of this software. Again: it is a place where my creativity is unlocked. It means a lot to me. I don’t have much in my life to offer other than sincere gratitude. So, please understand that I am expressing these frustrations from a place of love. I feel like an painter who can’t get into the art store to buy paint because there’s an insanely stupid, wildly over-complicated Rube Goldberg machine in front of the door that you have to figure out (with no clear instructions!) before it will even open (and the people inside the store are laughing at you as you’re trying to get inside, speaking a language you can’t even begin to understand). It is profoundly, deeply frustrating.

You are saying you aren’t booing anybody, sorry…but you are!!!

You’re complaing and telling the documentation in 7+years and the support was better in Lucee… (errr you mean Railo?) back then? And the install scripts of “ubuntu-nginx-lucee” were so easy, and they haven’t been updated? Well, that tells me that you have been away of this community for a long, really a long time. I’d say you even have never been a true commited part of this community: the scripts for “ubuntu-nginx-lucee” are pure open soure provided thankfully by the cfml security master @pfreitag and NOT anyone of the Lucee team. Thanks to guys like Pete we have really valuable stuff in our cfml community (for ACF and Lucee!!!). Then you said the documentation is lacking? Please take a short look at the commit history!!! Arguing that way shows me you have never ever really bothered taking a look at any of the open source stuff at Lucees source before. The documentation has grown a lot! And I’ve provided and invested a LOT, really a LOT of time personally into those docs myself… Such as environment variable guide, installing guides (also videos) for ubuntu & windows 2019, commandbox, xamp and more… helped others a LOT here in this community forum, with installing issues without receiving just a single tiny penny from the Lucee dev team, or others… I just presented everybody with those. i did it because this is an Open Source Project!!! You are really complaing at a very high level!!! Withou even having given a litlle single tiny help in anything to this community. So please stop complaing. If your are seeing something missing, please start adding stuff!!! Dig into the source and start envolving, just like @Terry_Whitney , @Gavin_Baumanis @Roberto_Marzialetti and the many more superb developers who are ALWAYS here to help other. Sincerely, I haven’t the same amount of time to help or adding anything more to this awesome community like I had before, because I have a new position and job that is demanding(but fun). At least I cstarted paying a monthly subscription to this awesome software creators to help them out. So pls… STOP complaining and do something about it that can share with us.

Your contribution to this community with your post is what is really and deeply frustrating.

By the way…show one single post of you in the past 7+ years where you have “helped” sharing of your 20years experience (wirhout asking others for theirs), and I might rethink about my opinion.

Yeah! You are right, @Andreas . I am not part of this community! At least the community of active developers of the software. I can’t do that! I think it’s perhaps more than a little unfair to be saying that the only valid criticism of the project can come from people who are making contributions to the software management. I read most of the threads on this board and think, “How on earth do these people understand this stuff?”

I’ve never taken a computer science course. I have never learned Java or any other language. All I know is the stuff I’ve pieced together in little bits from around the internet over the years. This community has helped a lot with that. I can’t offer that help back. Because I don’t know anything about Lucee other than what I learned for my stupid little website project.

I am merely pointing out that the resources that were once available to easily guide a novice web developer into having a stable Lucee installation are now gone. There are no longer updated installers, the nginx-ubuntu-lucee scripts (and others like them) are long gone. I don’t know how to write those scripts. I can’t offer to help with them. I don’t know how do that kind of work!

The best thing I can “contribute” is to let the people who can do something about it know that the current state is very hostile to beginner developers! My god, guys! If I could write the “how-to” guide or build the standalone installer or rebuild the nginx-ubuntu-lucee scripts myself, I would! I would share them with you. With all of you!!! I CAN’T DO THAT! I DON’T KNOW HOW!! Fundamentally, I don’t know how to help with Lucee problems! I’m sorry, that is not something I know how to do!!!

I use Lucee. I do not (and can not) develop and problem solve for Lucee.

I’m trying to share with all of you that I am experiencing a profound frustration with baseline levels of accessibility to the software that I love. When the response back to me is, "fix it yourself or shut up … " Oh my god! How do you expect me to take that?! How do you not expect me to be deeply frustrated with that!?

I am not a software developer! I use CFML code as a creative outlet! I can not even begin to understand how one manages, writes, improves, etc. software of this complexity and scope!

Telling someone that their criticism is only valid if they’re willing to fix the problem is insane, to me! And it’s really, really hurtful! I am trying to share with you all a profound frustration. You’re all telling me to shut my mouth unless I’m willing to fix it, myself!! My god!

Very simply: There are no longer entry-level resources for starting up a Lucee server. I think that’s a serious problem! No, I can’t fix it! But guess what? It’s still a problem!

Sorry this is happening to you. I would love to help but I know nothing about using AWS. My lucee install uses Arch Linux, Jetty and Lucee. The learning curve was a bit complicated when I first started this adventure 20 years ago with Railo. I believe if you detail one problem at a time here you will get sound advice.

I don’t want to start a deep discussion here.

That’s not what I’ve said. What I’m criticising is not that. Let me try to explain it with a little analogy: There are community events or gathering were there are people who always bring stuff, drinks, snacks for everybody, they keep until the end to clean up and contribute to the event, and there are others who just come by to eat and drink, then go back home. Well, you are participating but complaing that the snacks and the drinks are not as good as they have been before, and telling how deeply frustrating that is… while never having brought anything or having contributed the events before. This attitude is what I crticise. I’m sure that with 20years cfml experience and you’ve run a Lucee server for 7+, no way you have no experience to share.

But maybe we can try starting all over again. What is what is happening in your case? Please specify exactly what is happening in your case and we might be able to help you out. I know there is the meed to create new vids, but I dont know when I can rerecord it and cut it.

I know you are frustrated at the moment and I promise you that I’ll add stuff to ghe docs as soon as I get some time.

What is what you need? An installation guide for Lucee 6 on ubuntu 22.04 with Apache? I’ll try updating/adding that as soon as I can to the docs.


1 Like

This isn’t a party. We’re not all the same. Lucee is a piece of software. Lucee has a development community and a user community. I am a member of the user community. If the user community can’t provide feedback about the accessibility of the software without also having to become developers, themselves, then I don’t know what to tell you. Users can’t fix development problems. I’m sorry, but the fact is, with your party analogy, software users literally do just eat and then leave. That’s how software works. Software users cannot set things up for the party. They’re users. Not developers.

I am locked out of the tool that I love and cherish because there are no longer straightforward, low-barrier points of entry for non-developers to utilize. I think that’s a problem. Maybe nobody else does. But the only thing I can do is point it out to the people who can actually do something about it.

I’ve tried to clarify the challenges I’m facing about installation in other posts, but I’ll try it again, here:

After 7 years of incredible, problem-free months-long stability, I was forced by software obsolescence to upgrade my Ubuntu/Nginx/Lucee set up on Amazon Lightsail (similar to EC2) to a new Lightsail instance (one that even had more CPU and RAM!). I followed the instructions in your very installation guide, @Andreas , minus the parts about GUI installers. I’ve tried other installation guides out there. I tried having ChatGPT give me an installation guide! I tried with Lucee 6, then moved back down to Lucee 5.4. I’ve also tried the regular standalone installer. In between each (failed) effort, I am starting a completely-from-scratch cloud instance so that I can be certain that I’m not leaving a lingering problem behind.

What I have since encountered, in every single instance, in every permutation, every single time, is serious problems with crashes and hangs, which put the entire server out of commission, halt all incoming and outgoing network traffic, and are unrecoverable using tools like Monit. The only solution is manual stop and start of the server through Lightsail.

Crash logs from apache2, syslog, Lucee, and more reveal nothing. There are no unusual traffic patterns, no clear indicators of what’s preceding the events. They’re random. They often have a Java Out of Memory (OOM) event attached to them.

I have installed FusionReactor to try to understand what’s happening, but not getting any clearer picture, partly because FusionReactor is a fundamentally complex program and I don’t know what to look for. But, when I look at it, I look for things like memory, garbage collection, etc. I don’t know what any of that means, but none of it really stands out as anything notable. The data in FusionReactor looks exactly the same during normal site operations as it does immediately before a crash.

“Oh, but it can’t be Lucee! It has to be your code!” Again: my code ran without a single crashing incident on the exact same version of Lucee. The code has not changed, not one bit, not a single line. The code that ran without problems for years is the same code on the new server. The issue is not my code.

What has changed? Well, the only and I mean only difference is that I am now, for the first time ever, dealing with Apache2 and “mod_cfml,” which has to be one of the most well-used but under-explained and un-documented pieces of software in human existence. I can only surmise that this new Apache2/mod_cfml combination are at the root of this. Maybe something with AJP?! Who knows. I don’t know anything about that stuff. Again, I used the nginx-ubuntu-lucee scripts. (I couldn’t use them again because they’re tremendously out of date and nobody seems to have interest in maintaining them. Also, before you say anything, I can’t maintain them because I don’t know how they work.)

The problem seems to be in configuration, most particularly in the link between Apache and Lucee.

Of course, I’m also on Ubuntu 20 or 22 instead of 18, now. I guess that’s another thing that’s different.

I wish I could better understand what insane purpose mod_cfml is serving but it’s opaque and the documentation on its website doesn’t match any of the other guides or information out there on the internet. Apache, itself, is also mind-bogglingly complex and messy to configure. There are dozens of configuration files in multiple directories, it’s staggering to even comprehend.

So, part of the struggle I have about explaining “what’s going wrong” is that I don’t know what’s going wrong, I can’t diagnose it, and I can’t point to any particular issue. The server goes absolutely dead-as-night dark and once it does, there’s nothing I can do to investigate what’s going on.