Web pages not being processed, but admin pages work

Hello to everyone,

I am new to Lucee, so please forgive my lack of understanding. I have recently inherited a Lucee server that may not have been completed in it’s installation. I can run the Admin pages very well. But, when I attempt to run a page belonging to the website I am to support, I get an error. I created a simple page with the following information to simplify my testing:.

hello there - #cgi.SERVER_NAME#

I get the following in response:

Tomcat Mod_CFML error
mod_cfml request authentication failed!

I am new to Lucee and was looking forward to playing around with it. But instead, I am stuck just trying to get it to work. I am sorry but I had nothing to do with it’s installation So, I have no information about how it was done. All I can describe is the current stack.

Windows Server 2012
Tomcat 8
Java ???
BonCode AJP 1.3 Connector

Can anyone help me? I am stuck.

Don’t forget to tell us about your stack!

OS: ???
Java Version: ???
Tomcat Version: ???
Lucee Version: ???

See the solution here:

1 Like

I am confused. I read your reply. I think that both files you mentioned are the same file. So which one is it supposed to match? But thank you for the quick response.

There are two different files mentioned in that post:


Edit whichever exists in your installation, which is probably the latter.

Summary: The value of:

<Valve className="mod_cfml.core" sharedKey="YOUR_SECRET_HERE" ...>

should match the value of ModCFMLSecret in your Boncode settings.

Thank you!! Thank you!! that did it. I no longer get the error.

The documentation I found read that the first line had to be added. Otherwise I added these two lines to my BonCodeAJP13.settings file. The secret matched the secret in {lucee-root}\tomcat\conf\server.xml.


I restarted the server and now have another problem. Before the other guy left, he told me that he had made it so the server responded and processed html pages instead of cfm pages. So my test page consisted of setting a variable and CFOUTPUTting the variable. (So that I could see it processing the code.) When I run the html version of the code, it does the usual output of everything that is not a variable. Variables are displayed as such: #variable_name#. When I run a cfm version of the code, I still get the “Tomcat Mod_CFML error”. Before, I used to get the error on both html and cfm templates. -even though most of the code has html extensions. What gives? And, should I start another thread?

1 Like

Yes it’s best that you start a new thread because, though I started with Allaire ColdFusion way back in '97 on Windows NT servers, I switched to Linux, Apache, and mod_proxy about a decade ago and have forgotten pretty much everything about IIS and Boncode.

So you’ll get more exposure to people who have current experience with what you’re using.

Also they’ll probably need to see your Boncode settings.

Good luck!

Thank you for all your help.

1 Like