Lucee won't start up - Can't reach Admin (Express version)

So I downloaded Lucee Express, I extracted it to a folder on my C drive (C:\Lucee). I ran the startup batch file. I went to the localhost:8888 on my Google Chrome browser.

(Running on Windows, btw)

But nothing happens.

So what am I missing?

I’m sure I’m missing something. And probably something big.

Judith

Hi Judith, long time no see. I would recommend CommandBox if you just want a quick and easy way to run Lucee (or Adobe for that matter)

server start

That’s it.
https://commandbox.ortusbooks.com/embedded-server

As far as your question, it’s likely a missing java_home env var or a port that’s already bound. You’d need to look in your tomcat/logs/catalina.out I believe to see what’s happening.

So I did first allow port 8888 on my Windows firewall. But then I also checked my Catalina logs and what I have is: 24-Jan-2018 11:58:32.074 SEVERE [main] org.apache.coyote.AbstractProtocol.init Failed to initialize end point associated with ProtocolHandler [“http-nio-8888”]

Also 24-Jul-2018 11:58:32.078 SEVERE [main] org.apache.catalina.core.StandardService.initInternal Failed to initialize connector [Connector[HTTP/1.1-8888]]
org.apache.catalina.LifecycleException: Failed to initialize component [Connector[HTTP/1.1-8888]]

Caused by: java.net.BindException: Address already in use: bind
at sun.nio.ch.Net.bind0(Native Method)
at sun.nio.ch.Net.bind(Unknown Source)
at sun.nio.ch.Net.bind(Unknown Source)

So - I have a Sun JVM installed on my machine. Would that possibly be the problem? Could the JVM be using port 8888?

How do I see what is using what ports on my machine?

Thanks so much!

Can you run the bat file from the command line to see what the output is? Java might not be installed or something.

Mark Drew

This is what my Tomcat looks like when I run the startup batch file through Cmd prompt. It ends with server startup in 5314 ms but then it seems to hang… Unless that’s where I’m supposed to end up? I highly doubt it.

I don’t see any issues there. Is your network usage spiking? Sometimes snapshot builds of Lucee download additional bundles on the fly.

You can also check the server and web context logs for clues.

I usually kill all java processes :slight_smile:

Mark Drew

I will check server and web context logs…

My network usage isn’t spiking. It seems pretty level.

I did kill two Java.exe processes that were running.

I have to go pick my daughter up from the camp bus, but I’ll look at this later tonight and see what else I can figure out. Or I might try using Commandbox - is it really an easy way to run Lucee? Or does it require Networking 101 advanced degrees?

CommandBox is THE easiest way to run all CF engines. And no degree is required :slight_smile: Read the doc I linked to above. It’s really just a matter of downloading the box.exe and running box start. And even if it doesn’t work, it’s way easier to debug: box start --debug!

I think that is about it. Not at my machine to check. You should now check port 8888

Mark Drew

something else is using port 8888

run netstat -b -a from an admin command prompt to see what process is using 8888

So netstat on the Admin command prompt says that the Java.exe service is listening on port 8888.

I already stopped the Java.exe service and it still is not working. I’m going to come back to this tomorrow morning.

Thanks for your help… I’ll keep you posted.

When in doubt, reboot!

1 Like

So, an update: I have cleared the 8888 problem by stopping the application that was using port 8888 but I’m still not seeing the Lucee Admin screen. So my husband suggested that maybe I need to set the Java_home variables.

I checked my system settings and Java_home and JRE_home are not set.

So - somehow - though (as I gather) Lucee express is supposed to do this automatically, it was not done.

Where does the Tomcat installation actually reside in the Lucee directories? And what are the variables supposed to be set to for a plain Lucee express installation?

I will shutdown and startup and check my logs again to see if I can find any more clues as to what’s happening.

Judith

Lucee Express doesn’t set any env vars. You just unzip it and start it and it assumes you have Java installed and setup. You’re catalina.out should have information in it.

I hate to sound like a broken record, but seriously you’d probably be running by now on CommandBox, biased as I am. It’s lightyears ahead of Lucee Express. Just grab the binary, double click, CD into your web root and run “server start”. The next thing you’ll see is a web browser open to your site. CommandBox detects the ports in use and picks one that’s unused.

Regardless, if you want a faster turn around on troubleshooting you can jump in CFML slack and go over your log files, etc on there in real time and then post back here with the answer once we’ve solved it. I’m not sure why you’re having issues. Even Lucee Express as rudimentary as it is, usually “just works”.

1 Like

I can’t find a catalina.out file. I did check for it. All I’ve found in logs is files like catalina.2018-07-26. That’s why I have no idea what my catalina.out would say.

Also, this may seem like it’s taking three days, but I’m doing this very part time, between dealing with my kids (and my daughter came home and went back to sleepaway camp this week, so believe me in those three days I’ve maybe been able to spend two hours total on this problem…

And I do appreciate your help.

If I can’t find the answer tomorrow morning, I’ll try commandbox. I just didn’t want to add another layer to the application I was dealing with…

Judith

Are you available to do a quick Zoom call? I can DM you a URL. This really shouldn’t be too hard to figure out.

Sure. Go ahead.

So thank you very much to Brad Wood for helping me last night (despite needing a very early start this morning.) We solved the issue – it turns out the server was starting but my own misunderstanding of how Lucee Express works was getting in the way. I assumed the Tomcat server would be running even if I closed the window (thinking that it was a command shell for the process, similar to how closing the Windows command prompt does not close down Windows.) Lucee Express is, in fact, running in the Tomcat window that pops up. So by closing the Tomcat window, I was shutting down the server before I tried to access the admin! Silly me…

Once we left Tomcat opened, we had no issues at all.

Brad showed me Coldbox as well and I was very impressed. So easy to deal with. Thanks, Brad! You’ve definitely won me over.

Judith

2 Likes
s/coldbox/commandbox/

Glad to help :slight_smile:

2 Likes