Installation of Lucee on Raspberrypi ubuntu server

Hello guys, I’m already a few days trying to mount a Lucee server on the raspberrypi running Ubuntu server.
My intention is to have a sandbox to learn how to configure the server.

At first it was according to tutorial:
https://docs.lucee.org/guides/installing-lucee/installation-linux/linux-ubuntu-quick-video-guide.html
However, in step 4, after configuring the permissions on the installation file, this error is displayed on the console and the installer does not start:

image

I figured it could be a conflict and tried version 5.2 but the result was the same.

So I thought about trying to install from the command line and arrived at this page of the documentation:
https://docs.lucee.org/guides/installing-lucee/installation-linux/launching-the-installer.html
But on this page make me use an installation file with the extension .bin, I looked at the download page of Lucee and I couldn’t find this file anyway I tried to follow the installation guidelines with the .run file and again I had another error.
image

Also in the Lucee documentation I found the session where it talks about how to perform the installation without the GUI and this time with a .run file in the link:
https://docs.lucee.org/guides/installing-lucee/installation-linux/installing-in-unattended-mode.html

image

Again I had the same mistake :frowning:
Because of my little experience in Linux I have no idea what I might be doing wrong, can someone help me?

OS: Ubuntu 20.10

Hi @Bidu. I’m the author of those videos and documentation. Glad to see that these are being used. Never did a PI install, so I really don’t know what is different in your setup.

Some of the pages are outdated and need an overhaul. But the information submitted in those docs still are the best you can get at the moment.

Now to your problem. The error shows “unexpected”, this looks like some type of syntax problem whithin the .run file. What I can also see from one your screenhots above, is a very strange wrong encoding file at /home/cfuser just above the .run file. That file clearly doesn’t appear in the videos and I’ve not seen it in any of my tests before.

Related to your error I’ve found this post at SO. it makes the .run files executable by command line. Maybe that is the issue you are having. I’d give it a try:

I also have another question: Is there any specific reason you want to install those on a raspberrypi for learning? I’d use a VM for this. I’ve created those videos with a Oracle VM VirtualBox and they are great for such learning purposes. You can easily clone virtual machines as a backup, so you can test and play however you want it. And: You can also easily bridge the VM IP address within virtualbox, so you can even access or browse that VM Server from another machine of your home network.

Good morning @andreas ,
Thanks for your videos they taught me a lot :slight_smile:

Come on
I am setting up the server on the raspberrypi for two reasons:
1 - I will leave an application running locally, with a job every 1 hour
2 - This application accesses a specific website and makes a cfhhtp of some data, however this website is protected by “cloudflare” and all my attempts to make a cfhttp from an AWS server are blocked, now leaving my local ip no have problem = /

I tried to perform the procedure to execute, the .run but says that it is not a binary


Is there a place where I can download the binary or is it possible to install with apt get?

What output do you get if you do the folllwing command?:

$ sudo ls –l ./lucee-5.3.6.068-pl0-linux-x64-installer.run

Another approach would be to run Lucee with CommandBox. See Brads post here:

Follow the execution of the command or look at the other post

image

tks

I’d like to see the file permissions of that .run file. Try

$ sudo ls -l

That shall show all file permissions of the directories and files.


in addition to following the chmod commands in the documentation I also adjusted the permission according to your video on Thunar

As for the commandbox, the installation on ubuntu did not work, in the post it is using another OS one with a graphical interface, I will try to look for a little more.

I remember at last having managed to install lucee just by adding a package repository to apt-get, but I couldn’t find the package name

the installation on ubuntu is nearly identical to installation on debian or any other linux distro

sudo killall java
sudo rm -rf /opt/lucee
cd /root
sudo apt-get update
sudo apt-get install apache2 apache2-devel
sudo wget https://cdn.lucee.org/lucee-5.3.7.047-pl0-linux-x64-installer.run
sudo chmod +x lucee-5.3.7.047-pl0-linux-x64-installer.run
sudo /lucee-5.3.7.047-pl0-linux-x64-installer.run

install with defaults

sudo /opt/lucee/lucee_ctl stop
sudo /opt/lucee/lucee_ctl start

@Terry_Whitney thanks for your reply, I followed your commands, but when performing an installation gave the same error

try
sudo ./lucee-5.3.7.047-pl0-linux-x64-installer.run

same
image

Your instance lacks ELF support

first as root (as displayed) try
./lucee-5.3.7.047-pl0-linux-x64-installer.run

if that fails then you will need to go recompile your instance with ELF support.

gave the same message,
do you know how to insert me as i recompile the intance with ELF support?

tks again
image

I am not sure what you mean.

how do i do this:

if that fails then you will need to go recompile your instance with ELF support.

My suggestion is joining a Raspberry PI support group, as ELF binary support on the ARM system is the issue.

You would in essence download everything to run raspberry pi on a Linux OS computer
you would then recompile the support for your custom raspberry pi instance
then export the binary startup and re-flash the hardware with your own custom image.

1 Like

Thanks, for the help I will look for :slight_smile:

1 Like