XmlValidate()

OS: Linux
Java Version: 11
Tomcat Version: 9
Lucee Version: 5.3… latest

I try to validate an XML Document with XMLValidate. I get the following Error.

[Error] :1:165: cvc-elt.1.a: Cannot find the declaration of element ‘’.

This was a function that was working OK until we switched to lucee 5.

I looked into the Documentation:

And found the same error there if you switch the engine to Lucee 5 (works with Lucee 4.5). Before i start digging deep into XML Validation theory, is there something that has changed (or has to be changes in the .xsd File) or is this a general error with this function?

Rolf

I checked this topic and this works in the earlier lucee version after that this issue comes in lucee 5.3 and solved by the ticket [LDEV-2113] xmlValidate Cannot find the declaration of element - Lucee LDEV-2113 with the fixed version of 5.3.4.40 and again this issue starts from lucee version 5.3.7.26-SNAPSHOT. @rolf.anderegg can you file a bug in Jira Projects - Lucee?

so the bug was introduced by [LDEV-2889] allow to use multiple xsd files with XMLValidate - Lucee