Windows Authentication on Lucee datasource?

Hi

Does anyone know how to setup a NT Auth datasource from within Lucee Server
Admin Interface?
How to configure the datasource so that it used NTLM instead of SQL
authentication?

Hi Bilal,

Thanks for answering.
How do I add the integratedSecurity=true to an already existing datasource?
Would it make sense to have this as an configuration option inside the
Lucee interface?

–DavidOn Thursday, May 26, 2016 at 12:34:55 PM UTC+2, Bilal wrote:

David:
Have your tried setting up a jdbc datasource with the integrated
authentication parameter?

https://msdn.microsoft.com/en-us/library/ms378428(v=sql.110).aspx

Nevermind. I solved it.

This is what I did.

  1. Updated the MS JDBC Driver (to be sure that we run the latest one from
    https://msdn.microsoft.com/en-us/library/ms378428(v=sql.110).aspx )

  2. I stopped Lucee

  3. Copied the sqljdbc_auth.dll to C:\lucee\jdk\jre\bin

  4. Copied the sqljdbc42.jar to C:\lucee\lib

  5. Renamed the original file microsoft-sqljdbc.jar
    to microsoft-sqljdbc.jar_old

  6. Renamed sqljdbc42.jar to microsoft-sqljdbc42.jar

  7. Started Lucee

  8. Went to Server Admin interface and created a new datasource (Selected
    Other - JDBC Driver)

  9. class = com.microsoft.jdbc.sqlserver.SQLServerDriver / connection_string
    = jdbc:sqlserver://localhost:1433;databaseName=MY DB
    NAME;integratedSecurity=true;

  10. Submit and check if OK

This worked for me.
Hope this helps anyone in the future.

–DavidOn Thursday, May 26, 2016 at 2:47:34 PM UTC+2, David Eurenius wrote:

Hi Bilal,

Thanks for answering.
How do I add the integratedSecurity=true to an already existing
datasource?
Would it make sense to have this as an configuration option inside the
Lucee interface?

–David

On Thursday, May 26, 2016 at 12:34:55 PM UTC+2, Bilal wrote:

David:
Have your tried setting up a jdbc datasource with the integrated
authentication parameter?

https://msdn.microsoft.com/en-us/library/ms378428(v=sql.110).aspx

Not sure if it is the same for Lucee 5, but Micha has said in the past it
is not enough to rename JAR files, you need to move them elsewhereOn Thursday, 26 May 2016, David Eurenius <@David_Eurenius> wrote:

Nevermind. I solved it.

This is what I did.

  1. Updated the MS JDBC Driver (to be sure that we run the latest one from
    https://msdn.microsoft.com/en-us/library/ms378428(v=sql.110).aspx )

  2. I stopped Lucee

  3. Copied the sqljdbc_auth.dll to C:\lucee\jdk\jre\bin

  4. Copied the sqljdbc42.jar to C:\lucee\lib

  5. Renamed the original file microsoft-sqljdbc.jar
    to microsoft-sqljdbc.jar_old

  6. Renamed sqljdbc42.jar to microsoft-sqljdbc42.jar

  7. Started Lucee

  8. Went to Server Admin interface and created a new datasource (Selected
    Other - JDBC Driver)

  9. class = com.microsoft.jdbc.sqlserver.SQLServerDriver /
    connection_string = jdbc:sqlserver://localhost:1433;databaseName=MY DB
    NAME;integratedSecurity=true;

  10. Submit and check if OK

This worked for me.
Hope this helps anyone in the future.

–David

On Thursday, May 26, 2016 at 2:47:34 PM UTC+2, David Eurenius wrote:

Hi Bilal,

Thanks for answering.
How do I add the integratedSecurity=true to an already existing
datasource?
Would it make sense to have this as an configuration option inside the
Lucee interface?

–David

On Thursday, May 26, 2016 at 12:34:55 PM UTC+2, Bilal wrote:

David:
Have your tried setting up a jdbc datasource with the integrated
authentication parameter?

https://msdn.microsoft.com/en-us/library/ms378428(v=sql.110).aspx


Love Lucee? Become a supporter and be part of the Lucee project today! -
http://lucee.org/supporters/become-a-supporter.html


You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com
<javascript:_e(%7B%7D,‘cvml’,‘lucee%2Bunsubscribe@googlegroups.com’);>.
To post to this group, send email to lucee@googlegroups.com
<javascript:_e(%7B%7D,‘cvml’,‘lucee@googlegroups.com’);>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/6cbb43a4-6876-4bed-a526-a619f4183bc8%40googlegroups.com
https://groups.google.com/d/msgid/lucee/6cbb43a4-6876-4bed-a526-a619f4183bc8%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

AJ Mercer
<webonix:net strength=“Industrial” /> http://webonix.net | <webonix:org
community=“Open” /> http://webonix.org
http://twitter.com/webonix

David:
Have your tried setting up a jdbc datasource with the integrated authentication parameter?

https://msdn.microsoft.com/en-us/library/ms378428(v=sql.110).aspx

Thanks for pointing this out.

Is there a way to see what jar files is currently loaded ?On Friday, May 27, 2016 at 12:25:44 AM UTC+2, AJ Mercer wrote:

Not sure if it is the same for Lucee 5, but Micha has said in the past it
is not enough to rename JAR files, you need to move them elsewhere

On Thursday, 26 May 2016, David Eurenius <david.e...@comintelli.com <javascript:>> wrote:

Nevermind. I solved it.

This is what I did.

  1. Updated the MS JDBC Driver (to be sure that we run the latest one from
    https://msdn.microsoft.com/en-us/library/ms378428(v=sql.110).aspx )

  2. I stopped Lucee

  3. Copied the sqljdbc_auth.dll to C:\lucee\jdk\jre\bin

  4. Copied the sqljdbc42.jar to C:\lucee\lib

  5. Renamed the original file microsoft-sqljdbc.jar
    to microsoft-sqljdbc.jar_old

  6. Renamed sqljdbc42.jar to microsoft-sqljdbc42.jar

  7. Started Lucee

  8. Went to Server Admin interface and created a new datasource (Selected
    Other - JDBC Driver)

  9. class = com.microsoft.jdbc.sqlserver.SQLServerDriver /
    connection_string = jdbc:sqlserver://localhost:1433;databaseName=MY DB
    NAME;integratedSecurity=true;

  10. Submit and check if OK

This worked for me.
Hope this helps anyone in the future.

–David

On Thursday, May 26, 2016 at 2:47:34 PM UTC+2, David Eurenius wrote:

Hi Bilal,

Thanks for answering.
How do I add the integratedSecurity=true to an already existing
datasource?
Would it make sense to have this as an configuration option inside the
Lucee interface?

–David

On Thursday, May 26, 2016 at 12:34:55 PM UTC+2, Bilal wrote:

David:
Have your tried setting up a jdbc datasource with the integrated
authentication parameter?

https://msdn.microsoft.com/en-us/library/ms378428(v=sql.110).aspx


Love Lucee? Become a supporter and be part of the Lucee project today! -
http://lucee.org/supporters/become-a-supporter.html


You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/6cbb43a4-6876-4bed-a526-a619f4183bc8%40googlegroups.com
https://groups.google.com/d/msgid/lucee/6cbb43a4-6876-4bed-a526-a619f4183bc8%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

AJ Mercer
<webonix:net strength=“Industrial” /> http://webonix.net | <webonix:org
community=“Open” /> http://webonix.org
http://twitter.com/webonix

Just to say, I’ve just worked through these instructions and found that
with the latest version of the sqljdbc42.jar, the class name has been
changed to:

com.microsoft.sqlserver.jdbc.SQLServerDriver