Why do I have to put the port number after 127.0.0.1?


#1

Windows 10
Latest Lucee version

When I use Lucee, I have to put it like this http://127.0.0.1:8888/folder/index.cfm
It doesn’t work without the port number included. I searched a while but surprisingly didn’t find the answer.

Am I correct to assume I need something in the apache configuration so that it re directs to Lucee on 8888 for CFM files?

I’m sure this is a common question and an easy fix?

Thanks


#2

Yes. Apache httpd listens on port 80 and should proxy requests with “*.cfm” pattern etc. to Tomcat/Lucee.

If Lucee processes requests on port 8888 properly, but not requests on port 80, then there is a problem with the configuration of Apache httpd.


#3

@LuceeInTheSky Sounds like you’re missing mod_proxy and/or mod_proxy_ajp and/or the ProxyPass configuration in Apache. The following documentation shows how to enable these and configure properly. You don’t need mod_cfml (which dynamically creates hosts in Tomcat based on the request headers of the incoming request) but the pre-requisites for it are the same as Lucee needs so it’s a good guide to follow:

https://viviotech.github.io/mod_cfml/install-win-apache.html

HTH

– Denny


#4

ddspringle,

Just wanted to check back in and say THANKS!

Using the link you provided, I was able to get the issue sorted out in just a few minutes.

Much appreciated!