Upgrade from Lucee 4.5 to 5

Trying to follow the instructions here to upgrade Lucee 4.5 to 5:

http://docs.lucee.org/guides/lucee-5/upgrading-lucee-45.html

This seems to work as far as the service running but I’m no longer able to
access lucee admin or web administrator

Anyone?On Thursday, January 19, 2017 at 1:10:57 PM UTC-5, computer...@gmail.com wrote:

Trying to follow the instructions here to upgrade Lucee 4.5 to 5:

http://docs.lucee.org/guides/lucee-5/upgrading-lucee-45.html

This seems to work as far as the service running but I’m no longer able to
access lucee admin or web administrator

What url’s are you trying? What web server is in front? What port is tomcat running on? Can you access it directly via the port?
Debugging without information is very difficult.

Is there something in your web config stopping it? Does a page with #Now()# actually run?

Mark Drew

CMD
develop • deploy • deliver
http://cmdhq.io+44 7971 852296> On Jan 19, 2017, at 6:10 PM, <@computerservices> wrote:

Trying to follow the instructions here to upgrade Lucee 4.5 to 5:

http://docs.lucee.org/guides/lucee-5/upgrading-lucee-45.html

This seems to work as far as the service running but I’m no longer able to access lucee admin or web administrator


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com
.
To post to this group, send email to lucee@googlegroups.com
.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/9d50a0bf-e20e-4bf2-ae19-567340c0700d%40googlegroups.com
.
For more options, visit https://groups.google.com/d/optout
.

The “sun-answerbook” think is just a label, it’s not saying that’s the process that’s actually listening.

The program you used, nmap, is more a port scanner than a process list. You can get a better process list using the “netstat” command.

netstat -ltpn

The ‘ltpn’ options tell netstat to give you “Listening”, “TCP”, “Program name” and “Numeric Addresses”.

Using netstat, you should see a “java” process listening on port 8888.–
Kind regards,
Jordan Michaels
Vivio Technologies

----- Original Message -----
From: @computerservices
To: “Lucee” lucee@googlegroups.com
Sent: Friday, January 20, 2017 12:50:14 PM
Subject: Re: [Lucee] upgrade from Lucee 4.5 to 5

Well, deductive reasoning. Minutes before I replaced the .jar files, it
actually was tomcat. After I replaced the .jar files, and that being the
ONLY change I made, it should still be tomcat unless the .jar file decided
to start another process on that very port. What do you think? Since you
are a Lucee Core developer, you can probably answer that better than me.
Does the .jar file start any other process on port 8888?

there is also the fact that now after I uninstalled/re-installed and I have
verified that Tomcat is actually responding and I can get the lucee admin
and web, and run the same nmap command, I get the same result:

nmap -sT -O localhost

Starting Nmap 6.40 ( http://nmap.org ) at 2017-01-20 15:47 EST
Nmap scan report for localhost (127.0.0.1)
Host is up (0.00024s latency).
Other addresses for localhost (not scanned): 127.0.0.1
Not shown: 995 closed ports
PORT STATE SERVICE
22/tcp open ssh
80/tcp open http
443/tcp open https
8009/tcp open ajp13
8888/tcp open sun-answerbook

On Friday, January 20, 2017 at 3:38:47 PM UTC-5, Igal wrote:

Tomcat is listening on port 8888. See below

8888/tcp open sun-answerbook

How do you figure that “sun-answerbook” is Tomcat?

Igal Sapir
Lucee Core Developer
Lucee.org http://lucee.org/
On 1/20/2017 12:23 PM, computer...@gmail.com <javascript:> wrote:

there is no firewall running. Please see below:

ufw status
Status: inactive

Tomcat is listening on port 8888. See below

nmap -sT -O localhost

Starting Nmap 6.40 ( http://nmap.org ) at 2017-01-20 14:32 EST
Nmap scan report for localhost (127.0.0.1)
Host is up (0.00026s latency).
Other addresses for localhost (not scanned): 127.0.0.1
Not shown: 995 closed ports
PORT STATE SERVICE
22/tcp open ssh
80/tcp open http
443/tcp open https
8009/tcp open ajp13
8888/tcp open sun-answerbook

Not sure what the problem is. It was working fine until I upgraded to
Lucee 5 and then it just didn’t work anymore. There is a whole thread here
about upgrading to Lucee 5 and the lack of documentation:

https://groups.google.com/forum/#!topic/lucee/8WLinezVYv0

there was no resolution just the usual comments about needing more
information if tomcat is not working. Well obviously, something is causing
Tomcat not to work. Opening a new thread doesn’t seem to help cause nobody
seems to know what’s causing it. So, simply replacing the .jar file is not
enough. So, to anyone who’s thinking about upgrading 4.5 to 5 by following
the docs, DON’T DO IT!!

What I ended up doing is uninstall with the /opt/lucee/uninstall and then
run the install for the new version. That did keep my datasources and
settings.

Cheers

On Friday, January 20, 2017 at 12:20:57 PM UTC-5, Jordan Michaels wrote:

If you can see Tomcat listening to 8888, but cannot access it, then it
sounds like the problem is something like a local firewall.

You can see that Tomcat is specifically listening on port 8888? Using a
netstat or other tool perhaps?


Kind regards,
Jordan Michaels
Vivio Technologies

----- Original Message -----
From: computer...@gmail.com
To: “Lucee” lu...@googlegroups.com
Sent: Friday, January 20, 2017 5:08:46 AM
Subject: Re: [Lucee] upgrade from Lucee 4.5 to 5

the urls I’m trying to access are these:

http://ipaddress:8888/lucee/admin/server.cfm
http://ipaddress:8888/lucee/admin/web.cfm

Tomcat is running on port 8888

I cannot access it at all on that port.

there are no errors in catalina logs. As I mentioned previously, this
server was running Lucee 4.5 without problems. I followed the upgrade
instructions which basically entailed copying the lucee-5.1.0.34.jar in
the
/opt/lucee/lib directory and removing all the rest of the .jar files. The
one odd thing I noticed was that the instructions said do not remove the
lucee-server directory if one is present. Indeed there was a lucee-server
directory in there but it dissapeared as soon I started the lucee
service.
I thought maybe somehow I deleted it when I was deleting the .jar files,
so I restored the lucee-server directory from backup, restarted the
service
and it the directory was gone again.

Everything else seems to be okay. The existing .cfml code on the website
is
being served and no other problems I can see. I just can’t access the
lucee
admin on web contexts.

On Friday, January 20, 2017 at 6:04:57 AM UTC-5, Mark Drew wrote:

What url’s are you trying? What web server is in front? What port is
tomcat running on? Can you access it directly via the port?
Debugging without information is very difficult.

Is there something in your web config stopping it? Does a page with
#Now()# actually run?

Mark Drew

CMD
develop • deploy • deliver

http://cmdhq.io
+44 7971 852296

On Jan 19, 2017, at 6:10 PM, <computer...@gmail.com <javascript:>> wrote:

Trying to follow the instructions here to upgrade Lucee 4.5 to 5:

http://docs.lucee.org/guides/lucee-5/upgrading-lucee-45.html
<
http://www.google.com/url?q=http%3A%2F%2Fdocs.lucee.org%2Fguides%2Flucee-5%2Fupgrading-lucee-45.html&sa=D&sntz=1&usg=AFQjCNGJJyCgFmzMxQbsPQuBSb5oXJNVgg>

This seems to work as far as the service running but I’m no longer able
to
access lucee admin or web administrator


You received this message because you are subscribed to the Google
Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send
an
email to lucee+un...@googlegroups.com <javascript:>.
To post to this group, send email to lu...@googlegroups.com
<javascript:>.
To view this discussion on the web visit

https://groups.google.com/d/msgid/lucee/9d50a0bf-e20e-4bf2-ae19-567340c0700d%40googlegroups.com

<
https://groups.google.com/d/msgid/lucee/9d50a0bf-e20e-4bf2-ae19-567340c0700d%40googlegroups.com?utm_medium=email&utm_source=footer>

.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+un...@googlegroups.com.
To post to this group, send email to lu...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/b78ed26d-afd3-4a59-9b08-c2acb5eea204%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+un...@googlegroups.com <javascript:>.
To post to this group, send email to lu...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/17197c27-51e5-4af3-a254-817435d4de26%40googlegroups.com
https://groups.google.com/d/msgid/lucee/17197c27-51e5-4af3-a254-817435d4de26%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/226b4050-d52f-438a-b885-07893e09287f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hi,Am Donnerstag, 19. Januar 2017 19:10:57 UTC+1 schrieb computer...@gmail.com:

Trying to follow the instructions here to upgrade Lucee 4.5 to 5:

http://docs.lucee.org/guides/lucee-5/upgrading-lucee-45.html

This seems to work as far as the service running but I’m no longer able to
access lucee admin or web administrator

Any error messages? Did you check the logfiles?

Michael