Unterminated quoted string

I am trying my best to get lucee to work on a raspberry pi 3 B. I have the latest apache2 installed as of 4/2/2017 at 10 PM. I download the latest lucee (, chmod to 744, run sudo ./lucee.run and I get an error of:

./lucee.run: 1: ./lucee.run: Syntax error: Unterminated quoted string

Any help?

I’m not sure about that exact error message, but the quickest way to get Lucee running on a Pi is to just use CommandBox. In fact, CommandBox does much of what Apache does so you can even simply your server to just server start. See this entire blog that I run on an RPI2 using Lucee on CommandBox:

If you check out the blog above I even have instructions on setting the server to start on boot.

1 Like

I’ve seen commandbox, haven’t tried it before. I’ve always just used lucee. Do you know if commandbox supports as many cfml tags and options as lucee does?

CommandBox is not a CFML engine, it’s a CLI that does a lot of things, one being the ability to start any CF engine. So basically CommandBox starts servers for you. Lucee 4/5 and Adobe 9, 10, 11, 2016. Actually it starts any Java war, so Jenkins Open BlueDragon, etc whatever you like. So if you start Lucee via CommandBox, it’s like any other Lucee install. Just faster, easier, and with zero install.


1 Like

CommandBox is a clever CLI that embeds the engine of your choice. So for all intents and purposes if you start CommandBox requesting the Lucee engine (the default) you have all the features of that underlying engine available to you.

Updated: bah… too slow. Should have known you would beat me to the punch @bdw429s :wink:

1 Like

I see. So what CFML engine are you starting from commandbox? Looking at your site that you presented in your first post, I don’t see really what CFML engine that you are calling. It seems that it can start a coldfusion server.

Never mind, reading is fundamental. “The CMS in use is ContentBox Modular CMS and is running on the embedded server of CommandBox (Undertow and Lucee).” on your front page. What version of Lucee are you running and how did you download it? I simply did a wget on the x64 installer (the latest version) and when I tried sudo ./lucee.run, I got the error in the first post.

As far as what versions of CF engines that CommandBox can start the answer is any one you want.

CommandBox> start cfengine=lucee@4
CommandBox> start cfengine=lucee@5
CommandBox> start cfengine=adobe@9
CommandBox> start cfengine=adobe@10
CommandBox> start cfengine=adobe@11
CommandBox> start cfengine=adobe@2016
CommandBox> start warPath=myTotallyCustomJ2EEApp.war

In regards to what version of Lucee that pi.bradwood.com is running on-- it’s 4.5 right now, but that’s mostly irrelevant. The point is, I didn’t download or install any version of Lucee. I just asked CommandBox to start it up for me. It does the rest which involves downloading whatever it needs (if anything). The only thing I ever downloaded to my Pi was the binary download of the CommandBox binary which I stuck in /usr/bin/box and away I went.

In regards to your screenshot which you posted above, I’m not sure you’re on the same page. The suggestion to use CommandBox was not a suggestion to get the installer working. It was a complete alternative solution that didn’t involve you using the Lucee installer at all.

Now it’s clicking for me. I was under the impression that commandbox was a launcher for some downloaded program. But now I get that it will download what it needs and then start that server. So, one more question. Can it actually run adobe without an adobe license? I’d rather use adobe since our pages are encoded using CF 2016 encode. I know it’s trivial, but the bigger thing is that we’ve noticed that lucee doesn’t like the allowconcurrent option for cflogin. So if I can run adobe without having to have a license, that might be the best option, otherwise I’ll have to modify the code some to remove any tags or tag options that lucee doesn’t support. Also, how would I set up datasources to connect to a database? I currently use the adobe admin panel, not sure if that would be an option with commandbox starting a server.

The Adobe servers that CommandBox starts are basically developer edition. All the standard EULA restrictions apply so it’s up to you to determine if you’re using this for “production” use or not. You can apply an Adobe license for your CommandBox CF servers just like you would any other Adobe server. I will add I’ve never tested the Adobe servers on my Pi specifically but I would strongly favor Lucee if I were you since it boots much faster and uses much less resources than Adobe ColdFusion.

Lucee has its own admin panel just like Adobe. CommandBox servers work just like any other server and the admin panel is available at the same URL you’d expect. If you’re using CommandBox from a GUI, there’s actually an icon created in your system tray with a menu that will open the server admin for you. For servers started from a CLI with no desktop, you’d just hit the standard URLs. The Lucee server context admin is located at /lucee/admin/server.cfm and the web context admin is at /lucee/admin/web.cfm. If your server is going to be publicly accessible to need to visit both of these URLs and make sure you set the default password!

Regarding the cflogin functionality, is there a ticket logged for that? I would make sure there is, though I wouldn’t get my hopes too high. No one really uses cflogin any longer from what I’ve seen so that tag is unlikely to be a high priority to fix.