Unresolved constraint in bundle org.lucee.httpcomponents.httpclient

I just updated an installation from java 8 to 11 and Tomcat 7 to 9, but it won’t start because of an error I do not know how to resolve. I would expect these dependencies to be resolved in one of the jars in the lib, but no…

`SEVERE: Servlet [RestServlet] in web application threw load() exception
org.osgi.framework.BundleException: Unresolved constraint in bundle org.lucee.httpcomponents.httpclient [3]: Unable to resolve 3.0: missing requirement [3.0] osgi.wiring.package; (osgi.wiring.package=org.apache.commons.logging) [caused by: Unable to resolve 35.0: missing requirement [35.0] osgi.wiring.package; (osgi.wiring.package=org.apache.log4j) [caused by: Unable to resolve 22.0: missing requirement [22.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) [caused by: Unable to resolve 12.0: missing requirement [12.0] osgi.ee; (&(osgi.ee=JavaSE)(version=1.1))]]]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4097)

I hope someone knows a way to resolve this.
Thank you!

Which version of lucee, please always mention which versions are in play, in this case I’m guessing you upgraded an older version?

So it would be really useful to help anyone answer your question :relaxed:

Sorry Zack. I should know better.
I upgraded to Lucee 5.3.7.48. I had some issues with the osapi, and postgres jdbc connectors but those are all fine now, just by updating them in the admin.

I felt self confident enough to upgrade both Java and Tomcat because I had done it before. So changed the jre folder to point to Java 11, and had replaced the tomcat/libs and tomcat/bin folder from the tomcat 9 version. Made sure in that my server.xml I removed the entry for Jasper and added the mod_cfml.jar to my tomcat/lib.

I was using Java 1.8.0_152 (Oracle Corporation) and wanted to use OPEN JDK 11.0.10.

Thanks.

But from which version?

Tomcat 7 is rather ancient, so I guess you might benefit from upgrading your loader jar to something more recent

It ran fine with Lucee 5.3.7.48 on tomcat 7 and java 8. I did an update of Lucee recently, although I don’t know what version I used before but something in 5.3-ish. In /opt/lucee/lib there is a 5.1.0.34.jar although it says Lucee 5.3.7.48 in the admin.

Where would I find the loader.jar? Is that the 5.1.0.34.jar?

Yeah it’s the wrapper for lucee which allows our dynamic updates. Replacing the loader with a recent .jar from the download page might solve your issue

Meanwhile…

Thanks, I decided not to play with the loader.jar. What I did:
I copied a complete installation from another server, and changed the server.xml with the right Host tags, kept the tomcat_connector folder, kept the lucee_server.xml and it did the trick.