Unable to create symbolic link during installation

I am trying to set up a virtual machine on Microsoft Azure running ubuntu server 18.04. When I run the Lucee command-line install (version 5.3.2.077) the progress bar gets to 100%, then sits there for about 5 seconds and then returns the following errors:

Unable to create symbolic link /opt/lucee/jre/legal/java.xml/ADDITIONAL_LICENSE_INFO -> …/java.base/ADDITIONAL_LICENSE_INFO

Unable to create symbolic link /opt/lucee/jre/legal/java.xml/ASSEMBLY_EXCEPTION -> …/java.base/ASSEMBLY_EXCEPTION

Unable to create symbolic link /opt/lucee/jre/legal/java.xml/LICENSE -> …/java.base/LICENSE

Any thoughts on how to rectify this issue would be greatly appreciated.

what user are you running as?

As per the documentation, I am using the below commands to launch the installer:

chmod 744 lucee-5.3.2.077-pl0-linux-x64-installer.run
sudo ./lucee-5.3.2.077-pl0-linux-x64-installer.run

So, I believe it is running the install as root

Further, during the installation process, I selected that Lucee should run as “root”

Has anyone successfully installed Lucee on a Microsoft Azure Linux VM? If so, can you describe the steps taken?

did you check all the paths / files relating to the failed commands exist?

After initially trying the install multiple times on 3 different versions of Linux, it seems that either Microsoft or Lucee has made a change. I tried again from scratch yesterday and the installation went smoothly from start to finish. Thank you, Zac, for taking the time to send some suggestions.

1 Like