Timeout Issues

Hello. I’m trying to process an API request with Lucee. All works well when the processing time is short, but when it runs long because we have to process 1M+ records, I get the error below.

I already tried to set the IIS timeout on the website to 60000 seconds, (20000 seconds via cfsetting). Doesn’t seem to have an effect, it still times out well short of the set limit (maybe 1000 secs or so). The API provider has no way to break up the request with an offset. Its holding up something important, would greatly appreciate any help.

Server Error in ‘/’ Application.

Request timed out.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Web.HttpException: Request timed out.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[HttpException (0x80004005): Request timed out.]

Version Information: Microsoft .NET Framework Version:2.0.50727.8937; ASP.NET Version:2.0.50727.8922

have you tried , cfsetting requesttimeout in the page. not the admin.

Yes is currently on the page

Appears I found a solution I added to web.config:

		<httpRuntime executionTimeout="20000" maxRequestLength="2097151"/>

Which seems to have stop throwing the timeout error, unfortunately now there is another one that I’ll fill out a new ticket on. Its a local data processing machine so it can have these settings to do what it needs ot get the job done. For whatever reason it looks like the site > configure >limits> connection timeout from the IIS interface was being ignored. One thing I don’t understand between ACF and Lucee and how they deal with IIS is how come ACF’s cfsetting tag is absolute and Lucee’s is not. Seems like IIS enforces its own rules much easier in Lucee requests.