The key [passwordserver] does not exist

Lucee attempting to manually update to and I receive the error:

The key [passwordserver] does not exist.  only the following keys are available.

I receive the same error when I display Overview in admin.

Lucee (Velvet)
CF compatability: 2016.0.03.300357
Windows Server 2016 (10.0) 64 bit
Apache Tomcat/8.5.31
Java 1.8.0_172 (Oracle Corporation) 64 bit
Architecture: 64 bit

Hi @mdeak,

I’ve checked in my local & doesn’t able to reproduce the issue. Lucee has been updated successfully from to without any error.

How did you manually updated?

I downloaded the core file (.loc), put it in the patches directory, and restarted the service. Note Lucee would not restart from the admin panel.

I’m experiencing this, trying to upgrade from to

I was experiencing this issue as well and ultimately found out that in my lucee-server.xml config file that the configuration had the parameter of session-type=“j2ee” instead of “application” or “jee”. The server had been updated several times from Lucee 5.0 to now (5.2.9) and I think the value of “j2ee” was an old value that current Lucee isn’t expecting. Once I manually edited lucee-server.xml and set session-type to “application”, restarted Lucee (don’t know if that was really necessary), and tried again then the issue went away.

Thank you for the information. Unfortunately, my \lucee-server\context\lucee-server.xml config file does not have “session-type”, “j2ee”, or “jee” anywhere in it.