Telling Lucee to just inherit TZ information from server

I’m reproducing this from the CFML Slack channel as I didn’t get any feedback there.

I am trying to tell my Lucee server to not maintain its own settings re my timezone, instead just inherit it from the server settings. I cannot find a way to do this on the admin UI, where it requires me to actively tell Lucee what TZ to be in:


There’s a top option “— Server Value —” which one might think is the one, but that seems to just be a label.

My server settings are thus:

root@8c43088668af:/var/www# date
Wed Jun 2 07:46:28 Pacific 2021

In the server admin UI Lucee claims I’m on GMT.

Note: I do not simply want to tell Lucee “use Pacific/Auckland”, I want to tell it *to not maintain that setting itself, at all". So whatever the server TZ setting is: use that. This would be the default behaviour of a JVM-based app, as far as I can tell. It’s certainly how ColdFusion works.

I’m running version, via the stock official Lucee Docker container.


What does the jvm say the timezone is?

OK so this is going the same way as it was on Slack, and seemingly for the same reason.

I am asking where in the UI or in config I can say to Lucee “please don’t set a TZ” (the inference being that it will then perhaps use the system one).

In the UI there is an option to set a TZ. There is no option to UNSET that once it’s set. All I can do is to pick another TZ. So the UI is no use to me I think. Maybe there’s some other UI setting somewhere I’ve not found? Maybe there’s a config setting I can set instead. I don’t know. THIS is what I’m asking.

I’m gonna persist, only if just to annoy you! even if you won’t answer a simple question

what’s does this line look in your lucee-server.xml? before and after you change the settings

<regional locale="en_US" timeserver="" timezone="" use-timeserver="true"/>

1 Like

@AdamCameron This is the default behaviour. By default Docker is UTC and Lucee is set to UTC. If you set an ENV with the name TZ and the value as the timezone you want, it will set the timezone for the container to that and then Lucee will be that.

Without setting the TZ:

Setting the TZ environment var to Pacific/Auckland:

Maybe the issue is you already set it and the admin interface doesn’t have any way to “unset” it. In that case you will need the edit the lucee-server.xml and set the region to not have a timezone:

<regional timeserver="" />

@andrew thanks for clarification. I didn’t know that. Do you think it would be good to have those ENV/Sysprops added to the Lucee Env Sysprops documentation? Even if these are purely Tomcat or Docker env/sysprops, I would add them, because these indeed affect Lucee settings. Maybe we should add such variables that indirectly affects Lucee setup for the default servlet container Tomcat. What do you think @Zackster? Let me know and I’ll add them to the docs.

@andreas I think documenting anything that has an affect, even if indirect like this, is worthwhile. Better to have too much information than not enough :slight_smile:

1 Like

I have added a new page to docs about configuring regional settings.

1 Like

I’ve added a little more details for the Docker TZ environment variable to that page.


Lucee 6 now shows the timezones in the admin