[solved] Lucee Cannot install S3 Extension

I am working on upgrading from 5.3* and have successfully done all apart from installing the S3 extension, after the updgrade it was listed as not installed.
Via the Application admin panel I attemped to install any S3 version and get the following error:

Unable to resolve s3.extension [104](R 104.0): missing requirement [s3.extension [104](R 104.0)] osgi.wiring.bundle; (&(osgi.wiring.bundle=log4j)(bundle-version>=1.2.17)) Unresolved requirements: [[s3.extension [104](R 104.0)] osgi.wiring.bundle; (&(osgi.wiring.bundle=log4j)(bundle-version>=1.2.17))]Lucee was not able to download/load the following bundles [log4j:1.2.17;]

Any clues as to what to do?

Don’t forget to tell us about your stack!

OS: Linux (4.14.252-131.483.amzn1.x86_64)
Java Version: 64bit 1.8.0_92 (Oracle Corporation) 64bit
Tomcat Version: Apache Tomcat/8.0.35
Lucee Version:

Please let me know the Lucee version you had previously used. Have you tried with current s3 version? if not, please share the current version you are using now.

Thanks for the response - Previous working Lucee version is S3 extension was

I tried to install any of the listed versions of S3 in Lucee admin for the new 6.X server, starting with the current highest in Lucee Admin (S3 v2.x) and tried working back, there are only four or five in the available list all generated the same error.

But I didnt try upgrading the S3 before upgrading the Server as a whole. I guess if I have to I could do that but I’m a little further down the line with the update so it would mean starting from scratch again.
I also updated from 5.3.8 s using the “replace the jar file method” rather than the “update via admin” as that seemed problematic too

I currently have a production server (5.3.8) and the dev server 6.x both are on AWS

Been searching for solutions to this but cannot find anything specific. I guess I need to go back to original version and try again?

Solution: SSH into the server, cd to tomcat/lucee-server/deploy
sudo wget https://ext.lucee.org/s3-extension-

And it now works.

1 Like