Sftp with SSH using cfftp


#1

I’m trying to open a connection to a secure FTP server using a RSA key pair.

Adobe cf code would be

<cfset settings = {
	server= 		"remote-connection.com" ,
	user= 		"orangexception" ,
	passphrase=	"theRefreshingException"
	secure= 		1 ,
	directory=		"/" ,
	connection=	"SFTPWithRSAKey" ,
	key=			"e:/xact/path/to/PrivateOpenSSHKey" } />
	
<cfftp action=		"open" 
	connection=	"#settings.connection#"
	server=		"#settings.server#"
	username=	"#settings.user#"
	key=			"#settings.key#"	
	password=		"#settings.passphrase#"
	secure=		"#settings.secure#"
	stopOnError=	"yes"
	retryCount=	1 />

But Lucee does not allow the key= option for cfftp. Instead it has the fingerprint= option.
I tried to open the connection with just the fingerprint, but failed. Is SSH with public/privat Keys supposed to work with Lucee or is it still not supported?


#2

We use JSch for any sFTP Connctions. We don’t use the private key authentification, but the website says it is supported:

http://www.jcraft.com/jsch/


#3

This is worth a look


#4

I’m also using JSch which is working fine with key auth. But we are changing the server so I thought to check out if Lucee might support sFTP with SSH in the mean time.


#5

Vote for this Ticket
https://luceeserver.atlassian.net/browse/LDEV-1003


#6

FYI:
https://luceeserver.atlassian.net/browse/LDEV-1003 is fixed for Lucee 5.2.7.38