Setting an access (mdb file) datasource

I tried to set an access (mdb file) datasource.
I have set a datasource in the Windows ODBC panel
Then I declared a datasouce in Lucee with JDBC-ODBC bridge
then I gave a name and the database name,
(I do not know what is the database name ? is that the ODBC created name)
And whatever database name I gave , i had this error :

can’t find class [sun.jdbc.odbc.JdbcOdbcDriver] for jdbc driver, check if
driver (jar file) is inside lib folder (cannot load class through its
string name, because no definition for the class with the specified name
[sun.jdbc.odbc.JdbcOdbcDriver] could be found)

It seems the JdbcOdbcDriver files are not found ?

Thanks for help.
Pierre.

Java version installed is 1.8.
I will not return to 1.7 now.
I will try to find a solution with UcanAccess
Thanks.Le mercredi 20 janvier 2016 03:07:16 UTC+1, ADK a écrit :

Which version of Java are you using? Support for the JDBC-ODBC Bridge was
removed in version 1.8 so you need to be on 1.7 or earlier…

On Tuesday, January 19, 2016 at 10:15:59 AM UTC-8, Pierre Larde wrote:

I tried to set an access (mdb file) datasource.
I have set a datasource in the Windows ODBC panel
Then I declared a datasouce in Lucee with JDBC-ODBC bridge
then I gave a name and the database name,
(I do not know what is the database name ? is that the ODBC created name)
And whatever database name I gave , i had this error :

can’t find class [sun.jdbc.odbc.JdbcOdbcDriver] for jdbc driver, check if
driver (jar file) is inside lib folder (cannot load class through its
string name, because no definition for the class with the specified name
[sun.jdbc.odbc.JdbcOdbcDriver] could be found)

It seems the JdbcOdbcDriver files are not found ?

Thanks for help.
Pierre.

For Railo/Lucee
Put all the JAR files from the UCanAccess zip file into c:/lucee/lib or
(C:/railo/lib).
remove if then exixt hypersonic-hsqldb.jar (old hsqldb driver).

First method
In server - admin - Services - Datasource
create new datasource:
name: datasource:name
class: net.ucanaccess.jdbc.UcanaccessDriver
Connection String:*
jdbc:ucanaccess://C:/path_to_zour_site_root/base/name_of_access_base.accdb
(or .mdb)

Second method

Create* Applicaton.cfc* in site root, and put this:
component output=“false”{

this.name = “application-name”; // name of the application

this.datasources[“datasource_name”] = { class:
‘net.ucanaccess.jdbc.UcanaccessDriver’ , connectionString:
‘jdbc:ucanaccess://path_to_zour_site_root/base/name_of_access_base.accd’ };
}

Test *
Create
test.cfm* and put in:



and tray: localhost:8888/root_of_site/test.cfm

I hope I helped

Could you help me in implementing this UCanAccess pack.
Where to put the files, and what to do.
UCanAcces have 1 jar file and a lib with 4 jar files.
What to do with ? Should they go into Java, or Tomcat or Lucee.
And then how to declare a datasource in Lucee admin ?

Thanks a lot for assistance.
Pierre.Le mercredi 20 janvier 2016 11:22:56 UTC+1, Milan Marković a écrit :

Try it UCanAccess – pure Java JDBC Driver implementation which allows java
developers and jdbc client programs to read/write Microsoft Access database
(.mdb and .accdb files). No ODBC needed.
http://sourceforge.net/projects/ucanaccess/

уторак, 19. јануар 2016. 19.15.59 UTC+1, Pierre Larde је написао/ла:

I tried to set an access (mdb file) datasource.
I have set a datasource in the Windows ODBC panel
Then I declared a datasouce in Lucee with JDBC-ODBC bridge
then I gave a name and the database name,
(I do not know what is the database name ? is that the ODBC created name)
And whatever database name I gave , i had this error :

can’t find class [sun.jdbc.odbc.JdbcOdbcDriver] for jdbc driver, check if
driver (jar file) is inside lib folder (cannot load class through its
string name, because no definition for the class with the specified name
[sun.jdbc.odbc.JdbcOdbcDriver] could be found)

It seems the JdbcOdbcDriver files are not found ?

Thanks for help.
Pierre.

уторак, 19. јануар 2016. 19.15.59 UTC+1, Pierre Larde је написао/ла:

I tried to set an access (mdb file) datasource.
I have set a datasource in the Windows ODBC panel
Then I declared a datasouce in Lucee with JDBC-ODBC bridge
then I gave a name and the database name,
(I do not know what is the database name ? is that the ODBC created name)
And whatever database name I gave , i had this error :

can’t find class [sun.jdbc.odbc.JdbcOdbcDriver] for jdbc driver, check if
driver (jar file) is inside lib folder (cannot load class through its
string name, because no definition for the class with the specified name
[sun.jdbc.odbc.JdbcOdbcDriver] could be found)

It seems the JdbcOdbcDriver files are not found ?

Thanks for help.
Pierre.

Which version of Java are you using? Support for the JDBC-ODBC Bridge was
removed in version 1.8 so you need to be on 1.7 or earlier…On Tuesday, January 19, 2016 at 10:15:59 AM UTC-8, Pierre Larde wrote:

I tried to set an access (mdb file) datasource.
I have set a datasource in the Windows ODBC panel
Then I declared a datasouce in Lucee with JDBC-ODBC bridge
then I gave a name and the database name,
(I do not know what is the database name ? is that the ODBC created name)
And whatever database name I gave , i had this error :

can’t find class [sun.jdbc.odbc.JdbcOdbcDriver] for jdbc driver, check if
driver (jar file) is inside lib folder (cannot load class through its
string name, because no definition for the class with the specified name
[sun.jdbc.odbc.JdbcOdbcDriver] could be found)

It seems the JdbcOdbcDriver files are not found ?

Thanks for help.
Pierre.

Try it UCanAccess – pure Java JDBC Driver implementation which allows java
developers and jdbc client programs to read/write Microsoft Access database
(.mdb and .accdb files). No ODBC needed.

уторак, 19. јануар 2016. 19.15.59 UTC+1, Pierre Larde је написао/ла:

I tried to set an access (mdb file) datasource.
I have set a datasource in the Windows ODBC panel
Then I declared a datasouce in Lucee with JDBC-ODBC bridge
then I gave a name and the database name,
(I do not know what is the database name ? is that the ODBC created name)
And whatever database name I gave , i had this error :

can’t find class [sun.jdbc.odbc.JdbcOdbcDriver] for jdbc driver, check if
driver (jar file) is inside lib folder (cannot load class through its
string name, because no definition for the class with the specified name
[sun.jdbc.odbc.JdbcOdbcDriver] could be found)

It seems the JdbcOdbcDriver files are not found ?

Thanks for help.
Pierre.

уторак, 19. јануар 2016. 19.15.59 UTC+1, Pierre Larde је написао/ла:>

I tried to set an access (mdb file) datasource.
I have set a datasource in the Windows ODBC panel
Then I declared a datasouce in Lucee with JDBC-ODBC bridge
then I gave a name and the database name,
(I do not know what is the database name ? is that the ODBC created name)
And whatever database name I gave , i had this error :

can’t find class [sun.jdbc.odbc.JdbcOdbcDriver] for jdbc driver, check if
driver (jar file) is inside lib folder (cannot load class through its
string name, because no definition for the class with the specified name
[sun.jdbc.odbc.JdbcOdbcDriver] could be found)

It seems the JdbcOdbcDriver files are not found ?

Thanks for help.
Pierre.

Thanks a lot for help.

No success for the moment.

I have located the jar files in c:\Program Files\Lucee\

That’s where all lucee jar files are,

And I found there : hypersonic-hsqldb.jar

Which I renamed to : hypersonic-hsqldb_old.jar (so not usable)

I left the files like :

ucanaccess-3.0.3.1.jar and its lib as sub-directory

When I declared the datasource in Lucee (first method), I got this message :

Could not initialize class net.ucanaccess.jdbc.UcanaccessDriver

Do you think some files are not located correctly ?

Thanks for any advise.

Pierre.De : lucee@googlegroups.com [mailto:lucee@googlegroups.com] De la part de Milan Markovic
Envoyé : mercredi 20 janvier 2016 21:13
À : Lucee
Objet : [Lucee] Re: setting an access (mdb file) datasource

For Railo/Lucee

Put all the JAR files from the UCanAccess zip file into c:/lucee/lib or (C:/railo/lib).

remove if then exixt hypersonic-hsqldb.jar (old hsqldb driver).

First method

In server - admin - Services - Datasource

create new datasource:

name: datasource:name
class: net.ucanaccess.jdbc.UcanaccessDriver
Connection String: jdbc:ucanaccess://C:/path_to_zour_site_root/base/name_of_access_base.accdb (or *.mdb)

Second method

Create Applicaton.cfc in site root, and put this:

component output=“false”{

this.name = “application-name”; // name of the application

this.datasources[“datasource_name”] = { class: ‘net.ucanaccess.jdbc.UcanaccessDriver’ , connectionString: ‘jdbc:ucanaccess://path_to_zour_site_root/base/name_of_access_base.accd’ };
}

Test

Create test.cfm and put in:



and tray: localhost:8888/root_of_site/test.cfm

I hope I helped


Love Lucee? Become a supporter and be part of the Lucee project today! - http://lucee.org/supporters/become-a-supporter.html

You received this message because you are subscribed to a topic in the Google Groups “Lucee” group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/lucee/gA3NuJLWxvo/unsubscribe.
To unsubscribe from this group and all its topics, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/01b54bc1-0e49-4467-b1ec-06bda240f25f%40googlegroups.com https://groups.google.com/d/msgid/lucee/01b54bc1-0e49-4467-b1ec-06bda240f25f%40googlegroups.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


L’absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
http://www.avast.com

Pierre,

It may be better to remove the old jar completely, or at least change the
extension of the old file.

Aria Media Sagl
+41 (0)76 303 4477 cell
skype: ariamediaOn Thu, Jan 21, 2016 at 8:23 PM, Milan Marković <@Milan_Markovic> wrote:

Hi Pierre,

put all jar files:

  • ucanaccess-3.0.3.1.jar
  • jackcess-2.0.0.jar
  • commons-lang-2.4.jar
  • commons-logging-1.0.4.jar
  • hsqldb.jar

in your lucee install folder c:\Program Files\Lucee\lib.

Rename hypersonic-hsqldb.jar to hypersonic-hsqldb.jar.old.or remove it.
Restart lucee server and check.

Milan


Love Lucee? Become a supporter and be part of the Lucee project today! -
http://lucee.org/supporters/become-a-supporter.html

You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/a1c826a3-b17e-4172-8e35-654ed22ca12e%40googlegroups.com
https://groups.google.com/d/msgid/lucee/a1c826a3-b17e-4172-8e35-654ed22ca12e%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

Hi Pierre,

put all jar files:

  • ucanaccess-3.0.3.1.jar
  • jackcess-2.0.0.jar
  • commons-lang-2.4.jar
  • commons-logging-1.0.4.jar
  • hsqldb.jar

in your lucee install folder c:\Program Files\Lucee\lib.

Rename hypersonic-hsqldb.jar to hypersonic-hsqldb.jar.old.or remove it.
Restart lucee server and check.

Milan

Well,
I stopped Tomcat
I removed “hypersonic.hsqldb.jar”
All ucanaccess jar files are in : c:\program files\lucee\lib
I restart Tomcat (as Windows service)
Then, when going to Lucee admin, I got this error message (about hsqldb)
Etat HTTP 500 - cannot load class through its string name, because no
definition for the class with the specified name [org.hsqldb.jdbcDriver]
could be found
Tomcat wants this driver ?

May be some declaration line to modifiy in Tomcat config files ?

Thanks for any advise,
Pierre.Le jeudi 21 janvier 2016 22:05:05 UTC+1, Nando Breiter a écrit :

Pierre,

It may be better to remove the old jar completely, or at least change the
extension of the old file.

Aria Media Sagl
+41 (0)76 303 4477 cell
skype: ariamedia

On Thu, Jan 21, 2016 at 8:23 PM, Milan Marković <milanb...@gmail.com <javascript:>> wrote:

Hi Pierre,

put all jar files:

  • ucanaccess-3.0.3.1.jar
  • jackcess-2.0.0.jar
  • commons-lang-2.4.jar
  • commons-logging-1.0.4.jar
  • hsqldb.jar

in your lucee install folder c:\Program Files\Lucee\lib.

Rename hypersonic-hsqldb.jar to hypersonic-hsqldb.jar.old.or remove it.
Restart lucee server and check.

Milan


Love Lucee? Become a supporter and be part of the Lucee project today! -
http://lucee.org/supporters/become-a-supporter.html

You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+un...@googlegroups.com <javascript:>.
To post to this group, send email to lu...@googlegroups.com <javascript:>
.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/a1c826a3-b17e-4172-8e35-654ed22ca12e%40googlegroups.com
https://groups.google.com/d/msgid/lucee/a1c826a3-b17e-4172-8e35-654ed22ca12e%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

OK, sorry,

I did not notice the new “hsqldb.jar”,

Make sense , it must replace the old one at same place.

So all ucanaccess jar files are in c:\program files\lucee (not in a lib dir)

I restarted Tomcat, OK

I declared the datasource,

AND IT WORKS , GREAT.

I will able to use Lucee, now,

Last thing to check , is the search engine.

(all my sites use Access, small sites with few users or information systems,

Also I may have many access mdb files for a single site, for different functions)

Access is simple and very flexible. For the moment, I never have the obligation to upgrade to MySQL or MSSql.

Thanks a lot, Pierre.De : lucee@googlegroups.com [mailto:lucee@googlegroups.com] De la part de Milan Markovic
Envoyé : vendredi 22 janvier 2016 12:27
À : Lucee
Objet : [Lucee] Re: setting an access (mdb file) datasource

Are you sure you’re all jar copied to the folder where it was old hypersonic-hsqldb.jar?

Milan


Love Lucee? Become a supporter and be part of the Lucee project today! - http://lucee.org/supporters/become-a-supporter.html

You received this message because you are subscribed to a topic in the Google Groups “Lucee” group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/lucee/gA3NuJLWxvo/unsubscribe.
To unsubscribe from this group and all its topics, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/80e822a5-7055-48bf-aad7-5bf97902e8ce%40googlegroups.com https://groups.google.com/d/msgid/lucee/80e822a5-7055-48bf-aad7-5bf97902e8ce%40googlegroups.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


L’absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
http://www.avast.com

Are you sure you’re all jar copied to the folder where it was
old hypersonic-hsqldb.jar?

Milan

Hi Pierre,

    1. Perform a “Compact and Repair Database” on the database, and try
      again.

if dont work:

    1. You must change collation mode to general on the database, and
      again compact and repair

нед, 31. јан 2016. у 21.53 Pierre Larde <@Pierre_Larde> је написао/ла:> Using Ucanaccess driver to work with mdb files :

most of the queries work,
I just took a site from Coldfusion to Lucee (no change of code)
And I got this Ucanaccess error message :

Lucee 4.5.2.018 Error (database)
Message UCAExc:::3.0.3.1 Cannot write indexes of this type due to
unsupported collating sort order SortOrder[1036(0)] for text index
(Db=nadinefrance.mdb;Table=famille;Index=0)
SQL
update famille
set nb_prod=3
where id_fam=10
DatabaseName Ucanaccess for access db(Jet) using hasqldb
DatabaseVersion V2000 [VERSION_4]
DriverName Ucanaccess
DriverVersion

3.0.3.1

The SQL is very simple :

update famille
set nb_prod=3
where id_fam=10

Thanks for any help.
Pierre

Le jeudi 21 janvier 2016 20:23:30 UTC+1, Milan Marković a écrit :

Hi Pierre,

put all jar files:

  • ucanaccess-3.0.3.1.jar
  • jackcess-2.0.0.jar
  • commons-lang-2.4.jar
  • commons-logging-1.0.4.jar
  • hsqldb.jar

in your lucee install folder c:\Program Files\Lucee\lib.

Rename hypersonic-hsqldb.jar to hypersonic-hsqldb.jar.old.or remove it.
Restart lucee server and check.

Milan


Love Lucee? Become a supporter and be part of the Lucee project today! -
http://lucee.org/supporters/become-a-supporter.html


You received this message because you are subscribed to a topic in the
Google Groups “Lucee” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/lucee/gA3NuJLWxvo/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/abc048a8-2a87-4ce9-a119-6a90d9e6d90d%40googlegroups.com
https://groups.google.com/d/msgid/lucee/abc048a8-2a87-4ce9-a119-6a90d9e6d90d%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

Using Ucanaccess driver to work with mdb files :
most of the queries work,
I just took a site from Coldfusion to Lucee (no change of code)
And I got this Ucanaccess error message :

Lucee 4.5.2.018 Error (database)
Message UCAExc:::3.0.3.1 Cannot write indexes of this type due to
unsupported collating sort order SortOrder[1036(0)] for text index
(Db=nadinefrance.mdb;Table=famille;Index=0)
SQL
update famille
set nb_prod=3
where id_fam=10
DatabaseName Ucanaccess for access db(Jet) using hasqldb
DatabaseVersion V2000 [VERSION_4]
DriverName Ucanaccess
DriverVersion

3.0.3.1

The SQL is very simple :

update famille
set nb_prod=3
where id_fam=10

Thanks for any help.
PierreLe jeudi 21 janvier 2016 20:23:30 UTC+1, Milan Marković a écrit :

Hi Pierre,

put all jar files:

  • ucanaccess-3.0.3.1.jar
  • jackcess-2.0.0.jar
  • commons-lang-2.4.jar
  • commons-logging-1.0.4.jar
  • hsqldb.jar

in your lucee install folder c:\Program Files\Lucee\lib.

Rename hypersonic-hsqldb.jar to hypersonic-hsqldb.jar.old.or remove it.
Restart lucee server and check.

Milan

Thanks for these links.
Problem is solved :

I did modify in Access “options” : the sort order from “Français” to
“general”
Then compact the database.
(I did it in the original version .mdb , 2002)

And all queries are working (update and insert)

So the change of field type from “long integer” to “integer” was not the
solution.
Also, depending of the Acces version , the “options” button is difficult to
find.
(diiferent places with different versions)Le lundi 1 février 2016 22:03:22 UTC+1, Pierre Larde a écrit :

I get again the same error message :
Message UCAExc:::3.0.3.1 Cannot write indexes of this type due to
unsupported collating sort order SortOrder[1036(0)] for text index
(Db=nadinefrance.mdb;Table=famille;Index=0)
SQL
insert into famille
(apellation_fam,description_fam,active_fam,order_fam,famille_fam,date_crea)
values (‘Ppp’,‘Ppp’,1,17,0,{d ‘2016-02-01’})
DatabaseName Ucanaccess for access db(Jet) using hasqldb
DatabaseVersion V2000 [VERSION_4]
DriverName Ucanaccess
DriverVersion 3.0.3.1
Datasource C013_nadinefrance

Stacktrace …

The Error Occurred in
C:\Tomcat\webapps\ROOT\sites\nadinefrance\admin_photo\create_famille_save.cfm:
line 60

58:
(apellation_fam,description_fam,active_fam,order_fam,famille_fam,date_crea)
59: values
(’#form.fam_name#’,’#form.fam_des#’,#act#,#next_order#,#parent#,#createodbcdate(now())#)
60:
61:
62:

I did change all numeric long integer fields to numeric integer.
This solved the problem, the first time.
But now I get it again.
I do not see what I can do.

Thank you far any advise, help, support in using the Ucanaccess driver.
(this problem appear in update and insert SQL)

Le lundi 1 février 2016 13:18:14 UTC+1, Pierre Larde a écrit :

Thanks for your answer,

Compact and repair database did not solve the problem.

I found the problem by modifying the field type from :

“Numeric long integer” to “Numeric integer” (not long)

This is OK for the 32000 maximum value (I do not need more).

Could you help on “collation mode to general on the database” , I never
used this.

What is this concept, Is that to do with field types ?

Also, for information, in spite of the error message,

The SQL was been done, the update was done, but the process stopped with
the error.

Thanks again for assistance.

Pierre.

De : lucee@googlegroups.com [mailto:lucee@googlegroups.com] De la
part de
Milan Markovic
Envoyé : lundi 1 février 2016 00:36
À : Lucee
Objet : Re: [Lucee] Re: setting an access (mdb file) datasource

Hi Pierre,

    1. Perform a “Compact and Repair Database” on the database, and try
      again.

if dont work:

    1. You must change collation mode to general on the database, and
      again compact and repair

нед, 31. јан 2016. у 21.53 Pierre Larde <@Pierre_Larde> је
написао/ла:

Using Ucanaccess driver to work with mdb files :

most of the queries work,

I just took a site from Coldfusion to Lucee (no change of code)

And I got this Ucanaccess error message :

Lucee 4.5.2.018 Error (database)

Message

UCAExc:::3.0.3.1 Cannot write indexes of this type due to unsupported
collating sort order SortOrder[1036(0)] for text index
(Db=nadinefrance.mdb;Table=famille;Index=0)

SQL

update famille
set nb_prod=3
where id_fam=10

DatabaseName

Ucanaccess for access db(Jet) using hasqldb

DatabaseVersion

V2000 [VERSION_4]

DriverName

Ucanaccess

DriverVersion

3.0.3.1

The SQL is very simple :

update famille
set nb_prod=3
where id_fam=10

Thanks for any help.

Pierre

Le jeudi 21 janvier 2016 20:23:30 UTC+1, Milan Marković a écrit :

Hi Pierre,

put all jar files:

  • ucanaccess-3.0.3.1.jar
  • jackcess-2.0.0.jar
  • commons-lang-2.4.jar
  • commons-logging-1.0.4.jar
  • hsqldb.jar

in your lucee install folder c:\Program Files\Lucee\lib.

Rename hypersonic-hsqldb.jar to hypersonic-hsqldb.jar.old.or remove it.

Restart lucee server and check.

Milan


Love Lucee? Become a supporter and be part of the Lucee project today! -
http://lucee.org/supporters/become-a-supporter.html

You received this message because you are subscribed to a topic in the
Google Groups “Lucee” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/lucee/gA3NuJLWxvo/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/abc048a8-2a87-4ce9-a119-6a90d9e6d90d%40googlegroups.com
https://groups.google.com/d/msgid/lucee/abc048a8-2a87-4ce9-a119-6a90d9e6d90d%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.


Love Lucee? Become a supporter and be part of the Lucee project today! -
http://lucee.org/supporters/become-a-supporter.html

You received this message because you are subscribed to a topic in the
Google Groups “Lucee” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/lucee/gA3NuJLWxvo/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/CAJc2C%2BZGcB6aKJJdpCfjfUcGURgc63vZ8H_UF64FsvhSvknCDw%40mail.gmail.com
https://groups.google.com/d/msgid/lucee/CAJc2C%2BZGcB6aKJJdpCfjfUcGURgc63vZ8H_UF64FsvhSvknCDw%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.


[image: Avast logo] http://www.avast.com/

L’absence de virus dans ce courrier électronique a été vérifiée par le
logiciel antivirus Avast.
www.avast.com

I get again the same error message :
Message UCAExc:::3.0.3.1 Cannot write indexes of this type due to
unsupported collating sort order SortOrder[1036(0)] for text index
(Db=nadinefrance.mdb;Table=famille;Index=0)
SQL
insert into famille
(apellation_fam,description_fam,active_fam,order_fam,famille_fam,date_crea)
values (‘Ppp’,‘Ppp’,1,17,0,{d ‘2016-02-01’})
DatabaseName Ucanaccess for access db(Jet) using hasqldb
DatabaseVersion V2000 [VERSION_4]
DriverName Ucanaccess
DriverVersion 3.0.3.1
Datasource C013_nadinefrance

Stacktrace …

The Error Occurred in
C:\Tomcat\webapps\ROOT\sites\nadinefrance\admin_photo\create_famille_save.cfm:
line 60

58:
(apellation_fam,description_fam,active_fam,order_fam,famille_fam,date_crea)
59: values
(’#form.fam_name#’,’#form.fam_des#’,#act#,#next_order#,#parent#,#createodbcdate(now())#)
60:
61:
62:

I did change all numeric long integer fields to numeric integer.
This solved the problem, the first time.
But now I get it again.
I do not see what I can do.

Thank you far any advise, help, support in using the Ucanaccess driver.
(this problem appear in update and insert SQL)Le lundi 1 février 2016 13:18:14 UTC+1, Pierre Larde a écrit :

Thanks for your answer,

Compact and repair database did not solve the problem.

I found the problem by modifying the field type from :

“Numeric long integer” to “Numeric integer” (not long)

This is OK for the 32000 maximum value (I do not need more).

Could you help on “collation mode to general on the database” , I never
used this.

What is this concept, Is that to do with field types ?

Also, for information, in spite of the error message,

The SQL was been done, the update was done, but the process stopped with
the error.

Thanks again for assistance.

Pierre.

De : lucee@googlegroups.com [mailto:lucee@googlegroups.com] De la part
de
Milan Markovic
Envoyé : lundi 1 février 2016 00:36
À : Lucee
Objet : Re: [Lucee] Re: setting an access (mdb file) datasource

Hi Pierre,

    1. Perform a “Compact and Repair Database” on the database, and try
      again.

if dont work:

    1. You must change collation mode to general on the database, and
      again compact and repair

нед, 31. јан 2016. у 21.53 Pierre Larde <@Pierre_Larde> је
написао/ла:

Using Ucanaccess driver to work with mdb files :

most of the queries work,

I just took a site from Coldfusion to Lucee (no change of code)

And I got this Ucanaccess error message :

Lucee 4.5.2.018 Error (database)

Message

UCAExc:::3.0.3.1 Cannot write indexes of this type due to unsupported
collating sort order SortOrder[1036(0)] for text index
(Db=nadinefrance.mdb;Table=famille;Index=0)

SQL

update famille
set nb_prod=3
where id_fam=10

DatabaseName

Ucanaccess for access db(Jet) using hasqldb

DatabaseVersion

V2000 [VERSION_4]

DriverName

Ucanaccess

DriverVersion

3.0.3.1

The SQL is very simple :

update famille
set nb_prod=3
where id_fam=10

Thanks for any help.

Pierre

Le jeudi 21 janvier 2016 20:23:30 UTC+1, Milan Marković a écrit :

Hi Pierre,

put all jar files:

  • ucanaccess-3.0.3.1.jar
  • jackcess-2.0.0.jar
  • commons-lang-2.4.jar
  • commons-logging-1.0.4.jar
  • hsqldb.jar

in your lucee install folder c:\Program Files\Lucee\lib.

Rename hypersonic-hsqldb.jar to hypersonic-hsqldb.jar.old.or remove it.

Restart lucee server and check.

Milan


Love Lucee? Become a supporter and be part of the Lucee project today! -
http://lucee.org/supporters/become-a-supporter.html

You received this message because you are subscribed to a topic in the
Google Groups “Lucee” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/lucee/gA3NuJLWxvo/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/abc048a8-2a87-4ce9-a119-6a90d9e6d90d%40googlegroups.com
https://groups.google.com/d/msgid/lucee/abc048a8-2a87-4ce9-a119-6a90d9e6d90d%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.


Love Lucee? Become a supporter and be part of the Lucee project today! -
http://lucee.org/supporters/become-a-supporter.html

You received this message because you are subscribed to a topic in the
Google Groups “Lucee” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/lucee/gA3NuJLWxvo/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/CAJc2C%2BZGcB6aKJJdpCfjfUcGURgc63vZ8H_UF64FsvhSvknCDw%40mail.gmail.com
https://groups.google.com/d/msgid/lucee/CAJc2C%2BZGcB6aKJJdpCfjfUcGURgc63vZ8H_UF64FsvhSvknCDw%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.


[image: Avast logo] http://www.avast.com/

L’absence de virus dans ce courrier électronique a été vérifiée par le
logiciel antivirus Avast.
www.avast.com

Thanks for your answer,

Compact and repair database did not solve the problem.

I found the problem by modifying the field type from :

“Numeric long integer” to “Numeric integer” (not long)

This is OK for the 32000 maximum value (I do not need more).

Could you help on “collation mode to general on the database” , I never used this.

What is this concept, Is that to do with field types ?

Also, for information, in spite of the error message,

The SQL was been done, the update was done, but the process stopped with the error.

Thanks again for assistance.

Pierre.De : lucee@googlegroups.com [mailto:lucee@googlegroups.com] De la part de Milan Markovic
Envoyé : lundi 1 février 2016 00:36
À : Lucee
Objet : Re: [Lucee] Re: setting an access (mdb file) datasource

Hi Pierre,

    1. Perform a “Compact and Repair Database” on the database, and try again.

if dont work:

    1. You must change collation mode to general on the database, and again compact and repair

нед, 31. јан 2016. у 21.53 Pierre Larde <@Pierre_Larde> је написао/ла:

Using Ucanaccess driver to work with mdb files :

most of the queries work,

I just took a site from Coldfusion to Lucee (no change of code)

And I got this Ucanaccess error message :

Lucee 4.5.2.018 Error (database)

Message

UCAExc:::3.0.3.1 Cannot write indexes of this type due to unsupported collating sort order SortOrder[1036(0)] for text index (Db=nadinefrance.mdb;Table=famille;Index=0)

SQL

update famille
set nb_prod=3
where id_fam=10

DatabaseName

Ucanaccess for access db(Jet) using hasqldb

DatabaseVersion

V2000 [VERSION_4]

DriverName

Ucanaccess

DriverVersion

3.0.3.1

The SQL is very simple :

update famille
set nb_prod=3
where id_fam=10

Thanks for any help.

Pierre

Le jeudi 21 janvier 2016 20:23:30 UTC+1, Milan Marković a écrit :

Hi Pierre,

put all jar files:

  • ucanaccess-3.0.3.1.jar
  • jackcess-2.0.0.jar
  • commons-lang-2.4.jar
  • commons-logging-1.0.4.jar
  • hsqldb.jar

in your lucee install folder c:\Program Files\Lucee\lib.

Rename hypersonic-hsqldb.jar to hypersonic-hsqldb.jar.old.or remove it.

Restart lucee server and check.

Milan


Love Lucee? Become a supporter and be part of the Lucee project today! - http://lucee.org/supporters/become-a-supporter.html

You received this message because you are subscribed to a topic in the Google Groups “Lucee” group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/lucee/gA3NuJLWxvo/unsubscribe.
To unsubscribe from this group and all its topics, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/abc048a8-2a87-4ce9-a119-6a90d9e6d90d%40googlegroups.com https://groups.google.com/d/msgid/lucee/abc048a8-2a87-4ce9-a119-6a90d9e6d90d%40googlegroups.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


Love Lucee? Become a supporter and be part of the Lucee project today! - http://lucee.org/supporters/become-a-supporter.html

You received this message because you are subscribed to a topic in the Google Groups “Lucee” group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/lucee/gA3NuJLWxvo/unsubscribe.
To unsubscribe from this group and all its topics, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/CAJc2C%2BZGcB6aKJJdpCfjfUcGURgc63vZ8H_UF64FsvhSvknCDw%40mail.gmail.com https://groups.google.com/d/msgid/lucee/CAJc2C%2BZGcB6aKJJdpCfjfUcGURgc63vZ8H_UF64FsvhSvknCDw%40mail.gmail.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


L’absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
http://www.avast.com

Hi Pierre,

See the following links:

http://stackoverflow.com/questions/3601107/ms-access-2010-collating-sequence-not-supported-with-the-specified-file-format

http://stackoverflow.com/questions/3601107/ms-access-2010-collating-sequence-not-supported-with-the-specified-file-format
2. https://support.microsoft.com/en-us/kb/202150
3.
https://support.office.com/en-us/article/Select-settings-for-how-data-is-displayed-and-stored-in-your-database-8bea8d24-5673-4faa-a587-cd236fd11f9a?CorrelationId=53d32cf0-1335-4c8c-be5e-6275d26e52ea&ui=en-US&rs=en-US&ad=US#bm2
4.
http://stackoverflow.com/questions/20719417/unsupported-collating-sort-order-when-trying-to-read-from-access-using-jackces

Thanks a lot,

Yes with all files, it does work.

Great.

I will check more deeply tomorrow.

Thanks again,

Pierre.Le mardi 7 juin 2016 16:18:15 UTC+2, Milan Marković a écrit :

Hi Pierre,
put all jar files from ucanaccess.zip:

  • ucanaccess-3.0.3.1.jar
  • jackcess-2.0.0.jar
  • commons-lang-2.4.jar
  • commons-logging-1.0.4.jar
  • hsqldb.jar

in your lucee lib folder.

Restart lucee server and check.

Milan

Hi Pierre,
put all jar files from ucanaccess.zip:

  • ucanaccess-3.0.3.1.jar
  • jackcess-2.0.0.jar
  • commons-lang-2.4.jar
  • commons-logging-1.0.4.jar
  • hsqldb.jar

in your lucee lib folder.

Restart lucee server and check.> Milan