Set directory permission on linux

Under Linux environment ,
I create a directory with “cfdirectory”
then the new directory have no permission for “public read”,
then images in that directory do not display.

I tried to change the directory permission with this code
FileSetAccessMode(“#client_dir#”, “644” );

I am not sure that this script tag is the right code ? “FileSetAccessMode”
to modify the directory permission.

FileSetAccessMode works for files permission, does not seem to work for directory.

I tried also inside cfdirectory the mode parameter
with mode=644 or mode=other
none is working.

What is the right way for doing that ?

Thanks for any help.

Linux debian 10
apache 2.4
Java : 1.0.15 (Eclipse Adoptium) 64bit

I think you’ve been hit by [LDEV-3506] - Lucee

I cant test myself at the moment.

do a ls -lt /path/to/webroot
more than likely the directory is being created as the service user for lucee, but the web service running apache as a reverse proxy does not have permissions to read that directory.

the fix would be to have apahce and lucee in the same service group with the correct permissions.
add lucee to the www-data group or give www-data the same level permissions that lucee has.

1 Like