Server Admin login OK, but 'no PW'?can't create database

Installed fresh-this-week ubuntu 20.04,apache,phpadmin,mysql and the current 5.3(?) stable release Lucee. I put a simple , test page on my web site, and Lucee processes it properly (i.e., the cf tags behave like CF).

I successfully imported my database into MySQL with PHPMyAdmin, but a .cfm database query sez;
Lucee 5.3.6.61 Error (database)
Message datasource [cballen_woodstocktables] doesn’t exist
Detail available datasource names are
Datasource cballen_woodstocktables

I was able to log into the Lucee panel via the internet at (mydomain.com/lucee/admin/server.cfm) by entering my Lucee admin PW. When I try to create a datasource in nthe Lucee Server panel - to match my .cfm pages and imported MySQL database, I get this error:
Services - Datasource
Access denied for user ‘’@‘localhost’ (using password: NO)
lucee.runtime.exp.NativeException: Access denied for user ‘’@‘localhost’ (using password: NO) at com.mysql.cj.jdbc.exceptions.SQLError.createSQLException(SQLError.java:129) at, etc…
Can I get to Lucee admin thru my secure SSH terminal login (as root or sudo user) - or how do I run the Lucee server admin with the proper credentials? I’m a newbie on many dimensions here, but I’m most of the way there! Any suggestions? Thanks.

Hi @cba888 and welcome to our community.

The error you are seeing is because you didn’t specify the correct mysql specific credentials of your mysql database. These have to be added in the datasource creation section of Lucees admin, or you can set it also in the application.cfc. Are you able to connect with another mysql client to your database? What username and password are you using there? (Just to be clear, I don’t want you to post the username and password here. This is just s hint for you to know that you should set the username and password you’ve setup mysql during mysql installation.)

@cba888, welcome

If you have no password for your MYSQL database means you should empty the password field in data source creation. Check if you set the password during install MYSQL as per @andreas comment

Another hint: You’ve said you’ve installed phpmyadmin. Can you access your database with phpmyadmin? There you have also to use mysql credentials (username and password). Those you need to setup during datasource creation in Lucees server admin.

I can see my database fine in PHPMyAdmin.
My only way, that I have figured out so far, is to come in with my web browser to my web site, then I can log into /lucee/admin/server.cfm with my Lucee Admin password and I can see the server and web control panels, but when I use the Server panel and try to create a database I tell it name and MySQL, and it goes to a screen where I set parameters. Then I click ‘create’ and I get back:
Services - Datasource
Access denied for user ‘’@‘localhost’ (using password: NO)
lucee.runtime.exp.NativeException: Access denied for user ‘’@‘localhost’ (using password: NO) at com.mysql.cj.jdbc.exceptions.SQLError.createSQLException(SQLError.java:129) at…

My only option to identify myself is when I log into the server.cfm, and then it thinks I’m @‘localhost’. Is there any way to get to - or run - server.cfm from the SSH command line when I’m logged in as root or a sudo user? My configuration seems, to me, to be fine. As I said, I am seeing .cfm pages and cf tags processed OK. I tried with cfset and cfoutput and they work. I’m a novice here, but I think there’s something I’m missing… Thanks for your help!

I feel pretty stupid - and my apologies to those who have spent time on this - I messed up (repeatedly!!!) on the MySQL user/pw on the second screen of server - datasource… My datsource entry ‘took’ this time.

Don’t I see the parameters ‘user’ and ‘password’ in there? There you have to put the credentials of your mysql database.

Thank you, Andreas,
I was confused by thinking the error message was server.cfm not being satisfied with my credentials, when yes, in fact, you are correct in pointing to the MySQL credentials I should have added correctly on the ‘create datasource’ form…
Now everything: CF tag processing AND database access - seem to be working fine. Quite impressive that Lucee installation proceeded so effectively - when performed by a(n obviously) clumsy novice… Thank you!

1 Like

Hey hey, look… Don’t feel that way!!! I’ve been there too. These are your first steps. Don’t give up. No need to feel that way. It’s like learning to roller skate, you have to fall down. Now you know how to do it. Congrstulations!

Hey Andreas, thank you for your kind words. I am very grateful for your kind assistance. And for the comprehensive, detailed installation instructions that enabled a novice to get running. And it’s pretty amazing that the developers figured out how to make this product work effectively, right out of the box! I installed and my website knew immediately to interpret my CF tags! A week ago I had never heard of Lucee. I found out that my .cfm web sites had been hosted for the last few years on a legacy server and that my host had not been offering ColdFusion hosting for years, but had kept a CF server running for residual CF clients like me. So it was time to move. It seemed like new CF hosting accounts (for my small, personal websites) were expensive. So the idea evolved quickly to try setting up a VPS with Ubuntu/Apache/PHPMyAdmin/MySQL, and Lucee. And 72 hours from trying to sign up for a VPS, I’m basically fully functional. Amazing. Thank YOU!

1 Like

You are more than welcome. I can tell… here in Lucee’s support forum you are in very good hands. As you can see, even @cfmitrah, who is very busy developing with the Lucee Core Dev Team, took some of his valuable time to chime in and give some hints. If I wouldn’t have the time, some other here around would have done it.

Again, welcome.

I am happy - and honored - to join this community!