Scheduled Tasks Not Running


I am having a strange problem on one of our servers where scheduled tasks
simply do not run and get set to ‘expired/invalid’ in the Lucee admin after
the first attempt to run them. Nothing gets logged anywhere as far as we
can tell. However, if you trigger the scheduled task manually it runs fine.

We have tried all sorts of different interval settings for the tasks
themselves, but so far nothing has worked.

We have similar servers with the same setup and scheduled task all run fine
on those. We are using Windows with IIS with or without SSL and have tried
the following versions of Lucee: SNAPSHOT

We found the following Jira ticket which sounds like the same problem:

Has anybody else run into similar problems?? I am finding this particularly
hard to figure this out as there is no logging or output available.

All the best,


Hi, i have the same problem? any luck ?

Thank you

Hi Marios,

Not really… We added some logging into Lucee and built a custom jar to
see where this was going wrong for us, but that was as far as I could go
with it. See the Jira ticket for more information on that.

In the end, we rolled Lucee back to version and the schedules
started working again. Not a fix however.

We could not reproduce this on a dev server running any version of Lucee.

What platform and version are you having problems with?

All the best,

MartinOn Monday, 12 December 2016 14:01:48 UTC, Marios Papaioakim wrote:

Hi, i have the same problem? any luck ?

Thank you