Requesttimeout Doesn't Work

I have tried checking off the option to allow for requesttimeout option to work in the URL and try running
/process.cfm?requesttimeout=20000

I have tried adding the settings in the application file and at the top of the page. Code works fine in ACF, but will always timeout on me in Lucee. Anyone have any suggestions?

My server is CentOS7/Apache

Which version of lucee are you running?

What is the code in the page which is timing out doing?

There is this known issue about processing large file uploads
https://luceeserver.atlassian.net/browse/LDEV-2088

If you can knock up a reproducible example, that would be awesome. I know it can be difficult but the Lucee devs can action problems once they have a test case, without one, it’s less likely to be solved

Thank you for replying, I am running: Lucee 5.3.2.74-RC

The code on the page is doing a few API calls, database updates and inserts. Overall the process would probably take about 2 minutes total. No file uploads

what do the stacktraces look like?

Basically what I am seeing is that after 50 sec, it goes to a 504 timeout error. Is there something specific you are looking for? If I run each process individually it works fine, its when I start to chain them together. This code works fine on CF11 and CF2016 without issue. It’s very basic.

I am also running VirtualMin, I have updated PHP execution times (which i don’t think has anything to do with this, but I tried to changed it anyhow).

The 50s is the default in the lucee web admin?

Did you try enabling the requesttimeout in url option?

yes I changed the time and checked the box and tried using the URL parameter.

ok, basically it seemed to be apache issue, so far i added this to proxypass in httpd. now my script finished

ProxyPassMatch ^/(.+\.cf[cm])(/.*)?$ http://127.0.0.1:8888/$1$2 timeout=7200
ProxyPassMatch ^/(.+\.cfml)(/.*)?$ http://127.0.0.1:8888/$1$2 timeout=7200

Ah, so the error message was coming from Apache?

@Jordan_Michaels might be a good addendum for the mod cfml docs?

Yes, I started paying more attention to the 504 error and then looking in my apache error logs

I saw entries like this in there:
[Mon Jun 17 09:40:11.523030 2019] [proxy_http:error] [pid 4024] (70007)The timeout specified has expired: [client xxx.xx.xxx.xx:54130] AH01102: error reading status line from remote server 127.0.0.1:8888
[Mon Jun 17 09:40:11.523103 2019] [proxy:error] [pid 4024] [client xxx.xx.xxx.xx:54130] AH00898: Error reading from remote server returned by /tools/test.cfm

I asked a coworker and they send me a link to: https://serverfault.com/questions/272083/apache-proxy-timeout

I also looked up a few other tech articles related to that and they all basically said the same thing. I need to find out more about the connectiontimeout=xxx, when I tried adding that, I could not restart apache, so only after taking it out was I able to start it and then it worked.

Would be a cool feature in Lucee admin to look for these types of values and let you know that requesttimeout may not work due to httpd settings and what to adjust.

You mean like in the example configs or…? The issue itself seems like a mod_proxy issue.

However, in thinking about how Adobe gets around it, I’m guessing they set the default timeout to a pretty high value in their custom version of mod_jk. I wonder if this is something we should edit the installers to use by default and set to a high value by default? That way, the timeouts could essentially pass-through to Lucee like they do with ACF? Thoughts on that?