Problems installing Mark's spreadsheet extension provider

Lil bit of background I’ve been using CF since version 1 and then Railo,
now I’m experimenting with Lucee, really digging it and glad there is still
an movement behind CFML:

My install went smoothly except I’m having real trouble getting the
spreadsheet provider installed…

I’ve read Marks readme:

https://github.com/Leftbower/cfspreadsheet-lucee/blob/master/README.md and
Installation instructions but they’re confusing me…

Installation: via Lucee Admin GUI

In this method, you will create your own temporary extension provider:

  1. Download cfspreadsheet-lucee.zip
  2. Extract into /path/to/your/wwwroot/luceeExtensionProvider (you should
    then have 2 files in that folder: cfpoi.zip and ExtensionProvider.cfc)
  3. Add a file
    /path/to/your/wwwroot/luceeExtensionProvider/Application.cfc with the
    contents component {}
  4. Lucee Web Admin > Extensions > Providers: Add:
    http://your_local_site_host/luceeExtensionProvider/ExtensionProvider.cfc (ensure
    you are using the correct port in your setup)
  5. Lucee Web Admin > Extensions > Applications: Click on
    “” icon.
  6. Click “Install” Button
  7. Restart Lucee or Tomcat (depending on installation type)

I extracted (2) files from cfspreadsheet-lucee.zip (cfpoi.zip and
ExtensionProvider.cfc) to my web root, but here’s the confusion, I’m using
IIS and my webroot is c:\inetpub\wwwroot, but my website is actually setup
at c:\wwwroot2\www.WebsiteName.com\ … first I don’t know which i’m
supposed to extract these files, especially since my website folder has a
hosts alias pointing it to local.AgencyDash.com … I also don’t get the
part about add a file “Application.cfc with the contents component {}” am
I missing something I’m supposed to add here… was I supposed to add code
there? or was I suppose to extract the entire zip… then when I go to the
web admin and add the extensions in either case I get an error, I’ve
attached some screen shots of my provider settings and the folder
structures, any advice would be greatly appreciated… I apologize for
blurs, it’s a government system I’m working on.

I was under the impression that

Hi ADK,

I used that exact address… all I can point think of is that this address
is in fact a 127.0.0.1 fake HOST address for my internal purposes… I’ve
attached another screenshot if that helps… I really appreciate yourself,
I’d like to encourage my company to switch to Lucee and I’ve got everything
else working.

Kindest
-SeanOn Sunday, 28 June 2015 00:32:09 UTC-7, ADK wrote:

Hi Sean,

You just need to create a folder in a web accessible/browsable called
“luceeExtensionProvider” and in that folder you need the
“ExtensionProvider.cfc” file and the cfpoi.zip file. That’s it. The empty
Application.cfc is if you are creating a brand new site just for the
purpose of installing this extension.

Can you browse to http://local.AgencyDash.com and get a working cfml
page? If so, then add the folder and 2 files mentioned above to that
website’s root folder and you should then be able to add:

http://local.AgencyDash.com/luceeExtensionProvider/ExtensionProvider.cfc

to the provider URL and get it working. Also, perhaps check that you are
using the correct port in the above URL?

On Saturday, June 27, 2015 at 10:51:05 PM UTC-7, Sean Dearnaley wrote:

Lil bit of background I’ve been using CF since version 1 and then Railo,
now I’m experimenting with Lucee, really digging it and glad there is still
an movement behind CFML:

My install went smoothly except I’m having real trouble getting the
spreadsheet provider installed…

I’ve read Marks readme:

https://github.com/Leftbower/cfspreadsheet-lucee/blob/master/README.md
and Installation instructions but they’re confusing me…

Installation: via Lucee Admin GUI

In this method, you will create your own temporary extension provider:

  1. Download cfspreadsheet-lucee.zip
  2. Extract into /path/to/your/wwwroot/luceeExtensionProvider (you
    should then have 2 files in that folder: cfpoi.zip and
    ExtensionProvider.cfc)
  3. Add a file
    /path/to/your/wwwroot/luceeExtensionProvider/Application.cfc with the
    contents component {}
  4. Lucee Web Admin > Extensions > Providers: Add:
    http://your_local_site_host/luceeExtensionProvider/ExtensionProvider.cfc (ensure
    you are using the correct port in your setup)
  5. Lucee Web Admin > Extensions > Applications: Click on
    “” icon.
  6. Click “Install” Button
  7. Restart Lucee or Tomcat (depending on installation type)

I extracted (2) files from cfspreadsheet-lucee.zip (cfpoi.zip and
ExtensionProvider.cfc) to my web root, but here’s the confusion, I’m using
IIS and my webroot is c:\inetpub\wwwroot, but my website is actually setup
at c:\wwwroot2\www.WebsiteName.com\ … first I don’t know which i’m
supposed to extract these files, especially since my website folder has a
hosts alias pointing it to local.AgencyDash.com … I also don’t get
the part about add a file “Application.cfc with the contents component
{}” am I missing something I’m supposed to add here… was I supposed
to add code there? or was I suppose to extract the entire zip… then when
I go to the web admin and add the extensions in either case I get an error,
I’ve attached some screen shots of my provider settings and the folder
structures, any advice would be greatly appreciated… I apologize for
blurs, it’s a government system I’m working on.

I was under the impression that

Hi Sean,

You just need to create a folder in a web accessible/browsable called
“luceeExtensionProvider” and in that folder you need the
“ExtensionProvider.cfc” file and the cfpoi.zip file. That’s it. The empty
Application.cfc is if you are creating a brand new site just for the
purpose of installing this extension.

Can you browse to http://local.AgencyDash.com and get a working cfml page?
If so, then add the folder and 2 files mentioned above to that website’s
root folder and you should then be able to add:

http://local.AgencyDash.com/luceeExtensionProvider/ExtensionProvider.cfc

to the provider URL and get it working. Also, perhaps check that you are
using the correct port in the above URL?On Saturday, June 27, 2015 at 10:51:05 PM UTC-7, Sean Dearnaley wrote:

Lil bit of background I’ve been using CF since version 1 and then Railo,
now I’m experimenting with Lucee, really digging it and glad there is still
an movement behind CFML:

My install went smoothly except I’m having real trouble getting the
spreadsheet provider installed…

I’ve read Marks readme:

https://github.com/Leftbower/cfspreadsheet-lucee/blob/master/README.md
and Installation instructions but they’re confusing me…

Installation: via Lucee Admin GUI

In this method, you will create your own temporary extension provider:

  1. Download cfspreadsheet-lucee.zip
  2. Extract into /path/to/your/wwwroot/luceeExtensionProvider (you
    should then have 2 files in that folder: cfpoi.zip and
    ExtensionProvider.cfc)
  3. Add a file
    /path/to/your/wwwroot/luceeExtensionProvider/Application.cfc with the
    contents component {}
  4. Lucee Web Admin > Extensions > Providers: Add:
    http://your_local_site_host/luceeExtensionProvider/ExtensionProvider.cfc (ensure
    you are using the correct port in your setup)
  5. Lucee Web Admin > Extensions > Applications: Click on
    “” icon.
  6. Click “Install” Button
  7. Restart Lucee or Tomcat (depending on installation type)

I extracted (2) files from cfspreadsheet-lucee.zip (cfpoi.zip and
ExtensionProvider.cfc) to my web root, but here’s the confusion, I’m using
IIS and my webroot is c:\inetpub\wwwroot, but my website is actually setup
at c:\wwwroot2\www.WebsiteName.com\ … first I don’t know which i’m
supposed to extract these files, especially since my website folder has a
hosts alias pointing it to local.AgencyDash.com … I also don’t get the
part about add a file “Application.cfc with the contents component {}” am
I missing something I’m supposed to add here… was I supposed to add code
there? or was I suppose to extract the entire zip… then when I go to the
web admin and add the extensions in either case I get an error, I’ve
attached some screen shots of my provider settings and the folder
structures, any advice would be greatly appreciated… I apologize for
blurs, it’s a government system I’m working on.

I was under the impression that

OK after much trial and error I managed to get it installed,but only on the
web context… I had to add my provider location with the port number.
Spreadsheet showed up but it said POI didn’t exist, I restarted Lucee,
tried again and it seems to have installed, lets see if it works.

Quick update, got the extension provider installed by providing the port
number :
[http://local.AgencyDash.com:80/luceeExtensionsProvider/ExtensionProvider.cfc

But now I have new error on the application page… failed to load:

Failed to retrieve data from
[http://local.AgencyDash.com:80/luceeExtensionsProvider/ExtensionProvider.cfc]
within 5 seconds

(Lucee still tries to load the failing Extension Providers in a background
process)

Please see screenshot

I should have been more specific - the IIS screenshotOn Monday, June 29, 2015 at 1:42:02 PM UTC-4, Risto wrote:

In that screenshot your physical folder is luceeExtensionsProvider (plural
Extensions) but arent you referencing luceeExtensionProvider (extension
singular)?

are there any prerequisities to install this extension, like do I need to
install the JDK or JRE, or put jars into the lib folder? really kinda need
to get this working shortly…On Sunday, 28 June 2015 00:32:09 UTC-7, ADK wrote:

Hi Sean,

You just need to create a folder in a web accessible/browsable called
“luceeExtensionProvider” and in that folder you need the
“ExtensionProvider.cfc” file and the cfpoi.zip file. That’s it. The empty
Application.cfc is if you are creating a brand new site just for the
purpose of installing this extension.

Can you browse to http://local.AgencyDash.com and get a working cfml
page? If so, then add the folder and 2 files mentioned above to that
website’s root folder and you should then be able to add:

http://local.AgencyDash.com/luceeExtensionProvider/ExtensionProvider.cfc

to the provider URL and get it working. Also, perhaps check that you are
using the correct port in the above URL?

On Saturday, June 27, 2015 at 10:51:05 PM UTC-7, Sean Dearnaley wrote:

Lil bit of background I’ve been using CF since version 1 and then Railo,
now I’m experimenting with Lucee, really digging it and glad there is still
an movement behind CFML:

My install went smoothly except I’m having real trouble getting the
spreadsheet provider installed…

I’ve read Marks readme:

https://github.com/Leftbower/cfspreadsheet-lucee/blob/master/README.md
and Installation instructions but they’re confusing me…

Installation: via Lucee Admin GUI

In this method, you will create your own temporary extension provider:

  1. Download cfspreadsheet-lucee.zip
  2. Extract into /path/to/your/wwwroot/luceeExtensionProvider (you
    should then have 2 files in that folder: cfpoi.zip and
    ExtensionProvider.cfc)
  3. Add a file
    /path/to/your/wwwroot/luceeExtensionProvider/Application.cfc with the
    contents component {}
  4. Lucee Web Admin > Extensions > Providers: Add:
    http://your_local_site_host/luceeExtensionProvider/ExtensionProvider.cfc (ensure
    you are using the correct port in your setup)
  5. Lucee Web Admin > Extensions > Applications: Click on
    “” icon.
  6. Click “Install” Button
  7. Restart Lucee or Tomcat (depending on installation type)

I extracted (2) files from cfspreadsheet-lucee.zip (cfpoi.zip and
ExtensionProvider.cfc) to my web root, but here’s the confusion, I’m using
IIS and my webroot is c:\inetpub\wwwroot, but my website is actually setup
at c:\wwwroot2\www.WebsiteName.com\ … first I don’t know which i’m
supposed to extract these files, especially since my website folder has a
hosts alias pointing it to local.AgencyDash.com … I also don’t get
the part about add a file “Application.cfc with the contents component
{}” am I missing something I’m supposed to add here… was I supposed
to add code there? or was I suppose to extract the entire zip… then when
I go to the web admin and add the extensions in either case I get an error,
I’ve attached some screen shots of my provider settings and the folder
structures, any advice would be greatly appreciated… I apologize for
blurs, it’s a government system I’m working on.

I was under the impression that

In that screenshot your physical folder is luceeExtensionsProvider (plural
Extensions) but arent you referencing luceeExtensionProvider (extension
singular)?

In that screenshot your physical folder is luceeExtensionsProvider (plural
Extension

s) but arent you referencing luceeExtensionProvider (extension singular)?

Well spotted, Thanks… I just noticed it myself and was about to post
it… presumably this was the same reason it didn’t work on the Server
admin, but then again that provider took.On Monday, 29 June 2015 13:42:02 UTC-4, Risto wrote: