Problem with mod_cfml from the install

Hi All,

I have a new AWS EC2 instance running Amazon Linux and, like I have done
many times previously, I have installed HTTPD (using yum) and then
installed Lucee using the Linux 64bit installer. This all appears to have
worked fine and there are no errors in the install.log file, etc… HTTPD
and Lucee server is working fine, so I’ve added the virtual hosts I need in
Apache and accessing none CFML files, they are being picked up from the
correct document root specified in the HTTPD config, e.g.

/var/www/html/mysite.com

however when I attempt to access any CFML file from any of the virtual
hosts it is always going to:

/opt/lucee/tomcat/webapps/ROOT

and if I look in Lucee server admin there is only one context shown under
the “Web contexts” section on the server admin home page, when normally it
shows one per virtual host.

Anyone got any ideas why this time mod_cfml has not worked as it has done
previously for me and not created the contexts in Tomcat automatically for
each new virtual host as it is meant to?

Thanks.

Kind regards,

Andrew
about.me http://about.me/andrew_dixon - mso http://www.mso.net - Lucee
Association Member http://lucee.org

Assuming you didn’t unset the connector installation switch at the command
line.

Do you have:

  • This, in server.xml?
<Valve className="mod_cfml.core"
 loggingEnabled="false"
 maxContexts="200"
 timeBetweenContexts="2000"
 scanClassPaths="false"
 sharedKey="8ce0a5a0bf2d4b85aeacadac5d1de0b80c8f7c7c81babbe2722ee608e383781f"
 />
  • This in the global apache conf?
Allow from 127.0.0.1 ProxyPreserveHost On ProxyPassMatch ^/(.+\.cf[cm])(/.*)?$ http://127.0.0.1:8888/$1$2 ProxyPassMatch ^/(.+\.cfchart)(/.*)?$ http://127.0.0.1:8888/$1$2 ProxyPassMatch ^/(.+\.cfml)(/.*)?$ http://127.0.0.1:8888/$1$2 # optional mappings #ProxyPassMatch ^/flex2gateway/(.*)$ http://127.0.0.1:8888/flex2gateway/$1 #ProxyPassMatch ^/messagebroker/(.*)$ http://127.0.0.1:8888/messagebroker/$1 #ProxyPassMatch ^/flashservices/gateway(.*)$ http://127.0.0.1:8888/flashservices/gateway$1 #ProxyPassMatch ^/openamf/gateway/(.*)$ http://127.0.0.1:8888/openamf/gateway/$1 #ProxyPassMatch ^/rest/(.*)$ http://127.0.0.1:8888/rest/$1 ProxyPassReverse / http://127.0.0.1:8888/ -

mod_proxy and mod_proxy_http enabled?

mod_cfml enabled?

That stuff should happen automatically, but I think that’s all there is to
getting mod_cfml working. (Others will correct me if I’m wrong, no doubt.)

Thanks,
Jamie

On Fri, Oct 30, 2015 at 1:05 PM, Andrew Dixon <@Andrew_Dixon> wrote:

Hi All,

I have a new AWS EC2 instance running Amazon Linux and, like I have done
many times previously, I have installed HTTPD (using yum) and then
installed Lucee using the Linux 64bit installer. This all appears to have
worked fine and there are no errors in the install.log file, etc… HTTPD
and Lucee server is working fine, so I’ve added the virtual hosts I need in
Apache and accessing none CFML files, they are being picked up from the
correct document root specified in the HTTPD config, e.g.

/var/www/html/mysite.com

however when I attempt to access any CFML file from any of the virtual
hosts it is always going to:

/opt/lucee/tomcat/webapps/ROOT

and if I look in Lucee server admin there is only one context shown under
the “Web contexts” section on the server admin home page, when normally it
shows one per virtual host.

Anyone got any ideas why this time mod_cfml has not worked as it has done
previously for me and not created the contexts in Tomcat automatically for
each new virtual host as it is meant to?

Thanks.

Kind regards,

Andrew
about.me http://about.me/andrew_dixon - mso http://www.mso.net - Lucee
Association Member http://lucee.org


See Lucee at CFCamp Oct 22 & 23 2015 @ Munich Airport, Germany - Get your
ticket NOW - http://www.cfcamp.org/

You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/CAG1WijX2wcpxrt8R%2BuE3Za9nm73dx8XOuDXNPOyBDY5dH5nb4w%40mail.gmail.com
https://groups.google.com/d/msgid/lucee/CAG1WijX2wcpxrt8R%2BuE3Za9nm73dx8XOuDXNPOyBDY5dH5nb4w%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

Hi Andrew,

IIRC, EC2 uses local networking in order pass requests directly to your VM instance. The way requests get routed may be changing the HTTP headers that mod_cfml httpd adapter needs in order to pass the correct values to the mod_cfml valve. Would you mind enabling logging in your Apache config for the mod_cfml adapter and seeing what it’s reporting and passing to Tomcat? This should shed some light on what’s going on exactly, and we can work on a solution from there.

Kind regards,
Jordan Michaels----- Original Message -----
From: “Andrew Dixon” <@Andrew_Dixon>
To: lucee@googlegroups.com
Sent: Friday, October 30, 2015 10:05:41 AM
Subject: [Lucee] Problem with mod_cfml from the install

Hi All,

I have a new AWS EC2 instance running Amazon Linux and, like I have done
many times previously, I have installed HTTPD (using yum) and then
installed Lucee using the Linux 64bit installer. This all appears to have
worked fine and there are no errors in the install.log file, etc… HTTPD
and Lucee server is working fine, so I’ve added the virtual hosts I need in
Apache and accessing none CFML files, they are being picked up from the
correct document root specified in the HTTPD config, e.g.

/var/www/html/mysite.com

however when I attempt to access any CFML file from any of the virtual
hosts it is always going to:

/opt/lucee/tomcat/webapps/ROOT

and if I look in Lucee server admin there is only one context shown under
the “Web contexts” section on the server admin home page, when normally it
shows one per virtual host.

Anyone got any ideas why this time mod_cfml has not worked as it has done
previously for me and not created the contexts in Tomcat automatically for
each new virtual host as it is meant to?

Thanks.

Kind regards,

Andrew
about.me http://about.me/andrew_dixon - mso http://www.mso.net - Lucee
Association Member http://lucee.org


See Lucee at CFCamp Oct 22 & 23 2015 @ Munich Airport, Germany - Get your ticket NOW - http://www.cfcamp.org/

You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/CAG1WijX2wcpxrt8R%2BuE3Za9nm73dx8XOuDXNPOyBDY5dH5nb4w%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

Hey Andrew,

Thanks for reporting back.

The default version of Linux that Amazon uses is slightly unusual, and has thrown off some of the installer processes in the past as well that I’ve had to code around. It very much reminds me of web development for IE - where this huge corp expects you to code things a little bit differently just for them. I’ve created the following issue report and will look into it:

Thanks again.

-Jordan----- Original Message -----
From: “Andrew Dixon” <@Andrew_Dixon>
To: lucee@googlegroups.com
Sent: Friday, October 30, 2015 4:01:44 PM
Subject: Re: [Lucee] Problem with mod_cfml from the install

Hi Jordan,

Fixed it, but I’m not sure why this happened. Basically when I when into
httpd.conf to turn on the logging I found the:

LoadModule modcfml_module modules/mod_cfml.so
CFMLHandlers “.cfm .cfc .cfml”
ModCFML_SharedKey “[key]”
LogHeaders false
LogHandlers false
LogAliases false
VDirHeader false

Was all missing and the mod_cfml.so was missing from the modules directory.
All the mod_proxy stuff that Jamie mentioned was there ok, but not the
above. I then tried running the install_mod_cfml.sh manually from the sys
directory, using the key from the server.xml file in the Tomcat directory
it appeared like it worked but it still didn’t add the above or copy around
the mod_cfml.so file. So I added this manually and copied across the
mod_cfml.so file and then everything worked.

I definitely selected to install mod_cfml as I installed and uninstalled
Lucee three times in attempts to fix this. All a bit odd.

Kind regards,

Andrew
about.me http://about.me/andrew_dixon - mso http://www.mso.net - Lucee
Association Member http://lucee.org

On 30 October 2015 at 20:42, Jordan Michaels <@Jordan_Michaels> wrote:

:%s/Since/If/g

Not sure why I said ‘since’ there. =\

Warm Regards,
Jordan Michaels

On 10/30/2015 01:37 PM, Jordan Michaels wrote:

http://www.modcfml.org/index.cfm/documentation/modcfml-so-apache-module/config-options/

Uncomment any option with the word “log” in front of it. The log location
will depend on your system and its configuration. Since you’re on CentOS
I’d start looking in /var/log/httpd and if it’s not there check your
site-specific logs.

Hope this helps.

-Jordan

----- Original Message -----
From: “Andrew Dixon” <@Andrew_Dixon>
To: lucee@googlegroups.com
Sent: Friday, October 30, 2015 11:28:48 AM
Subject: Re: [Lucee] Problem with mod_cfml from the install

Hi Jordan,

Is it just the:

LogHeaders true

I need to add? And which Apache log do they end up in?

Kind regards,

Andrew
about.me http://about.me/andrew_dixon - mso http://www.mso.net -
Lucee
Association Member http://lucee.org

On 30 October 2015 at 18:10, Jordan Michaels <@Jordan_Michaels> wrote:

Hi Andrew,

IIRC, EC2 uses local networking in order pass requests directly to your
VM
instance. The way requests get routed may be changing the HTTP headers
that
mod_cfml httpd adapter needs in order to pass the correct values to the
mod_cfml valve. Would you mind enabling logging in your Apache config for
the mod_cfml adapter and seeing what it’s reporting and passing to
Tomcat?
This should shed some light on what’s going on exactly, and we can work
on
a solution from there.

Kind regards,
Jordan Michaels

----- Original Message -----
From: “Andrew Dixon” <@Andrew_Dixon>
To: lucee@googlegroups.com
Sent: Friday, October 30, 2015 10:05:41 AM
Subject: [Lucee] Problem with mod_cfml from the install

Hi All,

I have a new AWS EC2 instance running Amazon Linux and, like I have done
many times previously, I have installed HTTPD (using yum) and then
installed Lucee using the Linux 64bit installer. This all appears to have
worked fine and there are no errors in the install.log file, etc… HTTPD
and Lucee server is working fine, so I’ve added the virtual hosts I need
in
Apache and accessing none CFML files, they are being picked up from the
correct document root specified in the HTTPD config, e.g.

/var/www/html/mysite.com

however when I attempt to access any CFML file from any of the virtual
hosts it is always going to:

/opt/lucee/tomcat/webapps/ROOT

and if I look in Lucee server admin there is only one context shown under
the “Web contexts” section on the server admin home page, when normally
it
shows one per virtual host.

Anyone got any ideas why this time mod_cfml has not worked as it has done
previously for me and not created the contexts in Tomcat automatically
for
each new virtual host as it is meant to?

Thanks.

Kind regards,

Andrew
about.me http://about.me/andrew_dixon - mso http://www.mso.net -
Lucee
Association Member http://lucee.org


See Lucee at CFCamp Oct 22 & 23 2015 @ Munich Airport, Germany - Get your
ticket NOW - http://www.cfcamp.org/

You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit

https://groups.google.com/d/msgid/lucee/CAG1WijX2wcpxrt8R%2BuE3Za9nm73dx8XOuDXNPOyBDY5dH5nb4w%40mail.gmail.com
.
For more options, visit https://groups.google.com/d/optout.


See Lucee at CFCamp Oct 22 & 23 2015 @ Munich Airport, Germany - Get your
ticket NOW - http://www.cfcamp.org/

You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit

https://groups.google.com/d/msgid/lucee/689561896.294630.1446228646183.JavaMail.zimbra%40viviotech.net
.
For more options, visit https://groups.google.com/d/optout.


See Lucee at CFCamp Oct 22 & 23 2015 @ Munich Airport, Germany - Get your
ticket NOW - http://www.cfcamp.org/
— You received this message because you are subscribed to the Google
Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/5633D61E.4090103%40viviotech.net.

For more options, visit https://groups.google.com/d/optout.


See Lucee at CFCamp Oct 22 & 23 2015 @ Munich Airport, Germany - Get your ticket NOW - http://www.cfcamp.org/

You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/CAG1WijWtUjzAzESYR%2BUY%2BO0F-04EHxL49wuC05WGJA%2BK1JxH_Q%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

Hi Jamie,

Yep, that is all present and correct. I should have mentioned that in the
original post.

Kind regards,

Andrew
about.me http://about.me/andrew_dixon - mso http://www.mso.net - Lucee
Association Member http://lucee.orgOn 30 October 2015 at 17:32, Jamie Jackson <@Jamie_Jackson> wrote:

Assuming you didn’t unset the connector installation switch at the command
line.

Do you have:

  • This, in server.xml?
<Valve className="mod_cfml.core"
 loggingEnabled="false"
 maxContexts="200"
 timeBetweenContexts="2000"
 scanClassPaths="false"
 sharedKey="8ce0a5a0bf2d4b85aeacadac5d1de0b80c8f7c7c81babbe2722ee608e383781f"
 />
  • This in the global apache conf?
Allow from 127.0.0.1 ProxyPreserveHost On ProxyPassMatch ^/(.+\.cf[cm])(/.*)?$ http://127.0.0.1:8888/$1$2 ProxyPassMatch ^/(.+\.cfchart)(/.*)?$ http://127.0.0.1:8888/$1$2 ProxyPassMatch ^/(.+\.cfml)(/.*)?$ http://127.0.0.1:8888/$1$2 # optional mappings #ProxyPassMatch ^/flex2gateway/(.*)$ http://127.0.0.1:8888/flex2gateway/$1 #ProxyPassMatch ^/messagebroker/(.*)$ http://127.0.0.1:8888/messagebroker/$1 #ProxyPassMatch ^/flashservices/gateway(.*)$ http://127.0.0.1:8888/flashservices/gateway$1 #ProxyPassMatch ^/openamf/gateway/(.*)$ http://127.0.0.1:8888/openamf/gateway/$1 #ProxyPassMatch ^/rest/(.*)$ http://127.0.0.1:8888/rest/$1 ProxyPassReverse / http://127.0.0.1:8888/

mod_proxy and mod_proxy_http enabled?

mod_cfml enabled?

That stuff should happen automatically, but I think that’s all there is to
getting mod_cfml working. (Others will correct me if I’m wrong, no doubt.)

Thanks,
Jamie

On Fri, Oct 30, 2015 at 1:05 PM, Andrew Dixon <@Andrew_Dixon> wrote:

Hi All,

I have a new AWS EC2 instance running Amazon Linux and, like I have done
many times previously, I have installed HTTPD (using yum) and then
installed Lucee using the Linux 64bit installer. This all appears to have
worked fine and there are no errors in the install.log file, etc… HTTPD
and Lucee server is working fine, so I’ve added the virtual hosts I need in
Apache and accessing none CFML files, they are being picked up from the
correct document root specified in the HTTPD config, e.g.

/var/www/html/mysite.com

however when I attempt to access any CFML file from any of the virtual
hosts it is always going to:

/opt/lucee/tomcat/webapps/ROOT

and if I look in Lucee server admin there is only one context shown under
the “Web contexts” section on the server admin home page, when normally it
shows one per virtual host.

Anyone got any ideas why this time mod_cfml has not worked as it has done
previously for me and not created the contexts in Tomcat automatically for
each new virtual host as it is meant to?

Thanks.

Kind regards,

Andrew
about.me http://about.me/andrew_dixon - mso http://www.mso.net - Lucee
Association Member http://lucee.org


See Lucee at CFCamp Oct 22 & 23 2015 @ Munich Airport, Germany - Get your
ticket NOW - http://www.cfcamp.org/

You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/CAG1WijX2wcpxrt8R%2BuE3Za9nm73dx8XOuDXNPOyBDY5dH5nb4w%40mail.gmail.com
https://groups.google.com/d/msgid/lucee/CAG1WijX2wcpxrt8R%2BuE3Za9nm73dx8XOuDXNPOyBDY5dH5nb4w%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.


See Lucee at CFCamp Oct 22 & 23 2015 @ Munich Airport, Germany - Get your
ticket NOW - http://www.cfcamp.org/

You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/CA%2BonWPeS-fcRCBTbyTzZQ_hv90sNSbVFC%3Dw4OM8L1eszvf12gA%40mail.gmail.com
https://groups.google.com/d/msgid/lucee/CA%2BonWPeS-fcRCBTbyTzZQ_hv90sNSbVFC%3Dw4OM8L1eszvf12gA%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

Hi Jordan,

Fixed it, but I’m not sure why this happened. Basically when I when into
httpd.conf to turn on the logging I found the:

LoadModule modcfml_module modules/mod_cfml.so
CFMLHandlers “.cfm .cfc .cfml”
ModCFML_SharedKey “[key]”
LogHeaders false
LogHandlers false
LogAliases false
VDirHeader false

Was all missing and the mod_cfml.so was missing from the modules directory.
All the mod_proxy stuff that Jamie mentioned was there ok, but not the
above. I then tried running the install_mod_cfml.sh manually from the sys
directory, using the key from the server.xml file in the Tomcat directory
it appeared like it worked but it still didn’t add the above or copy around
the mod_cfml.so file. So I added this manually and copied across the
mod_cfml.so file and then everything worked.

I definitely selected to install mod_cfml as I installed and uninstalled
Lucee three times in attempts to fix this. All a bit odd.

Kind regards,

Andrew
about.me http://about.me/andrew_dixon - mso http://www.mso.net - Lucee
Association Member http://lucee.orgOn 30 October 2015 at 20:42, Jordan Michaels <@Jordan_Michaels> wrote:

:%s/Since/If/g

Not sure why I said ‘since’ there. =\

Warm Regards,
Jordan Michaels

On 10/30/2015 01:37 PM, Jordan Michaels wrote:

http://www.modcfml.org/index.cfm/documentation/modcfml-so-apache-module/config-options/

Uncomment any option with the word “log” in front of it. The log location
will depend on your system and its configuration. Since you’re on CentOS
I’d start looking in /var/log/httpd and if it’s not there check your
site-specific logs.

Hope this helps.

-Jordan

----- Original Message -----
From: “Andrew Dixon” <@Andrew_Dixon>
To: lucee@googlegroups.com
Sent: Friday, October 30, 2015 11:28:48 AM
Subject: Re: [Lucee] Problem with mod_cfml from the install

Hi Jordan,

Is it just the:

LogHeaders true

I need to add? And which Apache log do they end up in?

Kind regards,

Andrew
about.me http://about.me/andrew_dixon - mso http://www.mso.net -
Lucee
Association Member http://lucee.org

On 30 October 2015 at 18:10, Jordan Michaels <@Jordan_Michaels> wrote:

Hi Andrew,

IIRC, EC2 uses local networking in order pass requests directly to your
VM
instance. The way requests get routed may be changing the HTTP headers
that
mod_cfml httpd adapter needs in order to pass the correct values to the
mod_cfml valve. Would you mind enabling logging in your Apache config for
the mod_cfml adapter and seeing what it’s reporting and passing to
Tomcat?
This should shed some light on what’s going on exactly, and we can work
on
a solution from there.

Kind regards,
Jordan Michaels

----- Original Message -----
From: “Andrew Dixon” <@Andrew_Dixon>
To: lucee@googlegroups.com
Sent: Friday, October 30, 2015 10:05:41 AM
Subject: [Lucee] Problem with mod_cfml from the install

Hi All,

I have a new AWS EC2 instance running Amazon Linux and, like I have done
many times previously, I have installed HTTPD (using yum) and then
installed Lucee using the Linux 64bit installer. This all appears to have
worked fine and there are no errors in the install.log file, etc… HTTPD
and Lucee server is working fine, so I’ve added the virtual hosts I need
in
Apache and accessing none CFML files, they are being picked up from the
correct document root specified in the HTTPD config, e.g.

/var/www/html/mysite.com

however when I attempt to access any CFML file from any of the virtual
hosts it is always going to:

/opt/lucee/tomcat/webapps/ROOT

and if I look in Lucee server admin there is only one context shown under
the “Web contexts” section on the server admin home page, when normally
it
shows one per virtual host.

Anyone got any ideas why this time mod_cfml has not worked as it has done
previously for me and not created the contexts in Tomcat automatically
for
each new virtual host as it is meant to?

Thanks.

Kind regards,

Andrew
about.me http://about.me/andrew_dixon - mso http://www.mso.net -
Lucee
Association Member http://lucee.org


See Lucee at CFCamp Oct 22 & 23 2015 @ Munich Airport, Germany - Get your
ticket NOW - http://www.cfcamp.org/

You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit

https://groups.google.com/d/msgid/lucee/CAG1WijX2wcpxrt8R%2BuE3Za9nm73dx8XOuDXNPOyBDY5dH5nb4w%40mail.gmail.com
.
For more options, visit https://groups.google.com/d/optout.


See Lucee at CFCamp Oct 22 & 23 2015 @ Munich Airport, Germany - Get your
ticket NOW - http://www.cfcamp.org/

You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit

https://groups.google.com/d/msgid/lucee/689561896.294630.1446228646183.JavaMail.zimbra%40viviotech.net
.
For more options, visit https://groups.google.com/d/optout.


See Lucee at CFCamp Oct 22 & 23 2015 @ Munich Airport, Germany - Get your
ticket NOW - http://www.cfcamp.org/
— You received this message because you are subscribed to the Google
Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/5633D61E.4090103%40viviotech.net.

For more options, visit https://groups.google.com/d/optout.

Hi Jordan,

Is it just the:

LogHeaders true

I need to add? And which Apache log do they end up in?

Kind regards,

Andrew
about.me http://about.me/andrew_dixon - mso http://www.mso.net - Lucee
Association Member http://lucee.orgOn 30 October 2015 at 18:10, Jordan Michaels <@Jordan_Michaels> wrote:

Hi Andrew,

IIRC, EC2 uses local networking in order pass requests directly to your VM
instance. The way requests get routed may be changing the HTTP headers that
mod_cfml httpd adapter needs in order to pass the correct values to the
mod_cfml valve. Would you mind enabling logging in your Apache config for
the mod_cfml adapter and seeing what it’s reporting and passing to Tomcat?
This should shed some light on what’s going on exactly, and we can work on
a solution from there.

Kind regards,
Jordan Michaels

----- Original Message -----
From: “Andrew Dixon” <@Andrew_Dixon>
To: lucee@googlegroups.com
Sent: Friday, October 30, 2015 10:05:41 AM
Subject: [Lucee] Problem with mod_cfml from the install

Hi All,

I have a new AWS EC2 instance running Amazon Linux and, like I have done
many times previously, I have installed HTTPD (using yum) and then
installed Lucee using the Linux 64bit installer. This all appears to have
worked fine and there are no errors in the install.log file, etc… HTTPD
and Lucee server is working fine, so I’ve added the virtual hosts I need in
Apache and accessing none CFML files, they are being picked up from the
correct document root specified in the HTTPD config, e.g.

/var/www/html/mysite.com

however when I attempt to access any CFML file from any of the virtual
hosts it is always going to:

/opt/lucee/tomcat/webapps/ROOT

and if I look in Lucee server admin there is only one context shown under
the “Web contexts” section on the server admin home page, when normally it
shows one per virtual host.

Anyone got any ideas why this time mod_cfml has not worked as it has done
previously for me and not created the contexts in Tomcat automatically for
each new virtual host as it is meant to?

Thanks.

Kind regards,

Andrew
about.me http://about.me/andrew_dixon - mso http://www.mso.net - Lucee
Association Member http://lucee.org


See Lucee at CFCamp Oct 22 & 23 2015 @ Munich Airport, Germany - Get your
ticket NOW - http://www.cfcamp.org/

You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/CAG1WijX2wcpxrt8R%2BuE3Za9nm73dx8XOuDXNPOyBDY5dH5nb4w%40mail.gmail.com
.
For more options, visit https://groups.google.com/d/optout.


See Lucee at CFCamp Oct 22 & 23 2015 @ Munich Airport, Germany - Get your
ticket NOW - http://www.cfcamp.org/

You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/689561896.294630.1446228646183.JavaMail.zimbra%40viviotech.net
.
For more options, visit https://groups.google.com/d/optout.

Thanks Jordan.

Kind regards,

Andrew
about.me http://about.me/andrew_dixon - mso http://www.mso.net - Lucee
Association Member http://lucee.orgOn 30 October 2015 at 23:27, Jordan Michaels <@Jordan_Michaels> wrote:

Hey Andrew,

Thanks for reporting back.

The default version of Linux that Amazon uses is slightly unusual, and has
thrown off some of the installer processes in the past as well that I’ve
had to code around. It very much reminds me of web development for IE -
where this huge corp expects you to code things a little bit differently
just for them. I’ve created the following issue report and will look into
it:

https://github.com/utdream/CFML-Installers/issues/74

Thanks again.

-Jordan

----- Original Message -----
From: “Andrew Dixon” <@Andrew_Dixon>
To: lucee@googlegroups.com
Sent: Friday, October 30, 2015 4:01:44 PM
Subject: Re: [Lucee] Problem with mod_cfml from the install

Hi Jordan,

Fixed it, but I’m not sure why this happened. Basically when I when into
httpd.conf to turn on the logging I found the:

LoadModule modcfml_module modules/mod_cfml.so
CFMLHandlers “.cfm .cfc .cfml”
ModCFML_SharedKey “[key]”
LogHeaders false
LogHandlers false
LogAliases false
VDirHeader false

Was all missing and the mod_cfml.so was missing from the modules directory.
All the mod_proxy stuff that Jamie mentioned was there ok, but not the
above. I then tried running the install_mod_cfml.sh manually from the sys
directory, using the key from the server.xml file in the Tomcat directory
it appeared like it worked but it still didn’t add the above or copy around
the mod_cfml.so file. So I added this manually and copied across the
mod_cfml.so file and then everything worked.

I definitely selected to install mod_cfml as I installed and uninstalled
Lucee three times in attempts to fix this. All a bit odd.

Kind regards,

Andrew
about.me http://about.me/andrew_dixon - mso http://www.mso.net - Lucee
Association Member http://lucee.org

On 30 October 2015 at 20:42, Jordan Michaels <@Jordan_Michaels> wrote:

:%s/Since/If/g

Not sure why I said ‘since’ there. =\

Warm Regards,
Jordan Michaels

On 10/30/2015 01:37 PM, Jordan Michaels wrote:

http://www.modcfml.org/index.cfm/documentation/modcfml-so-apache-module/config-options/

Uncomment any option with the word “log” in front of it. The log
location

will depend on your system and its configuration. Since you’re on CentOS
I’d start looking in /var/log/httpd and if it’s not there check your
site-specific logs.

Hope this helps.

-Jordan

----- Original Message -----
From: “Andrew Dixon” <@Andrew_Dixon>
To: lucee@googlegroups.com
Sent: Friday, October 30, 2015 11:28:48 AM
Subject: Re: [Lucee] Problem with mod_cfml from the install

Hi Jordan,

Is it just the:

LogHeaders true

I need to add? And which Apache log do they end up in?

Kind regards,

Andrew
about.me http://about.me/andrew_dixon - mso http://www.mso.net -
Lucee
Association Member http://lucee.org

On 30 October 2015 at 18:10, Jordan Michaels <@Jordan_Michaels> wrote:

Hi Andrew,

IIRC, EC2 uses local networking in order pass requests directly to your
VM
instance. The way requests get routed may be changing the HTTP headers
that
mod_cfml httpd adapter needs in order to pass the correct values to the
mod_cfml valve. Would you mind enabling logging in your Apache config
for

the mod_cfml adapter and seeing what it’s reporting and passing to
Tomcat?
This should shed some light on what’s going on exactly, and we can work
on
a solution from there.

Kind regards,
Jordan Michaels

----- Original Message -----
From: “Andrew Dixon” <@Andrew_Dixon>
To: lucee@googlegroups.com
Sent: Friday, October 30, 2015 10:05:41 AM
Subject: [Lucee] Problem with mod_cfml from the install

Hi All,

I have a new AWS EC2 instance running Amazon Linux and, like I have
done

many times previously, I have installed HTTPD (using yum) and then
installed Lucee using the Linux 64bit installer. This all appears to
have

worked fine and there are no errors in the install.log file, etc…
HTTPD

and Lucee server is working fine, so I’ve added the virtual hosts I
need

in
Apache and accessing none CFML files, they are being picked up from the
correct document root specified in the HTTPD config, e.g.

/var/www/html/mysite.com

however when I attempt to access any CFML file from any of the virtual
hosts it is always going to:

/opt/lucee/tomcat/webapps/ROOT

and if I look in Lucee server admin there is only one context shown
under

the “Web contexts” section on the server admin home page, when normally
it
shows one per virtual host.

Anyone got any ideas why this time mod_cfml has not worked as it has
done

previously for me and not created the contexts in Tomcat automatically
for
each new virtual host as it is meant to?

Thanks.

Kind regards,

Andrew
about.me http://about.me/andrew_dixon - mso http://www.mso.net -
Lucee
Association Member http://lucee.org


See Lucee at CFCamp Oct 22 & 23 2015 @ Munich Airport, Germany - Get
your

ticket NOW - http://www.cfcamp.org/

You received this message because you are subscribed to the Google
Groups

“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send
an

email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit

https://groups.google.com/d/msgid/lucee/CAG1WijX2wcpxrt8R%2BuE3Za9nm73dx8XOuDXNPOyBDY5dH5nb4w%40mail.gmail.com

.
For more options, visit https://groups.google.com/d/optout.


See Lucee at CFCamp Oct 22 & 23 2015 @ Munich Airport, Germany - Get
your

ticket NOW - http://www.cfcamp.org/

You received this message because you are subscribed to the Google
Groups

“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send
an

email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit

https://groups.google.com/d/msgid/lucee/689561896.294630.1446228646183.JavaMail.zimbra%40viviotech.net

.
For more options, visit https://groups.google.com/d/optout.


See Lucee at CFCamp Oct 22 & 23 2015 @ Munich Airport, Germany - Get your
ticket NOW - http://www.cfcamp.org/
— You received this message because you are subscribed to the Google
Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/5633D61E.4090103%40viviotech.net
.

For more options, visit https://groups.google.com/d/optout.


See Lucee at CFCamp Oct 22 & 23 2015 @ Munich Airport, Germany - Get your
ticket NOW - http://www.cfcamp.org/

You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/CAG1WijWtUjzAzESYR%2BUY%2BO0F-04EHxL49wuC05WGJA%2BK1JxH_Q%40mail.gmail.com
.
For more options, visit https://groups.google.com/d/optout.


See Lucee at CFCamp Oct 22 & 23 2015 @ Munich Airport, Germany - Get your
ticket NOW - http://www.cfcamp.org/

You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/314612979.296366.1446247646099.JavaMail.zimbra%40viviotech.net
.
For more options, visit https://groups.google.com/d/optout.