Page Not Found (Error 404)

Hi there guys.
I’m new to Lucee and i’m trying to move from ACF to Lucee5.

I installed it on 3 Windows 10 machines that I’ll use to develop some small projects for me and the company I work at.

Computer 1: My personal computer: I installed it just fine, configured it with MySQL and tried to load a “test.cfm” file with just a #now()# output… it worked just fine. I also set a full CF site I’ve written in ACF2016 and it worked fine too.

Computer 2: My computer at work: the same thing happened as Comp1, everything worked fine plus I could access it from other computers at the same network.

Computer 3: My portable computer (and this will be my main developing computer), I installed on it just like the others. When I try to load the /tests/test.cfm (with the #now()# ) it runs just fine, BUT, when I try to run the other site, it gives me an 404 Not Found error.

I have a index.htm page on it with just a “coming soon” message and it works just fine at Comp1 and Comp2 but fails at Comp3, and I have a 1index.cfm that is the real .cfm page that will be released when everything is ready and it also gives me an error, but, this one below:

Lucee Error (missinginclude)
Message Page /rossiaward/1index.cfm [C:\lucee\tomcat\webapps\ROOT\rossiaward\1index.cfm] not found
Mapping /
Java Stacktrace lucee.runtime.exp.MissingIncludeException: Page /rossiaward/1index.cfm [C:\lucee\tomcat\webapps\ROOT\rossiaward\1index.cfm] not found
at lucee.runtime.PageSourceImpl.loadPage(
at lucee.runtime.PageContextImpl._doInclude(
at lucee.runtime.PageContextImpl._doInclude(
at lucee.runtime.listener.ModernAppListener._onRequest(
at lucee.runtime.listener.MixedAppListener.onRequest(
at lucee.runtime.PageContextImpl.execute(
at lucee.runtime.PageContextImpl._execute(
at lucee.runtime.PageContextImpl.executeCFML(
at lucee.runtime.engine.Request.exe(
at lucee.runtime.engine.CFMLEngineImpl._service(
at lucee.runtime.engine.CFMLEngineImpl.serviceCFML(
at lucee.loader.engine.CFMLEngineWrapper.serviceCFML(
at lucee.loader.servlet.CFMLServlet.service(
at javax.servlet.http.HttpServlet.service(
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(
at org.apache.catalina.core.ApplicationFilterChain.doFilter(
at org.apache.tomcat.websocket.server.WsFilter.doFilter(
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(
at org.apache.catalina.core.ApplicationFilterChain.doFilter(
at org.apache.catalina.core.StandardWrapperValve.invoke(
at org.apache.catalina.core.StandardContextValve.invoke(
at org.apache.catalina.authenticator.AuthenticatorBase.invoke(
at org.apache.catalina.core.StandardHostValve.invoke(
at org.apache.catalina.valves.ErrorReportValve.invoke(
at mod_cfml.core.invoke(
at org.apache.catalina.valves.AbstractAccessLogValve.invoke(
at org.apache.catalina.core.StandardEngineValve.invoke(
at org.apache.catalina.connector.CoyoteAdapter.service(
at org.apache.coyote.http11.Http11Processor.service(
at org.apache.coyote.AbstractProcessorLight.process(
at org.apache.coyote.AbstractProtocol$ConnectionHandler.process(
at java.util.concurrent.ThreadPoolExecutor.runWorker(
at java.util.concurrent.ThreadPoolExecutor$
at org.apache.tomcat.util.threads.TaskThread$

Timestamp 9/6/17 8:32:23 PM BRT

When I try to load the “index.htm” I get this:

HTTP Status 404 – Not Found
Type Status Report
Message /rossiaward/index.htm
Description The origin server did not find a current representation for the target resource or is not willing to disclose that one exists.
Apache Tomcat/8.5.16

And when i just type "localhost:8888/rossiaward it gives me this one

Lucee Error (missinginclude)
Message Page /rossiaward/index.cfm [C:\lucee\tomcat\webapps\ROOT\rossiaward\index.cfm] not found

it’s looking for a “index.cfm”, that doesn’t exists because it’s a “index.htm”… even if I rename the 1index.cfm to just index.cfm it does not find it.

As I said, everything work fine at Comp1 and Comp2 … but I got these errors at Comp3 … I even tried to export the Application.cfc from Comp1 to Comp3 but it didn’t worked and I didn’t changed anything but the default password because I’m still learning how to use Lucee (I’m used to ACF). I tried to set the folder permission with “full control” to “everyone” and restarted Lucee server but nothing different happened.

Can anyone help me here?

Without seeing your hard drive and configuration it’s honestly hard to guess. Lucee really isn’t very different at all from ACF in the way that it runs .cfm files from a directory. Firstly, you haven’t mentioned if you’re running behind a web server like IIS, Apache, Nginx, etc or just hitting Tomcat directly. If you’re using a web server, how are you connecting it to Lucee? Have you manually created new hosts in Tomcat? There’s many missing bits of information here.

Secondly, you provided information like the file C:\lucee\tomcat\webapps\ROOT\rossiaward\1index.cfm wasn’t found, but I’m unclear on whether or not that path is correct in the first place. If you’re not using a web server like IIS, then it’s likely that Tomcat’s default static file handler is case sensitive. have you checked that? Also, I’m not 100% sure if Tomcat’s default servlet is enabled for serving static files so review your web.xml. I think you’ll need to do some basic troubleshooting on your end and possibly come back with some more comprehensive information on exactly what you’ve set up.

Hi there, thanks for replying.

1: I’m just hitting Tomcat directly.

2: “C:\lucee\tomcat\webapps\ROOT\rossiaward\1index.cfm” does exists (\index.htm also exists - it’s a temp page).

As I said, I installed at these 3 computers at the same time… didn’t changed anything (just set the MySql datasource and new password) and just tried to run it. I could run it using CommandBox but with CommandBox i couldn’t ‘open’ it to others computers at the network… i’ll take a look at the “web.xml” but not really sure about what to look over there… i’ll try to compare from one working computer to another.

That’s not true of CommandBox at all. You should have asked that question first! By default CommandBox will bind to localhost, all you need to do in order to make a CommandBox site accessible on the LAN is to bind either to your LAN IP (like or just bind to and it will bind to all addresses.

Thx… but i tried CommandBox just to check if it was smth wrong with Lucee when i stalled it, it ran fine at my computer but when someone else tried to access it, he couldn’t, maybe cause i didn’t binded it. But anyway, i preffer to stick with Lucee install and solve this “not found” issue at this specific computer.

I’m sure Brad will jump on this, but you can absolutely “open” it through

Just supply a host of and a port of something known to box server
start. (or in your server.json)

See box help server start.

1 Like

I would recommend wiping that Lucee install and trying a fresh one. I’m sure whatever is wrong can be fixed, but not without someone knowledgeable enough directly troubleshooting. Probably less work just to slash and burn to make sure everything is fresh.

Don’t underestimate CommandBox though. I use it for 100% of my development work now. I’ve got dozens of local servers running all sorts of versions of Adobe CF, Railo, and Lucee all with different settings and I just start/stop them when I need. All with nothing “installed” :slight_smile:

Funny that it was a clean install… i installed and tested at Comp1, then Comp2 and then at Comp3 … and this happened at Comp3 … i’ll try to copy the web.xml from Comp1 to Comp3 to check.

Yes, I get that it was a clean install. All installs were clean at some point. I’m suggesting that perhaps it isn’t "clean " any longer and the best way to confirm that is simply to re-install it real quick.

ok, just did a clean Lucee install and the same thing happened.

Is there anything else I could try… or any else info you would need?
I could even open remote control for this machine by TeamViewer or smth like that.