Odd problem with mappings

Hi All,

This morning, two of our Lucee servers suddenly developed an odd problem, after an apache restart. Other servers are working fine.

When looking for a file, the webroot part of the path is doubled up, so instead of looking for /my/system/webroot/file.htm, lucee is looking for /my/system/webroot/my/system/webroot/file.htm. Every request throws a “missinginclude” exception.

All servers have a virtual mapping of / to {web-root-directory}. All other config for Apache and Tomcat appears to be identical.

If we change the virtual mapping of / to /, it works and if we delete the virtual mapping for /, it works.

Does anyone have any ideas?

Regards Peter

hmm, which version of Lucee, please always mention that when asking for help


We’ve tested on UNIX and Windows servers, and everything seems to work without a virtual mapping for /. Is it redundant?


Thanks. We just tried that and still get the same problem. It only works if we remove the mapping for “/” altogether. Is there any issue doing that?

we have been observing a very similar problem since last week, but with CFWheels’s default /app mapping. The path also gets duplicated just like the OP described.
There is no physical directory with the name /app, so I guess @Zackster 's suggestion won’t help here either.
Lucee version

We are yet to figure out what’s triggering this issue and to build a proper repro case, as it seems to crop up rather randomly.

Thanks FKL. Good to know we are not alone. We were particularly worried because this strange behaviour coincided with a huge DDOS attack on our service.