Null pointer exception trying ehcache

I tried to setup ehcache on a Lucee Server (4.5.1.023 final).

I added a cache in the administrator and set the cache to hold objects.

if I try to verify the cache in the administrator, I get an error (when i
hover the error sign it say’s “java.lang.NullPointerException”).

Whe i try to access the cache programatically:

<cfset cacheput(“default”,now())>

I get a more detailed Message:

Java Stacktracejava.lang.NullPointerException
at railo.runtime.cache.eh.EHCache.getCache(EHCache.java:512):512
at railo.runtime.cache.eh.EHCacheSupport.put(EHCacheSupport.java:63):63
at railo.runtime.functions.cache.CachePut._call(CachePut.java:36):36
at railo.runtime.functions.cache.CachePut.call(CachePut.java:19):19
at test.www.cache.a1_cfm$cf.call(/data/web/test/www/cache/a1.cfm:5):5
at railo.runtime.PageContextImpl.doInclude(PageContextImpl.java:880):880
at
railo.runtime.listener.ClassicAppListener._onRequest(ClassicAppListener.java:39):39
at
railo.runtime.listener.MixedAppListener.onRequest(MixedAppListener.java:19):19

The Box lucee is running on is a Centos 6.6 64-Bit.

I also tried with lucee Express installed on the same server with the same
result.

Is there someting more i have to install configure?

Any help is apreciated

TIA Rolf

Hi Rolf,

Have you added them in the “web” admin or the “server” admin?

Kind regards,

Andrew
about.me http://about.me/andrew_dixon - mso http://www.mso.net - Lucee
Association Member http://lucee.orgOn 1 October 2015 at 16:15, Rolf Anderegg <@Rolf_Anderegg> wrote:

I tried to setup ehcache on a Lucee Server (4.5.1.023 final).

I added a cache in the administrator and set the cache to hold objects.

if I try to verify the cache in the administrator, I get an error (when i
hover the error sign it say’s “java.lang.NullPointerException”).

Whe i try to access the cache programatically:

<cfset cacheput(“default”,now())>

I get a more detailed Message:

Java Stacktracejava.lang.NullPointerException
at railo.runtime.cache.eh.EHCache.getCache(EHCache.java:512):512
at railo.runtime.cache.eh.EHCacheSupport.put(EHCacheSupport.java:63):63
at railo.runtime.functions.cache.CachePut._call(CachePut.java:36):36
at railo.runtime.functions.cache.CachePut.call(CachePut.java:19):19
at test.www.cache.a1_cfm$cf.call(/data/web/test/www/cache/a1.cfm:5):5
at railo.runtime.PageContextImpl.doInclude(PageContextImpl.java:880):880
at
railo.runtime.listener.ClassicAppListener._onRequest(ClassicAppListener.java:39):39
at
railo.runtime.listener.MixedAppListener.onRequest(MixedAppListener.java:19):19

The Box lucee is running on is a Centos 6.6 64-Bit.

I also tried with lucee Express installed on the same server with the same
result.

Is there someting more i have to install configure?

Any help is apreciated

TIA Rolf


See Lucee at CFCamp Oct 22 & 23 2015 @ Munich Airport, Germany - Get your
ticket NOW - http://www.cfcamp.org/

You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/421a59d5-8146-40ff-8f55-7f691e20c627%40googlegroups.com
https://groups.google.com/d/msgid/lucee/421a59d5-8146-40ff-8f55-7f691e20c627%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

Ok, so “default” must be a reserved word for the cache name, I will raise a
bug ticket.

Kind regards,

Andrew
about.me http://about.me/andrew_dixon - mso http://www.mso.net - Lucee
Association Member http://lucee.orgOn 1 October 2015 at 16:40, Rolf Anderegg <@Rolf_Anderegg> wrote:

Hi Andrew,

I tried in the Server Administrator.

After your message i tried it in the Web Administrator.

-> Verifying the Cache created in the Administrator: Still not working

-> Creating a New Cache in the Web Administrator Works! including verify

After some further investigation:

The Problem was the name of the cache. I used “default” as the name which
dosent work neither in Server nor Web Administrator “default1” for example
worked like a charm in both admins.

Thanks a lot for your hint

Rolf


See Lucee at CFCamp Oct 22 & 23 2015 @ Munich Airport, Germany - Get your
ticket NOW - http://www.cfcamp.org/

You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/cbef407b-9681-455b-9fba-d873ed93cdd4%40googlegroups.com
https://groups.google.com/d/msgid/lucee/cbef407b-9681-455b-9fba-d873ed93cdd4%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.