Newer ESAPI extension cannot be loaded (

Trying to view my Extensions in Server Admin panel, to determine my pdf extension.

We are currently wedded to this release of Lucee I tried to remove esapi.extension- from the /bundles folder, and replaced it with a copy of esapi.extension- which is working on a dev server, but I continue to get this error after restarting Tomcat:

The Extension [ESAPI extension :] cannot be loaded, Lucee Version must be at least [], version is [].

Which version of esapi.extensions works with And where might one find a jar or do I need to compile from source here? Tags · lucee/extension-esapi · GitHub

Don’t forget to tell us about your stack!

OS: Windows Server 2012
Java Version: 1.8.0_311
Tomcat Version: 8.0.27
Lucee Version:

alas the changes between 5.2 and 5.3 mean you simply can’t use the newer releases, underlying changes mean they are incompatible, you can just re-compile the extension

Pretty sure the Lucee admin will only show you which compatible versions are available

Thanks for the speedy reply!

One small follow-up if you don’t mind, trying to understand what’s going on here?

I recompiled the earliest from here: Tags · lucee/extension-esapi · GitHub

I turned off Tomcat service, went into lucee-server/bundles, and deleted esapi-extension-2-1-0-17-SNAPSHOT.jar, and copied the compiled esapi-extension- into there. Once I restarted Tomcat and hit my app, esapi-extension-2-1-0-17-SNAPSHOT.jar re-appeard in lucee-server/bundles, and I still get the same error.

I’d like to note that these servers only have only ever had the Logging Analyzer extension installed, and other than that this is a stock Lucee install from jar. All of our app config comes from code.

  1. I cannot figure out what is re-creating that jar (that is not compatible with Lucee?)
  2. How can I find out which version of the esapi-extension jar is compatible with Lucee

Edit: I cannot see what versions are available in Admin:

um, try dropping the .lex for the known good version of the esapi ext into the /deploy folder,
that should uninstall the newer version?

Thanks for your help Zackster.
I’m not sure how the dependencies got out of synch, but a wholesale lucee.jar replacement works as intended. Great news!