Newbie question Lucee on IIS not loading localhost but does load admin

Hi All,

I’ve been running Lucee on a virtual machine for a month, migrating a site from ColdFusion. I’ve purchased a server today, installed IIS and Lucee (according to Lucee videos). I can log into admin at 127.0.0.1:8888 no problem, but if I load http://localhost I get ERR_CONNECTION_REFUSED (Google Chrome). Specifying 127.0.0.1 without a port also does not load the page.

Prior to installing Lucee IIS would correctly load the iisstart.htm file from localhost, so I know that IIS was working.

I followed a default install, and left all options checked, including the IIS connector.

I did search these forums and tried a number of suggestions, including mods to web.xml and adding ROOT.XML to c:\lucee\tomcat\conf\Catalina\127.0.0.1\ and \localhost\

If I try entering 127.0.0.1/index.cfm, after a minute or so the URL changes to:
http://127.0.0.1/index.cfm?&&&&&&&&&&&&&&&&&&&__

I am guessing that IIS and Tomcat are somehow conflicting, and it has to do with paths and/or permissions, but I’m afraid I am lost as to where the issue might be.

Can anyone point me in the right direction?

Thanks!

OS: Windows Server 2019
Java Version: 11.0.11 (AdoptOpenJDK) 64 bit
Tomcat Version: 9.0.46
Lucee Version: 5.3.8.201

Hi @martinbailey welcome!!!

at which part of the video series (step / time ?) did the issue apear? I’ve tested this video guides over a dozen of times and they were working. But I didn’t test it with the actual installer with Lucee 5.3.8.201.

Could you please take a look into your chrome dev tool network tab and look if you have some sort of redirects in there? How do they look like?

I’ve seen a similar issue when mod_cfml tries to create a web context and it can’t. It retries and redirects, retries and redirects etc. However, that doesn’t happen if you follow and keep the step by step instruction of the video guide.

What happens with a normal index.html file?

Thanks for your prompt response.

Even trying to load the default iisstart.htm document via either localhost or 127.0.0.1 fails with ERR_CONNECTION_REFUSED. I’ve tried disabling the (Windows) firewall for a few seconds and trying again, just to make sure that’s not the issue.

This was a fresh server, spun up yesterday. I installed IIS, at which point localhost was working correctly. I then installed Lucee (leaving all options as default/on during install). I could access the Admin control panel on port 8888 but could then no longer access localhost.

Interestingly, if I try to load http://127.0.0.1:8888/index.cfm (which should show the Welcome to your Lucee 5 installation message), it does load the HTML but does NOT load the style sheets and images, stored in sub-folders. Would that suggest that it’s some sort of mapping issue?

Sorry if I’ve not yet provided all of the information you need - ‘I don’t know what I don’t know’ yet!

This is odd. Did you change context configuration mappings in Tomcat or wwwroot bindings in IIS? If you are saying you can open localhost:8888/index.cfm but it’s not loading static file, then this sounds you’ve changed file permissions, changed context mappings and your context isn’t accessing the correct root. Also, it sounds that your IIS isn’t starting at all. Can you see something in the windows event viewer about any IIS errors?

the http error for the images which don’t load on port 8888 are coming from tomcat or iis?

Inspect http://127.0.0.1:8888/index.cfm in your browser. What does that state about your missing css and images?

i.e. what does this link show? http://127.0.0.1:8888/assets/img/lucee-logo.png

tomcat will show something like

An update on my previous thread, as situation has changed. After a reboot (and no doubt IIS/Tomcat/Lucee restarting) this is the following situation:

127.0.0.1:8888/index.cfm loads correctly
localhost:8888/index.cfm loads html but no CSS/images. Console reports 404 errors (ERR_ABORTED)
127.0.0.1/ does not load any page, and in the network console I see that it increments &&&_ etc every second or so
localhost/ loads html but no CSS/images. Console reports 404 errors
127.0.0.1:8888/assets/img/lucee-logo.png gives a 404

Interestingly, I have added a site to c:\inetpub\wwwroot\subfolder and it DOES show correctly using localhost/subfolder/

There is another issue - performance. On the virtual machine I’d created Lucee was blisteringly fast - faster than my ColdFusion server. This new server has 6 cores, 32gb RAM and an SSD hard drive, but there’s a second delay in loading all pages from my sub-site, but no delay on the Lucee admin page. I don’t know if this is to do with IIS or Tomcat, but it is not Lucee as the admin loads quick and debug information shows that Lucee processes pages on my website in only a few milliseconds. (I only mention this here in case it gives helps with the main purpose of this thread)

Regarding Zackster’s question of where the http error is coming from - sorry, I don’t know where to check for that. I’ve never used Tomcat (and don’t even know how to access any UI for it). I would only generally look at IIS logs.

Regarding permissions, I followed the video showing adding LOCAL SERVICE and full permissions.

Regarding context mappings: Again, I’ve not set/changed anything in Tomcat as I don’t know what to change or where. Based on my previous experience of installing Lucee on a VM and watching the videos I am not sure what I’d need to do in this regard.

If it helps I could make a little video showing all of the above, along with anything else? (I can host it and provide a link here).

Thanks!

This is the Ghostcat Patch Bug

Can you try the following?

  1. Step: Backup everything by creating an Image Snapshot of your server
  2. Step: Stop Tomcat Service
  3. Step: Stop IIS Service
  4. Step: Delete all folders inside of c:\lucee\tomcat\conf\Catalina\
  5. Step: backup and delete the folder c:\lucee\tomcat\lucee-server
  6. Step: delete the ‘web-inf’ folder inside of: c:\lucee\tomcat\webapps\ROOT\
  7. Restart Tomcat and wait until it has restarted.
  8. DO NOT start IIS

Then try accessing http://localhost:8888 . What do you see? Is the index.cfm file and all static files at c:\lucee\tomcat\webapps\ROOT\ loading ok?

Thanks for the suggestion.

I carefully followed your instructions to the letter, but get a Tomcat 404 message.

For now, I reversed the changes.

(If there are no further suggestions I may simply bite the bullet and restore this server from the initial image - there’s nothing important on there, and it may be easier than trying to continually diagnose this. Of course, the worry is that I end up in the same situation again. Open to suggestions here! :slight_smile: )

In case you are restoring the server to an initial image and going through the step by step installing video guide, please let me know (in case you are running into the issue again) exactly where and at which point you are running into it. Then I need to at least add a comment to those videos. If you run into the issue again and this is something new, I’ll go through all the steps and test it also.

Yes, I think I will restore. At least that way we will know for sure if there is an issue. I am also screen record the installation process, just in case…

Will update you most probably in a couple of days.

(Thanks for the continued assistance for a newbie! Really gives me confidence in the Lucee project and community!)

2 Likes

I reinstalled the imaged and followed the videos to the letter. I am able to recreate the issue. In the video, at the point of installing Lucee it shows the loading of localhost (before LOCAL SERVICE is given permissions), and it shows a Tomcat error. I don’t get that.

I made a recording of the whole process after installing IIS, starting from showing IISSTART as working.

You can view it here: https://123insight.com/temp/lucee-install-winServer-2019.mp4

Do let me know if you need any further info, logs, etc.

Thanks!

you have copied just the index.cfm over from the C:\lucee\tomcat\webapps\ROOT into c:\inetpub\wwwroot, but not the rest of the files from C:\lucee\tomcat\webapps\ROOT hence the problem!

Hi Zackster,

I didn’t copy anything. That single file must have been installed or copied by the Lucee installer. I followed the videos to the letter, running them side by side with the relevant windows to ensure accuracy.

When IIS was installed, the only files in \wwwroot\ were iisstart.htm and its associated png. The index.cfm file was there after the Lucee install, but not the subfolders. I copied them over and on 127.0.0.1 it does indeed load correctly. However, there’s still that one-second delay if I refresh the page. So, despite reinstalling on an absolutely fresh install of WinServer 2019 the same problem has occurred. Strangely, the virtual machine I previously created locally (Windows 10) does not have this issue, and I can view the site using localhost or 127.0.0.1.

I’m not really sure what else I can try now? Ideas welcome :slight_smile:

ah yep, i see that now, Lucee only copies over that file, my bad, I don’t use IIS myself :slight_smile:

guess we need to copy the assets folder over too, errggh, time to dive into the installBuilder xml rules :face_vomiting:

or not write a file there at all, the installer opens the tomcat page on port 8888 anyway…?

Ahhhh… Ok, now I see, but as far as I remember I even don’t navigate to that localhost/index.cfm over IIS in the video guide after installation. I dive later into the IIS wwwroot to edit index.cfm and remove the ASP stuff because of the .net feature. But I keep all files in Tomcat webapp/ROOT.xml untouched. Does the installer now open directly on port 80 when letting the “open lucee welcome page” at the end of installation (before it was port 8888)?

1 Like

Thanks @Zac, should have taken a look by myself. Promise I’m going to look more into the installer stuff soon.

After installing Lucee using all default settings on a fresh install of WinServer 2019 and IIS this is what happens:

  • Opening localhost does not work. After 30 seconds I get err_too_many_redirects
  • Opening any pages on 127.0.0.1/ do work, but with the one second delay.

I did follow the thread on the GhostCat Patch Bug, but I’m afraid I could not follow what I have to do to resolve it. I noted that it suggested updating mod_cfml_valve, but I’m already running the version published (v1.1.11)

I tried changing the line below in server.xml (which is what I thought this page was suggesting: 64182 – 1.03s delay on every request via ajp):

From: Engine name=“Catalina” defaultHost=“localhost”
To: Engine name=“Catalina” defaultHost="::f"

But this just resulted in no pages loading.