New Release Candidate 5.3.8.167-RC (RC2)

New Release Candidate (5.3.8.167-RC2)

There is a new Release Candidate ( 5.3.8.167-RC ) available to download from our download page https://download.lucee.org or via the Lucee Admin.

Changes since RC1

Code changes: https://github.com/lucee/Lucee/compare/5.3.8.139...5.3.8.167

Performance

[LDEV-3377] tag cfhttp stream support - Lucee

[LDEV-3293] Application.cfc patch cache - Lucee

[LDEV-3287] Unnecessary getRootPath() file system access on every request adds overhead - Lucee

[LDEV-3290] Reevaluate performance of locking overhead in pc.initApplicationContext() for every request - Lucee

[LDEV-3278] IllegalArgumentException timeout value is negative - using now() on cfschedule tag - Lucee

[LDEV-2087] Lucee 4 and 5 consumes too much heap memory with large uploads due to bug in HTTPServletRequestWrap.java - Lucee

Sessions

[LDEV-2973] Sessiontimeout ignored with J2EE sessions - Lucee

[LDEV-3434] cfid management - Lucee

ORM

[LDEV-3430] ORMExecuteQuery() with named argument throws error - Lucee

[LDEV-3411] Application Scope Leak & Zombie DB connections when ORM inside CFTHREAD - Lucee

Logging

[LDEV-2812] error parsing large json object dumps out entire json string as exception message - Lucee

[LDEV-3084] regression, datasource session scope logging no longer going to scope.log - Lucee

[LDEV-3371] avoid WeakHashtable used by apache.commons.logging - Lucee

[LDEV-3352] apache commons logging locked - Lucee

[LDEV-3266] cflog doesn't write application name to log - Lucee

Exceptions

[LDEV-3244] member function with too many arguments throws incorrect Error - Lucee

[LDEV-3226] html error from extension provider loaded directly into admin - Lucee

[LDEV-3346] NPE with lucee local docs - Lucee

[LDEV-3256] web admin-Debugging settings shows Can't cast String [] to a boolean error - Lucee

Scheduled Tasks

[LDEV-3214] Increased CPU usage (+40%) - due to scheduled task threads - Lucee

[LDEV-3243] Schedule task - action=delete doesn't throws error for the non existing task - Lucee

Static

[LDEV-3221] Regression: Closure in static method calling another static method causes request to hang when run in parallel - Lucee

[LDEV-3334] static function cannot be used with dot notation - Lucee

Misc

[LDEV-3117] cfexecute directory="#GetTempDirectory()#" throws error - Lucee

[LDEV-3236] Failed to download the bundle [com.sun.jna:5.5.0] on first start without network connection - Lucee (offline installs)

[LDEV-3275] IsNumeric returns True on strings like "3d" and "6f" (5.3.8 regression!) - Lucee

Highlights for 5.3.8 Release

Contributors

Our thanks goes to all Contributors for this release candidate:

  • John Bampton
  • Mircea Botex
  • Ben Bluemel
  • Andrew Dixon
  • kaputotx
  • Michael Offner
  • Eric Peterson
  • Pothys Ravichandran
  • Andreas Ru
  • Igal Sapir
  • Zac Spitzer
  • stillnet
  • Brad Wood

Regressions?

If you encounter any regressions with this release candidate, please first post to the mailing list at https://dev.lucee.org, or raise a ticket with https://bugs.lucee.org and the label “regression”, we will look into it with the highest priority.

2 Likes

Congrats on the work team. That’s the largest list of contributors I’ve seen on a Lucee release!

CommandBox users can also test the RC2 like so:

CommandBox> server start cfengine=lucee@5.3.8-RC
1 Like

I know as developers we have a culture of only complaining about bugs, but it would be great to know if you have tried the RC and didn’t have any problems too!

If you’ve tried the RC please share your experience!

Or just like the first post, user feedback is really important for us, it all helps make Lucee better

I’ve been using the both RCs in my local CommandBox CLI as well as all my default servers I start with CommandBox and I have yet to see any issues.

1 Like

We’ve been running 5.3.8.138 in production for over 3 months and it’s been absolutely solid.

I ran the 5.3.8.167-RC through our tests and unfortunately there was a regression with static variables, which from 5.3.8.150 are no longer accessible to child components. This is a blocker for us as our base components rely on this.

Appreciate all the work you’re doing, Zac.

@Zac: Running Lucee .167-RC for a while now on Ubuntu 20.04 LTS (but that server is mainly for dev and without load at the moment). I’m running the RC jar also locally and on a brand new Windows Server 2019 box that we are going to move into production next week. Seems to be pretty good, but also here isn’t much load at the moment, just some simulations. Can tell you more next week.

Other than the bug I’ve opened and thread I posted (all ideas and solutions welcome) it’s working great on our 4 tertiary instances … just still has that one major issue on our main public facing web site.

We have a production server using 5.3.8.167 and it’s working beautifully. We’re forever grateful for the amazing contributions made to this project.

1 Like