mySQL Driver / SSL Issues

This is a “kind of” follow-on from;

On My Dev machine I attempting to use the code provided to create a datasource programmatically and set the useSSL=false boolean.

However I am facing a peculiar error,
(via the web interface)
I have deleted an existing datasource - because it failed to verify - and tried to recreate it.
if I edit it and choose verify connection - it reports OK

but if I then choose to VERIFY ALL datasources it fails! And interestingly (at least to me) all the datasource TYPE information is missing;

I have tried quite a few times - no difference.

I also stopped the service, and edited the server XML - making all the options match the other “working” datasources in the XML. : and it still fails.

This message appears in the Tomcat “window”
Tue Feb 22 12:13:31 AEDT 2022 WARN: Establishing SSL connection without server’s identity verification is not recommended. According to MySQL 5.5.45+, 5.6.26+ and 5.7.6+ requirements SSL connection must be established by default if explicit option isn’t set. For compliance with existing applications not using SSL the verifyServerCertificate property is set to ‘false’. You need either to explicitly disable SSL by setting useSSL=false, or set useSSL=true and provide truststore for server certificate verification.

But useSSL IS set to false! and also verifyServerCertificate is false, too - in the web interface.

Any ideas?

Thanks!

Hi,

It is very helpful to post your OS and MySQL / MariaDB version here as well as any form of how you’re connecting to the DB instance, either locally or remote and via socket or via tcp.

in whatever path to my.cfn

[mysqld]
...

skip_ssl
# disable_ssl

then restart the service
then check the ssl status in the mysql console

SHOW VARIABLES LIKE '%ssl%';