Moving to Lucee from Adobe CF - Admin Mapping not respecting

Hi ,
New to Lucee.

I am trying to setup Lucee for replacing Adobe CF,
I have an error when I map a mapping as below, for existing working fine Adobe CF code.
You can say masked location as C:\ProjectNeo\application.cfm

Can you help find out what am I doing wrong?

When Lucee shows a physical path in red, it usually means it doesn’t actually exist on disk. Please double check the folder C:/mvc/config exists and is spelled correctly.

Thanks For replying,
I was showing an alternate mapping. But I created same but shows same error

Can you try using forward slashes? I don’t think it will mattter, but I’m curious.

Also, do you have a config folder in your web root, because if you do, it will get precedence.

Just tried that too, no luck if we do it in Mapping. But it worked when I do change in code from \config\config.cfm to /config/config.cfm
seems like I need to change this in all includes then.

Interesting, so to be clear this code does not work

<cfinclude template="\config\config.cfm">

but this does?

<cfinclude template="/config/config.cfm">

To be honest, I’ve been typing forward slashes out of habit for some many years (that way my code is always compat with both Windows and *nix) that I’d never noticed this.

I’d say this is a compat issue in Lucee. Please enter a ticket here:

And in the mean time, a quick find and replace in your source code should fix up your existing CFIncludes.

Thats correct. Forward slash works fine.

Please put a link to the ticket you create here.