Mod_cfml not working Lucee, Constant Redirect, _&, work around

We have been using the lucee- for years. Recently we updated to and used the server admin for almost all our updates. Recently had to do a new install on server using railo and the web context is pointing to tomcat/webroot. Tried a bunch of things, permissions on wwwrooot, server.xml config etc… nothing worked. Uninstalled, installed lucee- worked first time as expected, then updated to installed on fresh box and am having same issue. Is this known issue? Is there a version < 6 that is working?

lucee- is having same issue. I unistalled and re-installed and worked as expected. then back to the installed and not working

Did a diff with the old working version of server.xml,swapped the localhost and, restarted lucee, and it works now. This looks like to be a bug.

would i file this under a bug report? Seems like a pretty big bug

Hi, dont mean to be bumping this over and over(well actually i do), but this seems like show stopping bug for Mod_cfml. Like its completely broken. Does not point to the correct IIS root folder, and causes complete melt down on install. Nobody care? Am i missing something?

I know that there has been a loooooong discussion about that issue and an issue about delays for localhost or here at the forum and there have been some discussions on github. also. This issue is well known. Sometimes you get hit by this issue, but it depends. The installer we all are using as today was developed by Jordan Michaelis a while ago, who decided to change his professional path and left the company vivotech (i think he co-founded it). The installer source was handed over to the Lucee Team and as far as I know, @Zackster was then the person in charge to create the installer builds. Zac did some changes to the installer, but as that issue went very deep into Jordans code and it is a strange issue, nobody was able to fix it until today. I also, as a pull requester to Lucees open source code have experimented a lot with this issue, and taken part of that discussion, but until today not many of us could get it really further.

Since Zac is not as available as he was before, I don’t realy know when the dev team is going to publish fresh new Lucee installer build releases. But I have read that the Lucee Dev Team wants to migrate the installer builds to another solution and source, so this issue could get fixed. That is all I can tell you.

You can find part of the discussion about localhost and IPv4/v6 issues here:

Question: do you really need mod_,cfml orr would a manual installation suffice your needs?

If you want to know about the installers source as of today, here it is:

And here is an example of a forum thread about the redirecting issue