Mail spool randomly stops working on 5.2.9.317


#1

Environment: 2 identical server running Windows 2012 R2 and Lucee 5.2.9.317.

One of our the 2 servers, so far always the same have started randomly having issues sending spooled mail. It has happened 3 times in the last 2 weeks and there doesn’t seem to be a pattern that causes it.

Both servers are pretty much identical and have been running for years without issues from Lucee 4.x to 5.x.

We have recently updated to the latest Lucee 5.2.9.317 and it has ran fine for a long time and passed all our testing in a testing environment.

Everything will usually run fine for days and then the spool gets hung and emails stop going out until the service is restarted.

The following gets logged:

12/16/2018 06:03:28 	smtp

smtp
lucee.runtime.exp.NativeException: smtp
at javax.mail.Session.getService(Session.java:806)
at javax.mail.Session.getTransport(Session.java:728)
at javax.mail.Session.getTransport(Session.java:668)
at javax.mail.Session.getTransport(Session.java:648)
at lucee.runtime.net.smtp.SMTPConnectionPool$SessionAndTransport.(SMTPConnectionPool.java:184)
at lucee.runtime.net.smtp.SMTPConnectionPool.getSessionAndTransport(SMTPConnectionPool.java:57)
at lucee.runtime.net.smtp.SMTPClient.createMimeMessage(SMTPClient.java:456)
at lucee.runtime.net.smtp.SMTPClient._send(SMTPClient.java:827)
at lucee.runtime.spooler.mail.MailSpoolerTask.execute(MailSpoolerTask.java:124)
at lucee.runtime.spooler.SpoolerTaskSupport._execute(SpoolerTaskSupport.java:103)
at lucee.runtime.spooler.SpoolerEngineImpl.execute(SpoolerEngineImpl.java:604)
at lucee.runtime.spooler.SpoolerEngineImpl$TaskThread.run(SpoolerEngineImpl.java:539)
Caused by: lucee.runtime.net.mail.MailException: smtp
... 12 more

I have dug a bit and found other products that have a similar issue with a missing provider, but for those it was a show stopper, not something that worked and then stopped and worked again on a restart.

Would anyone have any ideas on what could cause this or which way to dig for further info?


#2

there is an existing issue for this problem https://luceeserver.atlassian.net/browse/LDEV-1720


#3

Thanks Zac,

That does seem related - I’ll try to dig in a bit more and see what I can find / add to the ticket.