Mail server configuration [solved]

You are both stars. I imagine the Application.cfc that I had found was simply a template file. Placing the file in the root directory causes it to be picked up. Is this file only used by any script in the same folder, or does it also serve as a default for scripts in sub-directories.

Edit: It is not a template. The strange thing is that the other file must be referenced in some way, because without it other elements on the site break. I am happy to work with the suggestions for the time being, though.

Your help is much appreciated, both of you. Is it possible to mark a couple of your comments as the solutions?

@mdsystems, Click ( ) which is placed underneath of every comment.So, you can see Solution mark.:slight_smile:

I can only mark one solution, so I will mark this comment but thank both @Julian_Halliwell and @cfmitrah for the comments, as they led to the solution. Without their help, it would have taken way more time than I had available to resolve this.

It think it’s worthwhile reading the thread, because no single solution was found by one post. I have “liked” the comments that were most significant in reaching a conclusion. Thank you both for your help.

You shouldn’t have any application code inside WEB-INF - leave that folder alone. Instead your code including Application.cfc (in the root) should all be above it as CFMitrah says.

1 Like

Please note that the application is not my own, and I am not myself making changes. I am just responsible for migrating it to a new server. A separate developer (not the original one) is responsible for the original coding.

The Application.cfc file that is in WEB-INF has been reverted to it’s original state. Without it, the site does not function. Should the original developer not have created a file there, or is that file a system file that should never be altered?

The developer won’t have created it: the contents of WEB-INF are generated automatically and include CFML for running the web admin UI among other things.

It shouldn’t be changed generally speaking, unless you’re customizing the context in some way.

1 Like

Many thanks for the additional info. Very helpful.

Just had the same issue. In the end, changing the application name (this.name) seemed to clear the Lucee vibe that it hadn’t been told the mailservers (this.mailservers), although it had been!

And 5 minutes later, Lucee is throwing the same error again.

I think this is a bon fide Lucee bug so I’ll just configure the mailservers in the cfadmin instead.