[Lucee] Re: Installation with Windows Server 2008 R2 / IIS 7.5

Hi chris i did use the windows installer which is why this is all doing my
head in. I thought it would just workOn 28/04/2015 9:33 PM, “Christopher Dawes” <@Christopher_Dawes> wrote:

any reason why you can’t use the windows installer? This adds the iis
hooks in also… then use whatever port you like off iis.?

installers at:
http://railo.viviotech.net/

On Tuesday, 28 April 2015 16:26:21 UTC+10, Gavin Baumanis wrote:

Hi Everyone,
I am guessing I am doing something really dumb… but have spent several
days trying to work it out - and thought I better ask for some help.

If I am on the local server (via RDP).
My source files must be within the tomacat directory structure.
AND I MUST use the port number 8888.

If I request the application non-locally, I get told the files do not
exist in c:\inetpub\wwwroot.

Does this mean I have to have two copies of my source files - this seems
pretty wrong…

I have a brand new server.
The only thing installed is Java JDK, Lucee and the IIS server role.

what do I need to do - in order to only need “A” destination for my files?

Also - my app is not working… It is serving half “blank” pages.
the header works, kinda - in that staic files are missing but it
correctly identifies the logged in user.
(LDAP works)

But after logging in I should see the main menu… but I get the header
only.
No content , no footer.

Developer tools show no missing files.(404’s).

I am hoping this is all related to the same thing… but genuinely have
no idea and am getting a little frustrated! - ARGH!

Anyway - thanks for anything you might have to suggest.

Gavin.


You received this message because you are subscribed to a topic in the
Google Groups “Lucee” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/lucee/HmpgOLtd1eM/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/7b292a40-04b0-4416-b228-53960663966d%40googlegroups.com
https://groups.google.com/d/msgid/lucee/7b292a40-04b0-4416-b228-53960663966d%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

It usually does. If you’re just getting familiar with Lucee, try just getting a test domain working first. This will isolate your stack from any problems that might be occurring in your app. For example, try to get a “hello world” page working on a test domain.

The following documentation was written for the Railo Installer, but the same concepts can be applied to the Lucee installer as well:

If you cannot get a test domain working, then let us know the specifics, and we’ll help you isolate the issue.

Hope this helps.

-Jordan----- Original Message -----
From: “Gavin Baumanis” <@Gavin_Baumanis>
To: lucee@googlegroups.com
Sent: Tuesday, April 28, 2015 4:35:02 AM
Subject: Re: [Lucee] Re: Installation with Windows Server 2008 R2 / IIS 7.5

Hi chris i did use the windows installer which is why this is all doing my
head in. I thought it would just work
On 28/04/2015 9:33 PM, “Christopher Dawes” <@Christopher_Dawes> wrote:

any reason why you can’t use the windows installer? This adds the iis
hooks in also… then use whatever port you like off iis.?

installers at:
http://railo.viviotech.net/

On Tuesday, 28 April 2015 16:26:21 UTC+10, Gavin Baumanis wrote:

Hi Everyone,
I am guessing I am doing something really dumb… but have spent several
days trying to work it out - and thought I better ask for some help.

If I am on the local server (via RDP).
My source files must be within the tomacat directory structure.
AND I MUST use the port number 8888.

If I request the application non-locally, I get told the files do not
exist in c:\inetpub\wwwroot.

Does this mean I have to have two copies of my source files - this seems
pretty wrong…

I have a brand new server.
The only thing installed is Java JDK, Lucee and the IIS server role.

what do I need to do - in order to only need “A” destination for my files?

Also - my app is not working… It is serving half “blank” pages.
the header works, kinda - in that staic files are missing but it
correctly identifies the logged in user.
(LDAP works)

But after logging in I should see the main menu… but I get the header
only.
No content , no footer.

Developer tools show no missing files.(404’s).

I am hoping this is all related to the same thing… but genuinely have
no idea and am getting a little frustrated! - ARGH!

Anyway - thanks for anything you might have to suggest.

Gavin.


You received this message because you are subscribed to a topic in the
Google Groups “Lucee” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/lucee/HmpgOLtd1eM/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/7b292a40-04b0-4416-b228-53960663966d%40googlegroups.com
https://groups.google.com/d/msgid/lucee/7b292a40-04b0-4416-b228-53960663966d%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/CAB6eXyVYsXL_GsXFmM8pQq3XkwFi92O3ZgA%3DDy1zdEZnCELpuA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

Hi There,

Got this sorted out.
Had nothing to do with Lucee.
IIS was not installed correctly.

Once I corrected the IIS install - Lucee installed perfectly!On Wednesday, 29 April 2015 04:21:44 UTC+10, Jordan Michaels wrote:

It usually does. If you’re just getting familiar with Lucee, try just
getting a test domain working first. This will isolate your stack from any
problems that might be occurring in your app. For example, try to get a
“hello world” page working on a test domain.

The following documentation was written for the Railo Installer, but the
same concepts can be applied to the Lucee installer as well:

https://github.com/getrailo/railo/wiki/Installation-InstallerDocumentation-MSAddingSites

If you cannot get a test domain working, then let us know the specifics,
and we’ll help you isolate the issue.

Hope this helps.

-Jordan

----- Original Message -----
From: “Gavin Baumanis” <gavinb...@gmail.com <javascript:>>
To: lu...@googlegroups.com <javascript:>
Sent: Tuesday, April 28, 2015 4:35:02 AM
Subject: Re: [Lucee] Re: Installation with Windows Server 2008 R2 / IIS
7.5

Hi chris i did use the windows installer which is why this is all doing my
head in. I thought it would just work
On 28/04/2015 9:33 PM, “Christopher Dawes” <daw...@gmail.com <javascript:>> wrote:

any reason why you can’t use the windows installer? This adds the iis
hooks in also… then use whatever port you like off iis.?

installers at:
http://railo.viviotech.net/

On Tuesday, 28 April 2015 16:26:21 UTC+10, Gavin Baumanis wrote:

Hi Everyone,
I am guessing I am doing something really dumb… but have spent
several

days trying to work it out - and thought I better ask for some help.

If I am on the local server (via RDP).
My source files must be within the tomacat directory structure.
AND I MUST use the port number 8888.

If I request the application non-locally, I get told the files do not
exist in c:\inetpub\wwwroot.

Does this mean I have to have two copies of my source files - this
seems

pretty wrong…

I have a brand new server.
The only thing installed is Java JDK, Lucee and the IIS server role.

what do I need to do - in order to only need “A” destination for my
files?

Also - my app is not working… It is serving half “blank” pages.
the header works, kinda - in that staic files are missing but it
correctly identifies the logged in user.
(LDAP works)

But after logging in I should see the main menu… but I get the header
only.
No content , no footer.

Developer tools show no missing files.(404’s).

I am hoping this is all related to the same thing… but genuinely have
no idea and am getting a little frustrated! - ARGH!

Anyway - thanks for anything you might have to suggest.

Gavin.


You received this message because you are subscribed to a topic in the
Google Groups “Lucee” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/lucee/HmpgOLtd1eM/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
lucee+un...@googlegroups.com <javascript:>.
To post to this group, send email to lu...@googlegroups.com
<javascript:>.
To view this discussion on the web visit

https://groups.google.com/d/msgid/lucee/7b292a40-04b0-4416-b228-53960663966d%40googlegroups.com

<
https://groups.google.com/d/msgid/lucee/7b292a40-04b0-4416-b228-53960663966d%40googlegroups.com?utm_medium=email&utm_source=footer>

.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+un...@googlegroups.com <javascript:>.
To post to this group, send email to lu...@googlegroups.com <javascript:>.

To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/CAB6eXyVYsXL_GsXFmM8pQq3XkwFi92O3ZgA%3DDy1zdEZnCELpuA%40mail.gmail.com.

For more options, visit https://groups.google.com/d/optout.

Thanks for reporting back and letting us know! =)

-Jordan----- Original Message -----
From: “Gavin Baumanis” <@Gavin_Baumanis>
To: lucee@googlegroups.com
Sent: Thursday, May 7, 2015 2:12:18 AM
Subject: Re: [Lucee] Re: Installation with Windows Server 2008 R2 / IIS 7.5

Hi There,

Got this sorted out.
Had nothing to do with Lucee.
IIS was not installed correctly.

Once I corrected the IIS install - Lucee installed perfectly!

Hi Gavin

Could you please share with us what were the missing parts of IIS.

–DavidOn Thursday, May 7, 2015 at 11:12:18 AM UTC+2, Gavin Baumanis wrote:

Hi There,

Got this sorted out.
Had nothing to do with Lucee.
IIS was not installed correctly.

Once I corrected the IIS install - Lucee installed perfectly!

On Wednesday, 29 April 2015 04:21:44 UTC+10, Jordan Michaels wrote:

It usually does. If you’re just getting familiar with Lucee, try just
getting a test domain working first. This will isolate your stack from any
problems that might be occurring in your app. For example, try to get a
“hello world” page working on a test domain.

The following documentation was written for the Railo Installer, but the
same concepts can be applied to the Lucee installer as well:

https://github.com/getrailo/railo/wiki/Installation-InstallerDocumentation-MSAddingSites

If you cannot get a test domain working, then let us know the specifics,
and we’ll help you isolate the issue.

Hope this helps.

-Jordan

----- Original Message -----
From: “Gavin Baumanis” gavinb...@gmail.com
To: lu...@googlegroups.com
Sent: Tuesday, April 28, 2015 4:35:02 AM
Subject: Re: [Lucee] Re: Installation with Windows Server 2008 R2 / IIS
7.5

Hi chris i did use the windows installer which is why this is all doing
my
head in. I thought it would just work
On 28/04/2015 9:33 PM, “Christopher Dawes” daw...@gmail.com wrote:

any reason why you can’t use the windows installer? This adds the iis
hooks in also… then use whatever port you like off iis.?

installers at:
http://railo.viviotech.net/

On Tuesday, 28 April 2015 16:26:21 UTC+10, Gavin Baumanis wrote:

Hi Everyone,
I am guessing I am doing something really dumb… but have spent
several

days trying to work it out - and thought I better ask for some help.

If I am on the local server (via RDP).
My source files must be within the tomacat directory structure.
AND I MUST use the port number 8888.

If I request the application non-locally, I get told the files do not
exist in c:\inetpub\wwwroot.

Does this mean I have to have two copies of my source files - this
seems

pretty wrong…

I have a brand new server.
The only thing installed is Java JDK, Lucee and the IIS server role.

what do I need to do - in order to only need “A” destination for my
files?

Also - my app is not working… It is serving half “blank” pages.
the header works, kinda - in that staic files are missing but it
correctly identifies the logged in user.
(LDAP works)

But after logging in I should see the main menu… but I get the
header

only.
No content , no footer.

Developer tools show no missing files.(404’s).

I am hoping this is all related to the same thing… but genuinely
have

no idea and am getting a little frustrated! - ARGH!

Anyway - thanks for anything you might have to suggest.

Gavin.


You received this message because you are subscribed to a topic in the
Google Groups “Lucee” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/lucee/HmpgOLtd1eM/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
lucee+un...@googlegroups.com.
To post to this group, send email to lu...@googlegroups.com.
To view this discussion on the web visit

https://groups.google.com/d/msgid/lucee/7b292a40-04b0-4416-b228-53960663966d%40googlegroups.com

<
https://groups.google.com/d/msgid/lucee/7b292a40-04b0-4416-b228-53960663966d%40googlegroups.com?utm_medium=email&utm_source=footer>

.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+un...@googlegroups.com.
To post to this group, send email to lu...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/CAB6eXyVYsXL_GsXFmM8pQq3XkwFi92O3ZgA%3DDy1zdEZnCELpuA%40mail.gmail.com.

For more options, visit https://groups.google.com/d/optout.

Hi and sorry for not being able to help you out

Once I noticed that iis was missing stuff - I uncleared all tick boxes and
the checked them all for a complete install

Sorry i was just trying to get it working and didnt take notes / pay
attentionOn 08/05/2015 9:44 PM, “David Eurenius” <@David_Eurenius> wrote:

Hi Gavin

Could you please share with us what were the missing parts of IIS.

–David

On Thursday, May 7, 2015 at 11:12:18 AM UTC+2, Gavin Baumanis wrote:

Hi There,

Got this sorted out.
Had nothing to do with Lucee.
IIS was not installed correctly.

Once I corrected the IIS install - Lucee installed perfectly!

On Wednesday, 29 April 2015 04:21:44 UTC+10, Jordan Michaels wrote:

It usually does. If you’re just getting familiar with Lucee, try just
getting a test domain working first. This will isolate your stack from any
problems that might be occurring in your app. For example, try to get a
“hello world” page working on a test domain.

The following documentation was written for the Railo Installer, but the
same concepts can be applied to the Lucee installer as well:

https://github.com/getrailo/railo/wiki/Installation-InstallerDocumentation-MSAddingSites

If you cannot get a test domain working, then let us know the specifics,
and we’ll help you isolate the issue.

Hope this helps.

-Jordan

----- Original Message -----
From: “Gavin Baumanis” gavinb...@gmail.com
To: lu...@googlegroups.com
Sent: Tuesday, April 28, 2015 4:35:02 AM
Subject: Re: [Lucee] Re: Installation with Windows Server 2008 R2 / IIS
7.5

Hi chris i did use the windows installer which is why this is all doing
my
head in. I thought it would just work
On 28/04/2015 9:33 PM, “Christopher Dawes” daw...@gmail.com wrote:

any reason why you can’t use the windows installer? This adds the iis
hooks in also… then use whatever port you like off iis.?

installers at:
http://railo.viviotech.net/

On Tuesday, 28 April 2015 16:26:21 UTC+10, Gavin Baumanis wrote:

Hi Everyone,
I am guessing I am doing something really dumb… but have spent
several

days trying to work it out - and thought I better ask for some help.

If I am on the local server (via RDP).
My source files must be within the tomacat directory structure.
AND I MUST use the port number 8888.

If I request the application non-locally, I get told the files do not
exist in c:\inetpub\wwwroot.

Does this mean I have to have two copies of my source files - this
seems

pretty wrong…

I have a brand new server.
The only thing installed is Java JDK, Lucee and the IIS server role.

what do I need to do - in order to only need “A” destination for my
files?

Also - my app is not working… It is serving half “blank” pages.
the header works, kinda - in that staic files are missing but it
correctly identifies the logged in user.
(LDAP works)

But after logging in I should see the main menu… but I get the
header

only.
No content , no footer.

Developer tools show no missing files.(404’s).

I am hoping this is all related to the same thing… but genuinely
have

no idea and am getting a little frustrated! - ARGH!

Anyway - thanks for anything you might have to suggest.

Gavin.


You received this message because you are subscribed to a topic in the
Google Groups “Lucee” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/lucee/HmpgOLtd1eM/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
lucee+un...@googlegroups.com.
To post to this group, send email to lu...@googlegroups.com.
To view this discussion on the web visit

https://groups.google.com/d/msgid/lucee/7b292a40-04b0-4416-b228-53960663966d%40googlegroups.com

<
https://groups.google.com/d/msgid/lucee/7b292a40-04b0-4416-b228-53960663966d%40googlegroups.com?utm_medium=email&utm_source=footer>

.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google
Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to lucee+un...@googlegroups.com.
To post to this group, send email to lu...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/CAB6eXyVYsXL_GsXFmM8pQq3XkwFi92O3ZgA%3DDy1zdEZnCELpuA%40mail.gmail.com.

For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the
Google Groups “Lucee” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/lucee/HmpgOLtd1eM/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/43d4dee5-a945-42b4-9301-5444780127b6%40googlegroups.com
https://groups.google.com/d/msgid/lucee/43d4dee5-a945-42b4-9301-5444780127b6%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.