Lucee performing very slow compared to Adobe CF site

Don’t forget to tell us about your stack!

OS: Windows Server 2022 (10.0) 64bit
Java Version: 11.0.17
Tomcat Version: 9.0.62
Lucee Version:
DB: MS SQL Server

Hi, We are looking to migrate our application from Adobe CF to lucee. I have got a test site up and running on Lucee but the site is extremely slow compared to Adobe. I have copied the site settings to be similar as the ones on adobe but does not make any difference. Can a anyone help with regards to what else I can possibly tweak or what the bottleneck could be?

Without any details, it is hard to guess. The Lucee Web Admin can log the request for you, you can check the db queries…

If every request is one second, it could be this issue: Remove address from ajp connector config · Issue #102 · viviotech/lucee-installer · GitHub (as you mentioned Windows)

1 Like

Thanks for your reply. I couldn’t understand exactly where i am meanto to remove this address from the ajp connector config…? is this in the server.xml file in apache?

The server.xml in the lucee/tomcat/conf/folder. But, again, withouth any details, this could be an issue but it could be something else…

I have the following:

<Connector protocol="AJP/1.3"
           redirectPort="8443" />

Don’t see where I can remove and address etc.

Yes the issue could be elsehwere. I’m going to try to see where bottlenecks may be using fusionreactor…

Thanks for your feedback

I think the first thing you should do is enable the debugging template and see what is taking longer compared to Adobe.
You can do this by going to http://localhost:8888/lucee/admin/web.cfm?action=debugging.settings
Enable whatever you need (db etc)

Then go to and create a debugging template. Check to see what is taking a long time there.

Secondly, see if you can do the requests directly to lucee, for example https://localhost:8888

If those are fast then you can figure out what is going on with IIS/Apache


Try adding address="::1" to the <Connector protocol="AJP/1.3"> element. As Michael says, that’s likely to work in cases where every request is taking a second or more.


Thanks for the info! Much appreciated

1 Like

This did the trick for me. Not sure I fully understand this ‘fix’ but the site is now much quicker…

1 Like

Thanks! that worked for me too. Kept wondering why there was this 1 sec hesitation for all requests, even with Inspect Templates set to “never” for performance and caching. Big difference.

Connector protocol="AJP/1.3"

OS: Windows Server 2019 64bit
Java Version: 11.0.15
Tomcat Version: 9.0.62
Lucee Version:
DB: MS SQL Server 2019


Thank you. It works. Much faster than before.

Lucee 5 (the latest version) does have this issue. Lucee 6 has.