Lucee JDBC Bridge not working after repackage

Sorry for cross post. I didn’t include support on the original comment. I have installed Lucee Windows DataCenter 2016. Java from the Lucee installer so 1.8

I need to access some Visual Foxpro Tables so I purchased a 64-bit ODBC driver that works fine. But I can’t get the JDBC-ODBC to work. I’ve spent dozens of hours and still not successful…

I repackaged the 1.7 JDBC-ODBC jar using this page.

When I try to save the Datasource I get

What version of Lucee should I use so I can get TLS 1.2 and the JDBC ODBC bridge working?

It’s now become a real big issue.

PLEASE help!


What driver did you purchase? Out of curiosity, is there any reason you did not try a pure JDBC driver for Foxpro rather than a JDBC-ODBC bridge? i.e. we use the one by Hxtt which is terrific, though we are connecting to Foxpro 2.0 - the DOS version!

Have you tried packaging the jar files as an OSGI bundle? That is what we did with the Hxtt jar and it works perfectly.