Lucee installer on Red Hat 9.2


I have tried to install lucee on a customer virtual machine.
The OS is Red Hat Enterprise Linux release 9.2 (Plow).
At the end of the installation, when 100% was reached, the following message appeared:

“Warning: Problem running post-install step. Installation may not complete correctly
Error running /opt/lucee/sys/ -m install -t 8888 -f
/etc/httpd/conf/httpd.conf -c /usr/sbin/apachectl: apachectl: The “-M” option is not supported.
apachctl: the “-M” option is not supported.”

I tried several Lucee Linux installers, e.g. the latest and older ones like, Always the same error.
Also disabled SE Linux. Used the bundled Java version and also the OS version.

apachectl -M doesn’t work, but httpd -M. So I also tried to change the apache control script location to httpd. But then another install error appeared.

Has anyone had the same problem and successfully installed lucee on Red Hat 9.2?

As we wanted to finish the installation, we switched to a Red Hat 8.8 distribution. The lucee installer worked fine.

Have you seen this?

I have not seen this. Thanks for the hint.

1 Like

I tried the installation on CentOS Stream 9, which is very similar to Red Hat 9.
As expected, the same error appeared at the end of the lucee installer. I then made the changes mentioned in the post. The installer finished without error.
Lucee is running, but when I open a cfm page in the browser, it is displayed in plain text and not rendered by coldfusion.

Now it’s working!

I had messed up a line in the IfModule part at the end of the /etc/httpd/conf/httpd.conf file.

This is how it should be:

<IfModule mod_proxy.c>
        ProxyPreserveHost On
        ProxyPassMatch ^/(.+\.cf[cm])(/.*)?$$1$2
        ProxyPassMatch ^/(.+\.cfml)(/.*)?$$1$2
        # optional mappings
        #ProxyPassMatch ^/flex2gateway/(.*)$$1
        #ProxyPassMatch ^/messagebroker/(.*)$$1
        #ProxyPassMatch ^/flashservices/gateway(.*)$$1
        #ProxyPassMatch ^/openamf/gateway/(.*)$$1
        #ProxyPassMatch ^/rest/(.*)$$1
        ProxyPassReverse /

I would like to thank @andreas and @Terry_Whitney for their help.


thank you so much for posting back your solution! Glad you made it work!

1 Like