Lucee installer looking for apache

I’m working on a CentOS Vagrant box that’s installing Lucee alongside
Nginx. I noticed the following message (which seemed to be on standard
output instead of standard error) which seems to imply that the Lucee
installer assumes that Apache will be installed.

Problem running post-install step. Installation may not complete correctly
Error running /opt/lucee/sys/install_mod_proxy.sh -m install -t 8888 -f
/etc/httpd/conf/httpd.conf -c /usr/sbin/apachectl : child process exited
abnormally

I’m doing an unattended install using the following command:

/root/lucee-4.5.1.000-pl0-linux-x64-installer.run --mode unattended
–optionfile /root/lucee-options.txt

The only data in the lucee-options.txt file is the password. Is there an
option for this to not look for Apache.

Thanks!

~Brad

ColdBox Platform Evangelist
*Ortus Solutions, Corp *

E-mail: brad@coldbox.org
ColdBox Platform: http://www.coldbox.org
Blog: http://www.codersrevolution.com

If you set --installconn to false in your options file, does the problem still occur?

Issue has been created here:

-Jordan----- Original Message -----
From: “Brad Wood” <@Brad_Wood>
To: lucee@googlegroups.com
Sent: Thursday, June 11, 2015 11:40:47 AM
Subject: [Lucee] Lucee installer looking for apache

I’m working on a CentOS Vagrant box that’s installing Lucee alongside
Nginx. I noticed the following message (which seemed to be on standard
output instead of standard error) which seems to imply that the Lucee
installer assumes that Apache will be installed.

Problem running post-install step. Installation may not complete correctly
Error running /opt/lucee/sys/install_mod_proxy.sh -m install -t 8888 -f
/etc/httpd/conf/httpd.conf -c /usr/sbin/apachectl : child process exited
abnormally

I’m doing an unattended install using the following command:

/root/lucee-4.5.1.000-pl0-linux-x64-installer.run --mode unattended
–optionfile /root/lucee-options.txt

The only data in the lucee-options.txt file is the password. Is there an
option for this to not look for Apache.

Thanks!

~Brad

ColdBox Platform Evangelist
*Ortus Solutions, Corp *

E-mail: brad@coldbox.org
ColdBox Platform: http://www.coldbox.org
Blog: http://www.codersrevolution.com


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/CALbQ1omBjCYd%2ByNGBLpQ%3DgHfv9nmAhw%3DJ%3DmSF41Pvyp40oB-SA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

Found the docs I wrote a while back for this:

Default value for installing the connector is true, so it will try to install the Apache connector unless you specifically tell it not to. Setting the installcon attribute to false should take care of this for you.

-Jordan----- Original Message -----
From: “Jordan Michaels” <@Jordan_Michaels>
To: lucee@googlegroups.com
Sent: Thursday, June 11, 2015 11:59:40 AM
Subject: Re: [Lucee] Lucee installer looking for apache

If you set --installconn to false in your options file, does the problem still occur?

Issue has been created here:

-Jordan

----- Original Message -----
From: “Brad Wood” <@Brad_Wood>
To: lucee@googlegroups.com
Sent: Thursday, June 11, 2015 11:40:47 AM
Subject: [Lucee] Lucee installer looking for apache

I’m working on a CentOS Vagrant box that’s installing Lucee alongside
Nginx. I noticed the following message (which seemed to be on standard
output instead of standard error) which seems to imply that the Lucee
installer assumes that Apache will be installed.

Problem running post-install step. Installation may not complete correctly
Error running /opt/lucee/sys/install_mod_proxy.sh -m install -t 8888 -f
/etc/httpd/conf/httpd.conf -c /usr/sbin/apachectl : child process exited
abnormally

I’m doing an unattended install using the following command:

/root/lucee-4.5.1.000-pl0-linux-x64-installer.run --mode unattended
–optionfile /root/lucee-options.txt

The only data in the lucee-options.txt file is the password. Is there an
option for this to not look for Apache.

Thanks!

~Brad

ColdBox Platform Evangelist
*Ortus Solutions, Corp *

E-mail: brad@coldbox.org
ColdBox Platform: http://www.coldbox.org
Blog: http://www.codersrevolution.com


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/CALbQ1omBjCYd%2ByNGBLpQ%3DgHfv9nmAhw%3DJ%3DmSF41Pvyp40oB-SA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/81437408.2565106.1434049180567.JavaMail.zimbra%40viviotech.net.
For more options, visit https://groups.google.com/d/optout.

Hi Brad,

Yep, either one of those options should do the trick. :wink:

Warm Regards,
Jordan MichaelsOn 07/02/2015 02:31 PM, Brad Wood wrote:

Hey Jordan, thanks for the reply! Someow I never got notified of your
replies even though I’m set to get E-mails from this list on my topics.

I’ll give this a shot. To confirm, I can do this one of two ways,
right? I can add “–installconn false” to the end of the install
command, or I can add the line “installconn=false” to my options file right?

Thanks!

~Brad

On Thursday, June 11, 2015 at 2:03:52 PM UTC-5, Jordan Michaels wrote:

Found the docs I wrote a while back for this:
https://github.com/getrailo/railo/wiki/Installation-installerdocumentation-linunattended
<https://github.com/getrailo/railo/wiki/Installation-installerdocumentation-linunattended>


Default value for installing the connector is true, so it will try
to install the Apache connector unless you specifically tell it not
to. Setting the installcon attribute to false should take care of
this for you.

-Jordan



----- Original Message -----
From: "Jordan Michaels" <jor...@viviotech.net <javascript:>>
To: lu...@googlegroups.com <javascript:>
Sent: Thursday, June 11, 2015 11:59:40 AM
Subject: Re: [Lucee] Lucee installer looking for apache

If you set --installconn to false in your options file, does the
problem still occur?

Issue has been created here:
https://github.com/utdream/CFML-Installers/issues/67
<https://github.com/utdream/CFML-Installers/issues/67>

-Jordan




----- Original Message -----
From: "Brad Wood" <bdw...@gmail.com <javascript:>>
To: lu...@googlegroups.com <javascript:>
Sent: Thursday, June 11, 2015 11:40:47 AM
Subject: [Lucee] Lucee installer looking for apache

I'm working on a CentOS Vagrant box that's installing Lucee alongside
Nginx.  I noticed the following message (which seemed to be on standard
output instead of standard error) which seems to imply that the Lucee
installer assumes that Apache will be installed.

Problem running post-install step. Installation may not complete
correctly
Error running /opt/lucee/sys/install_mod_proxy.sh -m install -t 8888 -f
/etc/httpd/conf/httpd.conf -c /usr/sbin/apachectl : child process
exited
abnormally

I'm doing an unattended install using the following command:

/root/lucee-4.5.1.000-pl0-linux-x64-installer.run --mode unattended
--optionfile /root/lucee-options.txt

The only data in the lucee-options.txt file is the password.  Is
there an
option for this to not look for Apache.

Thanks!

~Brad

*ColdBox Platform Evangelist*
*Ortus Solutions, Corp *

E-mail: br...@coldbox.org <javascript:>
ColdBox Platform: http://www.coldbox.org
Blog: http://www.codersrevolution.com <http://www.codersrevolution.com>

--
You received this message because you are subscribed to the Google
Groups "Lucee" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to lucee+un...@googlegroups.com <javascript:>.
To post to this group, send email to lu...@googlegroups.com
<javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/CALbQ1omBjCYd%2ByNGBLpQ%3DgHfv9nmAhw%3DJ%3DmSF41Pvyp40oB-SA%40mail.gmail.com
<https://groups.google.com/d/msgid/lucee/CALbQ1omBjCYd%2ByNGBLpQ%3DgHfv9nmAhw%3DJ%3DmSF41Pvyp40oB-SA%40mail.gmail.com>.

For more options, visit https://groups.google.com/d/optout
<https://groups.google.com/d/optout>.

--
You received this message because you are subscribed to the Google
Groups "Lucee" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to lucee+un...@googlegroups.com <javascript:>.
To post to this group, send email to lu...@googlegroups.com
<javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/81437408.2565106.1434049180567.JavaMail.zimbra%40viviotech.net
<https://groups.google.com/d/msgid/lucee/81437408.2565106.1434049180567.JavaMail.zimbra%40viviotech.net>.

For more options, visit https://groups.google.com/d/optout
<https://groups.google.com/d/optout>.


You received this message because you are subscribed to the Google
Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to lucee+unsubscribe@googlegroups.com
mailto:lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com
mailto:lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/83de30c2-5584-4249-a450-0cbda357b462%40googlegroups.com
https://groups.google.com/d/msgid/lucee/83de30c2-5584-4249-a450-0cbda357b462%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout.

Hey Jordan, thanks for the reply! Someow I never got notified of your
replies even though I’m set to get E-mails from this list on my topics.

I’ll give this a shot. To confirm, I can do this one of two ways, right?
I can add “–installconn false” to the end of the install command, or I
can add the line “installconn=false” to my options file right?

Thanks!

~BradOn Thursday, June 11, 2015 at 2:03:52 PM UTC-5, Jordan Michaels wrote:

Found the docs I wrote a while back for this:

https://github.com/getrailo/railo/wiki/Installation-installerdocumentation-linunattended

Default value for installing the connector is true, so it will try to
install the Apache connector unless you specifically tell it not to.
Setting the installcon attribute to false should take care of this for you.

-Jordan

----- Original Message -----
From: “Jordan Michaels” <jor...@viviotech.net <javascript:>>
To: lu...@googlegroups.com <javascript:>
Sent: Thursday, June 11, 2015 11:59:40 AM
Subject: Re: [Lucee] Lucee installer looking for apache

If you set --installconn to false in your options file, does the problem
still occur?

Issue has been created here:
https://github.com/utdream/CFML-Installers/issues/67

-Jordan

----- Original Message -----
From: “Brad Wood” <bdw...@gmail.com <javascript:>>
To: lu...@googlegroups.com <javascript:>
Sent: Thursday, June 11, 2015 11:40:47 AM
Subject: [Lucee] Lucee installer looking for apache

I’m working on a CentOS Vagrant box that’s installing Lucee alongside
Nginx. I noticed the following message (which seemed to be on standard
output instead of standard error) which seems to imply that the Lucee
installer assumes that Apache will be installed.

Problem running post-install step. Installation may not complete correctly
Error running /opt/lucee/sys/install_mod_proxy.sh -m install -t 8888 -f
/etc/httpd/conf/httpd.conf -c /usr/sbin/apachectl : child process exited
abnormally

I’m doing an unattended install using the following command:

/root/lucee-4.5.1.000-pl0-linux-x64-installer.run --mode unattended
–optionfile /root/lucee-options.txt

The only data in the lucee-options.txt file is the password. Is there an
option for this to not look for Apache.

Thanks!

~Brad

ColdBox Platform Evangelist
*Ortus Solutions, Corp *

E-mail: br...@coldbox.org <javascript:>
ColdBox Platform: http://www.coldbox.org
Blog: http://www.codersrevolution.com


You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+un...@googlegroups.com <javascript:>.
To post to this group, send email to lu...@googlegroups.com <javascript:>.

To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/CALbQ1omBjCYd%2ByNGBLpQ%3DgHfv9nmAhw%3DJ%3DmSF41Pvyp40oB-SA%40mail.gmail.com.

For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+un...@googlegroups.com <javascript:>.
To post to this group, send email to lu...@googlegroups.com <javascript:>.

To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/81437408.2565106.1434049180567.JavaMail.zimbra%40viviotech.net.

For more options, visit https://groups.google.com/d/optout.