Lucee IIS Mappings

Brand new to Lucee. We are running windows with IIS and currently have cold fusion installed and now Lucee as well. I am wondering where do i point the handler mappings in IIS so that the templates are processed through Lucee and not ColdFusion. Currently the extensions CFC, CFM, etc. are pointing to C:\ColdFusion\runtime\lib\wsconfig\jrun_iis6.dll What would be the new path? Thank you for any help. Excited to migrate away from Coldfusion and use Lucee!

are you using mod_cfml and the boncode connector?

Don’t even know what those are, but reading this:

mod_cfml automatically configures different hosts (contexts) in tomcat for Lucee based on your IIS configuration.

Note Lucee/mod_cfml doesn’t create webserver mappings for virtual directories like ACF does, i.e. create the cfml mappings for the virtual directories (yet)

it makes life much easier with Lucee, read up on it

Thank you.

Zac, while this is great, it really does not address IIS. For us, we installed Lucee through commandbox / contentbox. Apparently there is a lucee server running in the Users.administrator folder, but still does not answer my question about ISAPI / handler mappings, where to point them. Because we installed through command box, not sure what the handler mappings should be set to. I guess the version contentbox/command box installs is the express version since it appears it sets it up in a folder where each website has a version of lucee? Not sure if you are familiar with contentbox/command box?

@timefliesmia Are you wanting to use the same IIS instance to connect different sites to either Adobe ColdFusion OR Lucee running on CommandBox? I’m sure this is possible, but I’ve never done it myself. You’d need to…

  • ensure the adobe connectors were only configured for the sites that you wanted to send to CF
  • Install Boncode, but also just for the sites you wanted to connect to Lucee
  • Enable the AJP listener on an un-used port in CommandBox
  • Configure your boncode XML for that site to bind to the matching AJP port

I’m sure there are some other missing peices, but without being able to see your setup, it’s really impossible to say.

This video may help:

@bdw429s Thank you. I installed apache tomcat and the boncode connectors. It installed the connectors in the IIS handler mappings for boncode. I updated the boncodeajp13.settings to include True The IIS website and handler mappings would determine where it is routed, so having them both available is not the issue. It’s just not routing correctly or something. I am trying to get contentbox up and running.

@timefliesmia if you’re running Lucee via CommandBox then you don’t need Tomcat at all. Follow Brad’s instructions in the screencast he mentioned.

Yeah, CommandBox doesn’t use Tomcat, so I don’t know why you’re installing that. If you’re goal is just to get ContentBox up and running, why are you fooling with IIS at all? CommandBox has it’s own built in web server, just hit CommandBox’s HTTP port directly in your browser and save yourself a lot of time.

i am not an administrator per se. I have followed your boncode video, command box and set up a site to no availe. I just purchased consulting hours on ortis, luis said you could assist hopefully. I am sure it will likely take less than 30 minutes for you. I’ve been messing with this for 3 days :slight_smile:

@Julian_Halliwell Thank you. I have followed the screencast to a tee without any luck.

@timefliesmia, I’m curious if/how things worked out?