Lucee http2


#1

I have a site that uses IIS and supports http2. When the server is getting 20 or more requests, the requests seem to wait for a long time. Is there a number I should change in tomcat for the request threads. Something else I should look at.


#2

You can change how many connection you want to allow on tomcat and how many you want to manage from IIS.
You make corresponding changes in the server.xml for Tomcat and BonCodeAJP13.setting file in IIS.
More detail here:
http://www.boncode.net/connector/webdocs/Tomcat_Connector.htm#_Toc520189760

However, you should verify that your instance can handle the load. What is the CPU / Mem look like while you have those 20 connections etc.?


#3

You might also want to try enabling the Concurrent Requests queue found in the Lucee server admin (in the request settings). It’s disabled by default. I’m not exactly sure what it does, but it has resolved some load issues I’ve had using IIS/Boncode.