Lucee and undefined tag [CFFORM] error

Hello! I’m new to this and not really a web developer…

I have an application known as “Accela” that runs on an “OpenJDK Platform Binary” service, and I assume, inside that the lucee server runs which runs the admin tool website. When you install the app, there is an option for Cold Fusion, or Lucee. We use Lucee since it is free and open source.

When I click a link from the admin tool website, I get an “undefined tag [cfform]” error message.

If I go to the “cfm” file and modify the tag “CFFORM” to “FORM” then the page and buttons work as expected.

On a previous version of Accela, the site used “Railo” and the admin tool worked without issue.

Any idea what may be going on here? I appreciate the help!

OS: Windows Server 2022
Java Version: JDK Runtime Environment 1.8.0_202
Lucee Version:

You need to install the extension:

Thanks, @Roberto_Marzialetti! I downloaded the extension and placed it into the \lucee-server\deploy as indicated by the instructions. I waited for a few minutes and the extension was moved to \lucee-server\deploy\failed-to-deploy.

I found this error in the deploy.log file:

“ERROR”,“Thread-816”,“03/18/2024”,“12:43:12”,“Extension”,"The system cannot find the path specified;The system cannot find the path specified;lucee.runtime.exp.NativeException: The system cannot find the path specified
at Method)
at lucee.runtime.osgi.BundleInfo.getInstance(
at lucee.runtime.extension.RHExtension.load(
at lucee.runtime.extension.RHExtension.init(
at lucee.runtime.extension.RHExtension.(
at lucee.runtime.config.XMLConfigAdmin.updateRHExtension(
at lucee.runtime.config.XMLConfigAdmin._updateRHExtension(
at lucee.runtime.config.DeployHandler.deploy(
at lucee.runtime.engine.Controler.control(
at lucee.runtime.engine.Controler.access$000(
at lucee.runtime.engine.Controler$
Caused by: The system cannot find the path specified
… 13 more

Have you tried to download/install the extension through the Lucee Administrator?


I attempted to go to the address https://localhost/lucee/admin/web.cfm but got the error “Page /web.cfm not found”.

I do see an “admin.cfm” file, but it points to "cflocation url=“admin/web.cfm” addtoken=“no”. The file is located here: C:\Accela\av.cfmx\deploy\ROOT.war\WEB-INF\lucee\context

This may be a “lite” version of Lucee as I do not see the web.cfm file in the directory? Is there a way to install the admin page?

Extensions are installed via the Server interface, not Web.


1 Like