Lucee 6 on a Mac

I’m trying to get Lucee running on my Mac. I’ve run Lucee on a PC for many years and have zero issues installing and configuring it there, but I Have spent days attempting to make it run on my Mac.

I’ve watched several videos (they seem to be using tomcat 8 and Lucee 5 version.) I tried the express, WAR and the .Jar implementation methods without success.

I have JRE 21 running, I can drop Tomcat 10 in and get it running. But any attempt to get lucy running is not happening. I really need some help.

MacOS 14.2.1
Tomcat 10.1.17
JDK 21
and downloaded and tried Lucee

Java installed without issue
Tomcat installed without issue
I made the tomcat .sh files executable. chmod +x *.sh
I then used the ~/Apps/lucee

I dropped the ROOT.war file in the webapps folder (deleted the ROOT folder)

I created a with the following:

export CATALINA_HOME=/Users/jeremymerritt/tomcat
export CATALINA_BASE=/Users/jeremymerritt/Apps/lucee

made the file executable and ran it.

It looks like the WAR unpacked and I got a ROOT folder

After I still can’t hit the index.cfm file.

I edited the server.xml in the Lucee conf folder and changed the port to 7000 and re-ran the

can see the server on 7000 but can’t get it to see any files. everything is 404

I added a host declaration to the server xml and can then see a file, but the cfml engine isn’t doing its job I just get the text of the file displayed.

I’m just plain stuck and don’t have any clue what to edit or change.
the real end goal is to add apache as the front end and then use tomcat/lucee behind that on my Mac for development.

My dev environment for over 2 decades has been windows. I started with coldfusion in the 90s and eventually used the OPENBD around 2010 and moved to Lucee around 2015 but all in windows.

But, since moving to a silicon Mac I can’t run windows x86/x64 any more on my Mac and need to develop and test on my Mac.

I’m not a command line genius by any means on my Mac. I love command line but just don’t get all the unix contexts yet. Any help would be greatly appreciated.

I don’t think Java 21 is supported yet. Officially Lucee runs with Java 11. Have you tried that? I also don’t know if Lucee supports Tomcat 10 already.

Tomcat 10 changed the java.x namespaces to jakarta, which breaks compatibility.
Lucee currently dont support it and i guess it will be a super huge task to change that.
So you have to stick which tomcat 9.x.

Also support for Java 21 / 17? is not complete (correct me if im wrong there) . So you also have to stick which version 11 there.

1 Like


That was the clue I needed to get this up and running. I just was not aware of the tomcat version and java version compatibility with Lucee.

I really appreciate your help.