Lucee recompiles all classes intermittently

Let me set the stage:

  • Lucee
  • Docker containers (running some for of nix)
  • Local development
  • FW/1 application

When we were on Lucee 5.2.x, re-initializing the FW/1 application was decently fast, and Lucee only appeared to recompile the classes I’ve been working on. However, since switching to Lucee, I’m occasionally seeing every single CFC class get recompiled, even if it’s not being worked-on. This can take like 5-minutes (and I see each class getting logged to the system output).

I think maybe it related to me switching .git branches? But, not always. I’m on the verge of just resetting my Docker for Mac to its factory settings to see if I messed something up.

Anyone ever see anything like this?


Also, I have always had my checking of templates set to “Once” (in the Lucee Admin).

@bennadel To be honest, 5.3.4 and 5.3.5 had a lot of change to classloading and a handful of regressions. Can you give this a test on the new 5.3.6 release which is much more stable. Also, what version of java are you using?

We’re still on Java 8 (moving to 11 would have broken a number of JAR libs). We’re hoping to upgrade that at some point, but … priorities :smiley:

I’ll try to see if it makes any difference with the other version. I believe I can build my own image locally.

Java 8 seems to work better on Lucee 5.3.4 and 5.3.5, mostly because several of the regressions were related to Java 11 changes. Forget docker images-- this is why local dev on Docker sucks. :slight_smile: Cut the extra layers and just start up a good old CommandBox server to test. It takes a single command, like 3 seconds, and doesn’t require any image nonsense.

I am not sure that I / we can switch to non-Docker at this point because we have a number of other services that all communicate on the same docker network (and all that kind of jazz). To be honest, I only have the most shallow understanding of how Docker works.

The compilation issues are probably Lucee regressions that should have been fixed, not related to Docker :slight_smile: Switching Lucee versions should be as easy as changing your FROM line in the Dockerfile.

1 Like

I’m currently using this one:

FROM lucee/lucee:

I’ll see if I can figure out which one corresponds to the update. I’m pretty bad at locating Docker images :smiley: There’s always soooo many listed.

1 Like

So, I reset my Docker to the “factory settings”, and it seems to have helped some. I no longer see any of the CFC getting logged to the Docker output; but, I do still have some re-init requests taking unusually long (though, not as bad as before).

I still haven’t tried a different Image yet.

So, I went into the server-management UI (lucee admin) and upgraded the version to Lucee I’m still running on an older Docker image; but, I believe as long as I don’t clean my containers, it should be using the latest Lucee version.

Tentatively, I’m seeing better performance now with Lucee I’m re-initializing my Framework-One application on a regular basis, and I haven’t hit any of the 5-minute re-builds. That said, it’s only been a few hours, so I’ll see if this keeps going smoothly.

1 Like