Lucee 5.3.3.62 and <cfinsert> / <cfupdate>

Thanks. Can you add the “regression” label to the bug report as asked by Zac_Spitzer?

Now, I’ve added. @Gunter, Did you saw? Please make sure of this :slight_smile:

Yes, verifying it now with a test database/table/script :slight_smile:

Yes, cfupdate seems to be ok. I run into problems with date fields (related to this https://luceeserver.atlassian.net/browse/LDEV-1344 ) and assumed that it was because of the problems I faced with cfinsert, but it isn’t. Thanks for sorting this out!

@Gunter, OK YWC :slight_smile:

if you change the table name to a non existent table, i see the same error

logging with sql server profiler, the error we are seeing is caused by

use [];

i.e. the database name isn’t being passed in

Msg 1038, Level 15, State 4, Line 1
An object or column name is missing or empty. For SELECT INTO statements, verify each column has a name. For other statements, look for empty alias names. Aliases defined as "" or [] are not allowed. Change the alias to a valid name.
Msg 911, Level 16, State 1, Line 1
Database '' does not exist. Make sure that the name is entered correctly.

(also posted in jira)

looks like perhaps this commit did it


https://luceeserver.atlassian.net/browse/LDEV-1980

again, database handling changes have been made for a specific database (in this case mysql),
but only test cases for that specific database are added

Like @Zac_Spitzer stated before. It broke somewhere around 21 Sep 2018, so I downgraded Lucee to 5.2.9.31, and it works fine.
This, together with the webservice problem I experienced (CF / Lucee incompatibility for createObject() / SOAP request), it’s safe to say that I better stick with 5.2.9.31 for now.