Lost debug info on 1 website


#1

I recently upgraded from Lucee 4.5 to 5.1.3.18 using a fresh install of 5.1.3.18 and I can’t seem to get debug info on 1 website.

I have 2 websites on the server. Maybe I configured them wrong. Both work nicely except one will show the debug information at the bottom, and log debug info in the administrator, but the other will not. Without an error - it shows my page without debug info - but with any error, It just shows a 500 error page.

In the server admin, I set enable debugging to yes and checked all options.
Under templates I created a debug template and added my server’s ip as well as my desktop ip. (also tried with just * an not limited to ip) I tried classic and modern (each individually). Also tried the web admin using the one for the website that doesn’t show the debug info. Same thing.

Any ideas. The debut info worked for both websites under lucee 4.5. I tried browsing locally also - did not make a difference from browsing remotely


#2

I added another website, and same problem. Can not get debug info. Only a 500 error. Anyone else seeing this?


#3

Anything in the log files?

What Debug Template are you using? Modern? Make sure that the file exists. Remove the debug template and then add it again.


#4

I found the debug templates, and they are all there. I tried all of the choices in the admin panel. No luck.
I found the error logs. I was looking at the wrong logs - found some huge stderr logs. I can use those to figure out the problems I am having.


#5

500 error would normally indicate an issue with the application server.

You might have to disable the HTTP status codes to get the actual error message, fix it, then see whether you can get the debug output.