Log4j2 ConsoleAppender issue after upgrading to 5.3.6.61 from 5.3.3.62

Hi all,

We’re testing 5.3.6.61 at the moment and have noticed that the use of the Log4j2 ConsoleAppender (which we use to write application logs on the Java and CFML side) has stopped working.
If we revert back to 5.3.3.62 then the console logs work just fine.

After the upgrade, only the ConsoleAppender has stopped working - our RollingFileAppender is still working correctly.

We develop using IntelliJ (due to our heavy reliance on Java integration) so we’re not keen to lose our console logs. Is there a change that could have caused this issue? We don’t get many chances to upgrade our stack so I’m hopeful we won’t have to revert!

Cheers!

OS: Windows
Java Version: AdoptOpenJDK 1.8_265-b01
Tomcat Version: Tomcat 9.0.20
Lucee Version: 5.3.6.61

Just tested the 5.3.7.43-RC and 5.3.8.76-SNAPSHOT releases and unfortunately there is still no console logging. I’ll submit a JIRA if no one has any thoughts?

1 Like

any of these commits look responsible?

I think commandbox was having problems with console output and it got fixed?

2 Likes

@valley I’m pretty sure this is a “feature”. There is a new out log in your lucee server context that has all the console logs. Lucee wraps the sytem.out print stream to redirect. I am not a fan of this feature, in fact I argued with Micha about it. You can switch it back by manually editing the <system> portion of your Lucee-server.xml config file where you redirect where the system.out writes to.

I think commandbox was having problems with console output

@Zac_Spitzer To be clear, CommandBox wasn’t having any problems, Lucee was :slight_smile: Redirecting the entire system out was Micha’s fix, but I never thought it was a good fix. It was heavy-handed.

1 Like

Thanks guys, editing the server.xml did the trick.

We actually blow away the default lucee-server.xml as part of our application installer build so the system portion still looked like this after the Lucee upgrade…
<system err="default" out="null"/>
Makes sense that a null value would stop it from working, I presume at some point there was a change to Lucee to have it actually respect the setting, so I can’t be angry :slight_smile:

1 Like

@valley Correct, that setting had been in the XML file for a very long time, but Lucee ignored it! Lucee “fixed” itself a while and suddenly began obeying that setting. When I argued with Micha about it, he agreed to change the default value of the setting in the XML file you get for a new installation of Lucee, but of course, this does not help anyone such as yourself who has an older XML file they are using still. I hit the exact same issue as you where suddenly the setting started working and I was like “Where did my out logs go???”

1 Like