Log Analyzer 2.4.0 beta


#1

Change log for 2.4.0

  • collapse long stack traces
  • wrap long lines
  • add search and reload to view log
  • renamed details to analysis
  • fixed crash viewing individual detail record
  • added page titles
  • always include the plugin stylesheet for each template
  • fixed sortable header colors (clashed with bg)
  • bumped the version to 2.4.0

You can download the .lex file to try it out
https://github.com/zspitzer/lucee-loganalyzer/blob/master/dist/modern/extension-loganalyzer-2.4.0.16.lex

after it’s installed you need to append &alwaysnew=1 to the url so the plug in shows up
due to this bug https://luceeserver.atlassian.net/browse/LDEV-1022


#2

Is there anything special required to get this working besides dropping the lex file in the deploy folder for Lucee to find?

I did exactly that but it keeps getting moved into a failed-deploy folder. Not sure if anything gets logged somewhere when this occurs. I see the bit about appending alwaysnew=1 but is there a specific page to do that on?


#3

you can just upload the lex via the extensions page in the admin (bottom of the page)

There’s a much funkier total v3 rewrite version here, I just haven’t got around to
adding some analysis stuff in as I got distracted


#4

Thanks. I didn’t know about the ability to upload. So after that, do I access it from the link under plugins still? Seems I get a blank page in the admin when clicking that.


#5

yep you access it from the link under plugins

did you try the alwaysnew=1 tick? the behavior with extensions stuff is a bit hit and miss at times,

maybe try restarting lucee?

https://luceeserver.atlassian.net/browse/LDEV-1775


#6

Ok cool. I’ve tried both of your suggestions with no success :frowning:


#7

um, did you have the old version installed? try uninstalling that first


#8

I did have it installed previously and uninstalled it prior to trying this out. I am wondering if having the previous version installed first is what’s causing my issues now.


#9

are you trying it from the web or server admin?

I just tried it on my local dev, the web admin still had the old plugin installed after I removed it from the server admin (but I’d been developing the plugin on that server, so it might be in an inconsistent state


#10

I’m trying from the server admin. I never set it up from the web admin.


#11

are you on win or mac?

this is what my server context plugin directory looks like


#12

Linux :slight_smile: My directory looks the same.


#13

ok, that’s good, so to recap, you’re getting a blank page when you click on the log viewer link under plugins.

Which version of lucee are you running? does the heading Plugins - Log analyzer show, or do you see just nothing?


#14

Correct. I am running 5.2.8.21-SNAPSHOT and I do see heading you describe but there is no content in the body of the page.

Thanks for all of your help so far.


#15

thanks for your patience… as it’s all just cfml, do you wanna try throwing a cfhrow in overview.cfm?


#16

Sure. I’m gonna be turning in for the night here shortly so I’ll follow up with my findings when I get the next chance.


#17

was the url for the blank page the following?

http://127.0.0.1:8888/lucee/admin/server.cfm?action=plugin&plugin=loganalyzer&pluginAction=contextSelector&nextAction=overview

from the server admin, it redirects to that page if there is no context selected, but it only
shows the selector when <cfif request.admintype eq "server"> is true

try dumping out that variable in contextSelector.cfm ?

the underlying assumption is that request.admintype is either web or server


#18

new build is up 3.0.0.20 defaults to the serverContext and shows a warning when adminType isn’t web or server