JDBC driver for MS SQL and Lucee 5.2.7.62 in a docker container


#1

I’m running Lucee 5.2.7.62 in a docker container using this image - https://hub.docker.com/r/lucee/lucee52-nginx/. I’m trying to create a datasource that connects to an MS SQL database. I’m running into the following error when I try to create a datasource that connects to an MS SQL database:

The driver could not establish a secure connection to SQL Server by using Secure Sockets Layer (SSL) encryption. Error: "SQL Server did not return a response.

I tried the following via the Lucee administrator without success:

  • Updated the JDBC driver from Microsoft SQL Server to 6.2.2.jre8 from 4.0 (restarted Lucee and tried to create the datasource).
  • Re-installed the 6.2.2.jre8 driver .

I’m able to create the datasource using the jTDS driver. Should I just use the jTDS driver? What are the downsides (if any) of using the jTDS driver?


#2

googling “SQL Server did not return a response” turns up a lot of results, have you investigated them?


#3

Our database server is on Windows 2003 and it doesn’t support the TLS version that the MS SQL JDBC drivers uses. For now, we’re going to use the jTDS drivers. So far, I haven’t noticed any issues with using jTDS.


#4

You may need to add the datasource definition inside of your application.cfc. I had to do this with MySql and set useSSL=false inside of the JDBC connection string. MSSQL has something similar encrypt=false

https://docs.microsoft.com/en-us/sql/connect/jdbc/connecting-with-ssl-encryption?view=sql-server-2017

It also appears there is an authentication property as well that can be set to NotSpecified. I assume that a combination of these connection properties should get you squared away.

https://docs.microsoft.com/en-us/sql/connect/jdbc/setting-the-connection-properties?view=sql-server-2017