java.lang.StackOverflowError in Lucee Express on Linux and BSD

Hi,

I posted an issue a while back in the Issue Tracker, but haven’t gotten
much traction, so I thought I’d see if anyone here has run into the same
issue and possibly resolved it.

The issue is here:
https://bitbucket.org/lucee/lucee/issue/229/lucee-451000-error

Essentially (at least for me), Lucee Express works on Windows only. The
Linux installer works too.

However, using Lucee Express on CentOS 6.5, Ubuntu 11.10 LTS, and OpenBSD
5.6 have all resulted in the same problem - Tomcat starts, but loading the
main page of Lucee results in a StackOverflowError message.

This also happens with Lucee Express with Jetty, including the latest Jetty
9 described/downloaded here:
https://groups.google.com/forum/#!topic/lucee/Pj70NfcKgZ4

I’m just baffled at what is going wrong since I haven’t seen anyone
describe the problem.

I’m using VMware Workstation 11 for all OS instances, but have also
deployed CentOS on vSphere 5.5 with the same result - as expected.

Eric

I looked at the bitbucket issue and the info is a bit sparse,

a stack overflow is most likely due to an infinite loop. does this happen
witha particular cfml project or just a clean install of Lucee?

also in the past I tried but never manager to get railo (back in the day)
running on openJDK and reverted back to oracle/sun java

HTH

GXOn Wednesday, April 22, 2015 at 3:13:45 AM UTC+3, emi...@genesishosting.com wrote:

Hi,

I posted an issue a while back in the Issue Tracker, but haven’t gotten
much traction, so I thought I’d see if anyone here has run into the same
issue and possibly resolved it.

The issue is here:
https://bitbucket.org/lucee/lucee/issue/229/lucee-451000-error

Essentially (at least for me), Lucee Express works on Windows only. The
Linux installer works too.

However, using Lucee Express on CentOS 6.5, Ubuntu 11.10 LTS, and OpenBSD
5.6 have all resulted in the same problem - Tomcat starts, but loading the
main page of Lucee results in a StackOverflowError message.

This also happens with Lucee Express with Jetty, including the latest
Jetty 9 described/downloaded here:
https://groups.google.com/forum/#!topic/lucee/Pj70NfcKgZ4

I’m just baffled at what is going wrong since I haven’t seen anyone
describe the problem.

I’m using VMware Workstation 11 for all OS instances, but have also
deployed CentOS on vSphere 5.5 with the same result - as expected.

Eric

Thanks for the reply! This happens with a clean install (or rather
download/unzip of the Express version of Lucee), when browsing to
http://<ip_address>:8888/. Of course this works on Linux when using the
installer - it’s the Express version that doesn’t work.

I thought I also tried the Oracle/Sun Java, but I can’t remember, so I’ll
try this as well and report back.

Eric

Ok, I went back to a snapshot that was pre-binary-install of Lucee, so only
Express was unzipped, and I downloaded the jdk of 1.8.0 Update 45 from
Oracle, set all of the environment variables in setenv.sh to point to the
Oracle directories (see below for the contents of the setenv.sh file).

Unfortunately, still getting the stack overflow messages.

Eric

CATALINA_BASE=/lucee/lucee001; export CATALINA_BASE
CATALINA_HOME=/lucee/lucee001; export CATALINA_HOME
CATALINA_PID=/lucee/lucee001/work/tomcat.pid; export CATALINA_PID
CATALINA_TMPDIR=/lucee/lucee001/temp; export CATALINA_TMPDIR
JRE_HOME=/root/jdk1.8.0_45/jre; export JRE_HOME
JAVA_HOME=/root/jdk1.8.0_45; export JAVA_HOME
TOMCAT_OWNER=root; export TOMCAT_OWNER
JAVA_OPTS="-Xms256m -Xmx1024m -XX:MaxPermSize=128m
-javaagent:${CATALINA_HOME}/lib/ext/lucee-inst.jar"; export JAVA_OPTS;

If you’d like to contribute to testing the bundles that will power the
new GUI installers, you can try one of the linux version from here:

http://cfmlprojects.org/artifacts/org/lucee/lucee.tomcat.modcfml.jre/4.5.1.011/

Should be an unzip + run lucee-ctl type of deal, and last I checked it
was working on CentOS 6. (Using the latest 1.7 JRE for now.)

-DenOn 4/24/15 2:44 PM, @emiller wrote:

Ok, I went back to a snapshot that was pre-binary-install of Lucee, so
only Express was unzipped, and I downloaded the jdk of 1.8.0 Update 45
from Oracle, set all of the environment variables in setenv.sh to point
to the Oracle directories (see below for the contents of the setenv.sh
file).

Unfortunately, still getting the stack overflow messages.

Eric

CATALINA_BASE=/lucee/lucee001; export CATALINA_BASE
CATALINA_HOME=/lucee/lucee001; export CATALINA_HOME
CATALINA_PID=/lucee/lucee001/work/tomcat.pid; export CATALINA_PID
CATALINA_TMPDIR=/lucee/lucee001/temp; export CATALINA_TMPDIR
JRE_HOME=/root/jdk1.8.0_45/jre; export JRE_HOME
JAVA_HOME=/root/jdk1.8.0_45; export JAVA_HOME
TOMCAT_OWNER=root; export TOMCAT_OWNER
JAVA_OPTS="-Xms256m -Xmx1024m -XX:MaxPermSize=128m
-javaagent:${CATALINA_HOME}/lib/ext/lucee-inst.jar"; export JAVA_OPTS;


You received this message because you are subscribed to the Google
Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to lucee+unsubscribe@googlegroups.com
mailto:lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com
mailto:lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/886db5b9-d24c-4ffa-9031-5e65df072366%40googlegroups.com
https://groups.google.com/d/msgid/lucee/886db5b9-d24c-4ffa-9031-5e65df072366%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout.

First attempt, after a simple “unzip”, then “./lucee-ctl start”, the service starts, but with a PID error (looks like the wrong directory?):

[root@localhost lucee-tomcat]# ./lucee-ctl start

SET JAVA_HOME to /lucee/lucee-tomcat/jre

Using CATALINA_BASE: /lucee/lucee-tomcat/tomcat

Using CATALINA_HOME: /lucee/lucee-tomcat/tomcat

Using CATALINA_TMPDIR: /lucee/lucee-tomcat/tomcat/temp

Using JRE_HOME: /lucee/lucee-tomcat/jre

Using CLASSPATH: /lucee/lucee-tomcat/tomcat/bin/bootstrap.jar:/lucee/lucee-tomcat/tomcat/bin/tomcat-juli.jar

Using CATALINA_PID: /lucee/lucee-tomcat/tomcatbin/catalina.pid

./bin/catalina.sh: line 410: /lucee/lucee-tomcat/tomcatbin/catalina.pid: No such file or directory

Tomcat started.

[root@localhost lucee-tomcat]# netstat -an | grep 8888

tcp 0 0 :::8888 :::* LISTEN

tcp 0 0 ::ffff:127.0.0.1:8888 ::ffff:127.0.0.1:33668 TIME_WAIT

unix 2 [ ACC ] STREAM LISTENING 48888 /tmp/orbit-root/linc-325a-0-43612daae248c

But this results in the attached screenshot (if the mailing list supports attachments).

Eric

Absolutely! I’m downloading the 64-bit version now and will report back
after playing with it on CentOS 6.5.

Eric

Looks like the PID issue is a simple one - just a missing / in lucee_ctl
(line 10):

function start() {
export CATALINA_PID=$SCRIPT_DIR/tomcatbin/catalina.pid;
cd “$SCRIPT_DIR/tomcat”
./bin/catalina.sh start “$@”
export EXIT_CODE=$?
}>

Sweet, thanks for checking it ou!. I added a fix for the missing / in
the ctl script. The next build will have it.

What do people think about switching to JRE 8 instead of 7?

-DenOn 4/25/15 3:15 PM, @emiller wrote:

Looks like the PID issue is a simple one - just a missing / in lucee_ctl
(line 10):

function start() {
export CATALINA_PID=$SCRIPT_DIR/tomcatbin/catalina.pid;
cd “$SCRIPT_DIR/tomcat”
./bin/catalina.sh start “$@”
export EXIT_CODE=$?
}


You received this message because you are subscribed to the Google
Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to lucee+unsubscribe@googlegroups.com
mailto:lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com
mailto:lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/8a463bf7-11c7-42c4-b5ca-8853dffca6f9%40googlegroups.com
https://groups.google.com/d/msgid/lucee/8a463bf7-11c7-42c4-b5ca-8853dffca6f9%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout.